+1 maintenance report (Nov 25/26)

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

+1 maintenance report (Nov 25/26)

Julian Andres Klode
So I did not keep a log of my activities yesterday, so some stuff
might be missing, but here's what I remember from this weeks +1 shift:

* filed a mass removal bug for obsolete packages with uninstallable
  build-depends (LP: #1905545):
  - edubuntu-menueditor
  - florence (DONE)
  - mp3splt (DONE)
  - pyspeex (DONE)
  - unity-lens-photos
  - kodi-* - kodi is not in hirsute atm, and these addons will need
    changes for next version anyway.....

  Also seb128 deleted gconf-editor and fixed up a unity thingy that
  was in my report after me asking about it :)

  Do we want an automated report for these kinds of packages? No rdeps
  and uninstallable (build-)depends?
* requested xubuntu-docs finally be updated to get rid of its gnome-doc-utils
  build-dep, this is not buildable since bionic ... LP: #1905548
* removed obsolete libdts-dev dep from mythtv
* retriggering all sorts of python related autopkgtests
* added a &delete=1 parameter to request.cgi which allows you
  to delete a request you made before (otherwise same parameters)

-- unsat build-depends in release pocket report (from https://magenta.jak-linux.org/ubuntu-archive/distcheck/hirsute/release.txt) - libjs-xterm is new in there, did somebody demote that? :D

Unsatisfiable build-depends (release sources against release binaries)
===============================================================================
As of release Release file: Thu, 26 Nov 2020 15:04:47 UTC
As of proposed Release file: Thu, 26 Nov 2020 15:05:31 UTC

Packages build-depending on kodi-addons-dev:amd64:
  * kodi-pvr-argustv                         build-depends on missing kodi-addons-dev:amd64 (>= 2:18~)
  * kodi-pvr-dvbviewer                       build-depends on missing kodi-addons-dev:amd64 (>= 2:18~)
  * kodi-pvr-hdhomerun                       build-depends on missing kodi-addons-dev:amd64 (>= 2:18~)
  * kodi-pvr-hts                             build-depends on missing kodi-addons-dev:amd64 (>= 2:18~)
  * kodi-pvr-iptvsimple                      build-depends on missing kodi-addons-dev:amd64 (>= 2:18~)
  * kodi-pvr-mediaportal-tvserver            build-depends on missing kodi-addons-dev:amd64 (>= 2:18~)
  * kodi-pvr-mythtv                          build-depends on missing kodi-addons-dev:amd64 (>= 2:18~)
  * kodi-pvr-nextpvr                         build-depends on missing kodi-addons-dev:amd64 (>= 2:18~)
  * kodi-pvr-njoy                            build-depends on missing kodi-addons-dev:amd64 (>= 2:18~)
  * kodi-pvr-vdr-vnsi                        build-depends on missing kodi-addons-dev:amd64 (>= 2:18~)
  * kodi-pvr-vuplus                          build-depends on missing kodi-addons-dev:amd64 (>= 2:18~)
  * kodi-pvr-wmc                             build-depends on missing kodi-addons-dev:amd64 (>= 2:18~)
  * kodi-visualization-spectrum              build-depends on missing kodi-addons-dev:amd64 (>= 2:18.0~)
  * kodiplatform                             build-depends on missing kodi-addons-dev:amd64 (>= 2:18~)

Packages build-depending on libjs-xterm:amd64:
  * jupyter-notebook                         build-depends on missing libjs-xterm:amd64 (>= 3.8.1-3~)
  * jupyter-sphinx                           build-depends on missing libjs-xterm:amd64 (>= 3.8.1-3~)
  * lmfit-py                                 build-depends on missing libjs-xterm:amd64 (>= 3.8.1-3~)
  * matplotlib                               build-depends on missing libjs-xterm:amd64 (>= 3.8.1-3~)
  * nbconvert                                build-depends on missing libjs-xterm:amd64 (>= 3.8.1-3~)
  * octave-kernel                            build-depends on missing libjs-xterm:amd64 (>= 3.8.1-3~)
  * pandas                                   build-depends on missing libjs-xterm:amd64 (>= 3.8.1-3~)
  * plotly                                   build-depends on missing libjs-xterm:amd64 (>= 3.8.1-3~)
  * sagenb-export                            build-depends on missing libjs-xterm:amd64 (>= 3.8.1-3~)
  * statsmodels                              build-depends on missing libjs-xterm:amd64 (>= 3.8.1-3~)

Packages build-depending on librust*:
  * rust-bat                                 build-depends on missing librust-git2-0.10-dev:amd64
  * rust-kmon                                build-depends on missing librust-tui-0.8+default-dev:amd64
  * rust-markup5ever-rcdom                   build-depends on missing librust-html5ever-0.25+default-dev:amd64

Packages build-depending on python-*:
  * edubuntu-menueditor                      build-depends on missing python-distutils-extra:amd64
  * unity-lens-photos                        build-depends on missing python-distutils-extra:amd64

Packages build-depending on gnome-doc-utils:amd64:
  * xubuntu-docs                             build-depends on missing gnome-doc-utils:amd64

Packages build-depending on golang-*:
  * rclone                                   build-depends on missing golang-github-stretchr-testify-dev:amd64 (>= 1.6.1)

Packages build-depending on grub-efi-amd64-signed:amd64:
  * cd-boot-images-amd64                     build-depends on missing grub-efi-amd64-signed:amd64 (= 1.155+2.04-1ubuntu35)

Packages build-depending on libhivex0:amd64:
  * diffoscope                               build-depends on missing libhivex0:amd64 (>= 1.3.14)

Packages build-depending on libsis-base-java:amd64:
  * libsis-jhdf5-java                        build-depends on missing libsis-base-java:amd64 (>= 18.09~pre1)

Packages build-depending on node-*:
  * node-globby                              build-depends on missing node-braces:amd64 (>= 3.0.2+~3.0.0)

Packages build-depending on supermin:amd64:
  * libguestfs                               build-depends on missing supermin:amd64 (>= 5)

Packages build-depending on wasi-libc:amd64:
  * rustc                                    build-depends on missing wasi-libc:amd64 (<= 0.0~git20200114.1fad338++)

Packages build-depending on xfce4-panel:amd64:
  * vala-panel-appmenu                       build-depends on missing xfce4-panel:amd64 (= 4.14.4-1)


--
debian developer - deb.li/jak | jak-linux.org - free software dev
ubuntu core developer                              i speak de, en

--
ubuntu-devel mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel