+1 maintenance report

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

+1 maintenance report

Bryce Harrington-8
This was my week's rotation on +1 maintenance.  There are several
transitions in process, it doesn't look like they're conflicting with
each other so much as just taxing the runners (particularly on armhf and
ppc64el).



### Stats ###

Monday:     1398 update excuse records found
Tuesday:    1262 update excuse records found
Wednesday:  1114 update excuse records found
Thursday:   1068 update excuse records found
Friday:     1018 update excuse records found



### Ruby ###

Lucas mentioned that he fixed rubygems in debian and now the ruby stack
could be retriggered.  I did so, with triggers for the proposed versions
of rubygems, ruby-defaults, icu, and libxml.  Unfortunately, that seems
not to be sufficient.  The logs for the various ruby packages show
errors about not being able to find specific gems or the rubygems
package in general.

As an experiment, I tried a no-change rebuild of ruby-bootsnap, but it
FTBFS on all arch's.  I verified it is building with the new rubygems
and gem2deb packages.

Checking with Lucas, he said, "I would go through the dependencies chain
and check if they were built with gem2deb 1.4.  Maybe something is
missing it."


### PHP ###

* php7.4 was blocking apparmor (and later openssl) due to unsatisfied
  dependencies on i386.  I retriggered with icu, openssl, and a dozen
  other packages which seems to have resolved it (some tests still in
  progress though).

* php8.0 was in the archive, due to autosync from Debian.  We aren't
  planning for PHP 8.0 this cycle so we've removed it for 21.04 and
  blocked it from syncing.

* php-horde-ansel:  We removed php-horde* in focal, but this seems to be
  a remnant that popped up via autosync.  Filed LP: #1907705 to have it
  removed.

* php-phar-io-manifest / php-phar-io-version: Just needed triggered
  together, along with phpunit.

* php-token-stream: Also needed retriggered against php-phar-io* and
  phpunit

* phpunit: Also needed retriggered against php-phar-io* and phpunit, and
  symfony

While the above retriggers worked, there were failures still on i386,
although not sure that will cause problems migrating.  If they do, we
may want to look closer at supportability of php on i386 more generally.



### R-Bioc-* ###

There's a bunch of r-bioc-* packages in update-excuses.  I did a heavy
amount of retriggering, which seems to have resolved _some_ issues, but
most of the packages are still blocked until r-bioc-biocgenerics
migrates, and r-bioc-biocgenerics is blocking on six packages:

  - r-bioc-genomeinfodb
  - r-bioc-annotationhub
  - r-bioc-delayedarray
  - r-bioc-delayedmatrixstats
  - r-bioc-dropletutils
  - r-bioc-shortread

r-bioc-genomeinfodb is failing because it's trying to access the web
during its unit tests (ftp.ncbi.nlm.nih.gov port 21 specifically).  It
may need to be reconfigured to not do that, or else have its test(s)
skipped (i.e. maybe add hint force-badtest?)

r-bioc-annotationhub complains about an invalid cache for
sqlite, and asks to run with localHub=False.  This sounds like it might
also be a "can't access the web" situation (see
https://support.bioconductor.org/p/127555/).

r-bioc-delayedarray and r-bioc-delayedmatrixstats show warnings and
errors about invalid data types.  Might be ordinary test failures but
googling reveals nothing on them.  I kind of wonder if these too are
needing data or packages from the web and just lack code to handle that
error.

r-bioc-dropletutils (arm64) looks more like a platform data type
discrepancy.  "Objects equal but not identical".  Googling turned up
https://github.com/r-lib/testthat/issues/920 that if used might give
more debuggable information here.

r-bioc-shortread (amd64) complains of an undefined superclass.  Googling
showed a hint that this may need a newer Biobase, so maybe retriggering
this against hirsute-propose's r-bioc-biobase/2.50.0-1 would resolve
it.  If not, maybe there is a patch in r-bioc-biobase master to cherrypick.


### crmsh / pacemaker ###

Retriggered together plus with lxml and some py deps in -proposed, and
they seem happy now.



### Package Rebuilds ###

These FTBFS resolved by just a rebuild:

  - limnoria
  - python-casacore
  - mousetweaks
  - pqiv
  - perl6-zef
  - herbstluftwm
  - node-jsonld
  - puppetlabs-ring-middleware-clojure
  - netplan.io
  - sahara
  - python-sqlalchemy-utils
  - placement
  - intel-media-driver-non-free 20.4.2+ds1-1


### Retriggers ###

These all passed with just a simple retriggering:

  - aptdaemon (amd64)
  - arrayfire (armhf)
  - asterisk (ppc64el)
  - augur (amd64)
  - bambam (arm64)
  - deal.ii (ppc64el)
  - dgit (armhf)
  - fmtlib (arm64)
  - golang-github-containerd-cgroups (ppc64el)
  - golang-github-dchest-uniuri (s390x)
  - golang-github-emersion-go-imap (arm64)
  - golang-github-farsightsec-go-nmsg (armhf)
  - golang-github-fluffle-goirc (armhf)
  - golang-golang-x-text (amd64)
  - golang-golang-x-net (arm64)
  - golang-honnef-go-tools (amd64)
  - golang-logrus (armhf)
  - golang-testify (ppc64el)
  - haveged (ppc64el)
  - heat (s390x)
  - kas (armhf)
  - kdiagram (armhf)
  - lintian-brush (amd64)
  - lua-http (arm64)
  - node-jsprim (armhf)
  - node-merge (armhf)
  - nodejs (armhf)
  - open-iscsi (i386)
  - openssh (s390x)
  - php-mail (ppc64el)
  - phpunit-recursion-context (armhf)
  - poliastro (armhf)
  - psqlodbc (ppc64el)
  - python-qtconsole (amd64)
  - python-transitions (amd64)
  - r-bioc-biocfilecache (armhf)
  - r-bioc-sparsematrixstats (armhf)
  - r-bioc-singlecellexperiment (amd64)
  - r-bioc-genomicalignments (arm64)
  - r-cran-png (armhf)
  - r-bioc-singler (armhf)
  - r-bioc-aroma.light (amd64)
  - r-cran-spacetime (armhf)
  - r-cran-stringi
  - runescape (armhf)
  - salt (ppc64el)
  - slime (amd64)
  - ssl-cert (armhf)
  - syncthing (amd64)
  - txzmq (armhf)
  - ubuntu-release-upgrader (armhf)
  - libvcflib (amd64)
  - zimlib (ppc64el)


### Retriggered timeouts ###

These mentioned 'FAIL timed out' in their log, so attempted retriggers
for them too:

  - bordeaux-threads (amd64)
  - lintian (amd64 armhf)
  - aptdaemon (armhf)
  - firewalld (arm64)
  - chrony (armhf)
  - macaulay2 (amd64)
  - mysql-8.0 (i386)
  - beets (arm64 amd64)
  - joblib (arm64)
  - dolfin (armhf)
  - gscan2pdf (amd64 s390x)
  - puma (arm64)
  - openvswitch (arm64 ppc64el amd64 s390x)
  - golang-github-azure-azure-sdk-for-go (armhf)

I think those all pass now.  If not, might look at if they need marked
as long_test or something.


### Remaining Work ###

The rest of these I ran out of time to work on, but can share hunches on
what's wrong and/or what needs done.

* tifffile (s390x)
  - A patch for this is available upstream, see
    https://github.com/cgohlke/tifffile/issues/18

* cura FTBFS
  - https://launchpad.net/ubuntu/+source/cura/4.7.1-2/+build/20202491
  - Failed on code style test.
  - See https://github.com/Ultimaker/Cura/issues/8817
  - See https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=973230
  - Patch upstream to fix it at
    https://github.com/Ultimaker/Cura/commit/00bc1bfcdc960d4bad62adc4b1615ca4cc6b3cee

* r-cran-projpred (riscv64)
  - https://launchpad.net/ubuntu/+source/r-cran-projpred/2.0.2+dfsg-1/+build/20320580
  - FTBFS due to missing build dep on nodejs.  nodejs's control file
    specifies the exact arch's it supports, and riscv64 is not listed.
    I suppose either it needs added, or set to 'any', or
    r-cran-projpred's control needs modified to list the exact arch's
    rather than 'Architecture: any'

* cargo FTBFS on riscv64
  - [crossbeam-utils 0.7.2] error[E0412]: cannot find type `AtomicU128` in module `core::sync::atomic`
    [crossbeam-utils 0.7.2] For more information about this error, try `rustc --explain E0412`.
  - Build failure was cargo 0.47.0-1~exp1ubuntu1 built with rustc
    (1.43.0+dfsg1+llvm-1~exp1ubuntu2)
  - Possibly relates to LP: #1901571 - firefox 85 requires rustc 1.47
    and cargo 0.47
  - Maybe cargo needs its rustc version requirement bumped?

* dfwinreg
  - https://launchpad.net/ubuntu/+source/dfwinreg/20201006-1/+build/20369376
  - Missing build dep pycreg (deb #976653)

* node-yarnpkg 1.22.4-5 (amd64)
  - https://launchpad.net/ubuntu/+source/node-yarnpkg/1.22.4-5/+build/20382448
  - "Error: Cannot find module 'babel-core'"
  - I'm not certain but I suspect this needs babel-core v7, but v6 is in
    Debian.  Or something.  See:
    + https://github.com/babel/babel/issues/10688
    + https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=941700
    + https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=958780

* php-league-html-to-markdown (s390x)
  - Retriggered with phpunit, php-shellcommand, and php-phar-io*
  - https://autopkgtest.ubuntu.com/packages/php-league-html-to-markdown/hirsute/s390x
  - Still failing though.

* golang-github-revel-revel 1.0.0-1
  - https://launchpadlibrarian.net/510431363/buildlog_ubuntu-hirsute-amd64.golang-github-revel-revel_1.0.0-1_BUILDING.txt.gz
  - Is trying to access external resource (http://httpbin.org/get)

Bryce

--
ubuntu-devel mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel