Quantcast

[Bug 1422417] [NEW] ceph radosgw needs mod-proxy-fcgi for apache 2.2

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 1422417] [NEW] ceph radosgw needs mod-proxy-fcgi for apache 2.2

Launchpad Bug Tracker-318
Public bug reported:

In the past, upstream Ceph has provided a forked and self-packaged mod-
fastcgi deb.  Some potential license issues have been identified that
prevent us from distributing this package going forward.

Unfortunately mod-proxy-fcgi is not available for apache 2.2 (shipped in
precise).  We have created a backport, available at

  https://github.com/ceph/mod-proxy-fcgi

Ideally this backport would be provided in the precise backports
repository so that Ceph users can deploy Ceph radosgw without any
additional repos.

Note that this isn't pulled from the development release because that
ships Apache 2.4, which supports this module natively.  2.4 is not
available for precise.

Please let us know if this is an acceptable use of backports before we
do the (non-trivial) packaging.  Thanks!

** Affects: precise-backports
     Importance: Undecided
         Status: New

--
You received this bug notification because you are a member of Ubuntu
Backporters, which is subscribed to Precise Backports.
https://bugs.launchpad.net/bugs/1422417

Title:
  ceph radosgw needs mod-proxy-fcgi for apache 2.2

To manage notifications about this bug go to:
https://bugs.launchpad.net/precise-backports/+bug/1422417/+subscriptions

--
ubuntu-backports mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-backports
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 1422417] Re: ceph radosgw needs mod-proxy-fcgi for apache 2.2

James Page-4
After some discussion with Laney on irc, we'll also need to SRU a fix
into the Apache2 package for 14.04 to allow upgrades with this new
backport package to work correctly, as apache2-bin will need to
Break/Replace libapach2-mod-proxy-fcgi.

** Also affects: apache2 (Ubuntu)
   Importance: Undecided
       Status: New

** Also affects: apache2 (Ubuntu Trusty)
   Importance: Undecided
       Status: New

** Changed in: apache2 (Ubuntu)
       Status: New => Invalid

--
You received this bug notification because you are a member of Ubuntu
Backporters, which is subscribed to Precise Backports.
https://bugs.launchpad.net/bugs/1422417

Title:
  ceph radosgw needs mod-proxy-fcgi for apache 2.2

To manage notifications about this bug go to:
https://bugs.launchpad.net/precise-backports/+bug/1422417/+subscriptions

--
ubuntu-backports mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-backports
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 1422417] Re: ceph radosgw needs mod-proxy-fcgi for apache 2.2

Scott Kitterman-3
In reply to this post by Launchpad Bug Tracker-318
As long as 12.04 + backports -> 14.04 upgrades work, I think this is
reasonable.  I'd prefer someone other than me on the SRU team to make
the call on the SRU piece of this though.

--
You received this bug notification because you are a member of Ubuntu
Backporters, which is subscribed to Precise Backports.
https://bugs.launchpad.net/bugs/1422417

Title:
  ceph radosgw needs mod-proxy-fcgi for apache 2.2

To manage notifications about this bug go to:
https://bugs.launchpad.net/precise-backports/+bug/1422417/+subscriptions

--
ubuntu-backports mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-backports
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 1422417] Re: ceph radosgw needs mod-proxy-fcgi for apache 2.2

Launchpad Bug Tracker-318
In reply to this post by Launchpad Bug Tracker-318
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: apache2 (Ubuntu Trusty)
       Status: New => Confirmed

--
You received this bug notification because you are a member of Ubuntu
Backporters, which is subscribed to Precise Backports.
https://bugs.launchpad.net/bugs/1422417

Title:
  ceph radosgw needs mod-proxy-fcgi for apache 2.2

To manage notifications about this bug go to:
https://bugs.launchpad.net/precise-backports/+bug/1422417/+subscriptions

--
ubuntu-backports mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-backports
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 1422417] Re: ceph radosgw needs mod-proxy-fcgi for apache 2.2

Launchpad Bug Tracker-318
In reply to this post by Launchpad Bug Tracker-318
Looking forward to this

--
You received this bug notification because you are a member of Ubuntu
Backporters, which is subscribed to Precise Backports.
https://bugs.launchpad.net/bugs/1422417

Title:
  ceph radosgw needs mod-proxy-fcgi for apache 2.2

To manage notifications about this bug go to:
https://bugs.launchpad.net/precise-backports/+bug/1422417/+subscriptions

--
ubuntu-backports mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-backports
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 1422417] Re: ceph radosgw needs mod-proxy-fcgi for apache 2.2

Ken Dreyer (Red Hat)
In reply to this post by Launchpad Bug Tracker-318
We're going to remove support for FCGI in RGW:
http://tracker.ceph.com/issues/16784, so we won't need this bug any
more.

--
You received this bug notification because you are a member of Ubuntu
Backporters, which is subscribed to Precise Backports.
https://bugs.launchpad.net/bugs/1422417

Title:
  ceph radosgw needs mod-proxy-fcgi for apache 2.2

To manage notifications about this bug go to:
https://bugs.launchpad.net/precise-backports/+bug/1422417/+subscriptions

--
ubuntu-backports mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-backports
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 1422417] Re: ceph radosgw needs mod-proxy-fcgi for apache 2.2

Launchpad Bug Tracker-318
In reply to this post by Launchpad Bug Tracker-318
Thanks. Let's close the bug then, so it's clear that nobody is expecting
this to ever happen in Trusty. The bug is valid, so rather than Invalid
I'll mark it Won't Fix (as we don't intend to fix it).

This isn't intended to exclude anyone else doing it. If you want to work
on this, please raise it in this bug and we can reopen.

--
You received this bug notification because you are a member of Ubuntu
Backporters, which is subscribed to Precise Backports.
https://bugs.launchpad.net/bugs/1422417

Title:
  ceph radosgw needs mod-proxy-fcgi for apache 2.2

To manage notifications about this bug go to:
https://bugs.launchpad.net/precise-backports/+bug/1422417/+subscriptions

--
ubuntu-backports mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-backports
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 1422417] Re: ceph radosgw needs mod-proxy-fcgi for apache 2.2

Launchpad Bug Tracker-318
In reply to this post by Launchpad Bug Tracker-318
(still subject to SRU team approval, etc)

** Changed in: apache2 (Ubuntu Trusty)
       Status: Confirmed => Won't Fix

--
You received this bug notification because you are a member of Ubuntu
Backporters, which is subscribed to Precise Backports.
https://bugs.launchpad.net/bugs/1422417

Title:
  ceph radosgw needs mod-proxy-fcgi for apache 2.2

To manage notifications about this bug go to:
https://bugs.launchpad.net/precise-backports/+bug/1422417/+subscriptions

--
ubuntu-backports mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-backports
Loading...