[Bug 1581643] [NEW] Please backport gramps 4.2.3~dfsg-1 (universe) from yakkety

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug 1581643] [NEW] Please backport gramps 4.2.3~dfsg-1 (universe) from yakkety

Ross Gammon-2
Public bug reported:

Please backport gramps 4.2.3~dfsg-1 (universe) from yakkety to trusty,
xenial.

Reason for the backport:
========================
To have the latest Gramps from the 4.x.y upstream branch in all possible LTS releases.

Testing:
========
Mark off items in the checklist [X] as you test them, but please leave the checklist so that backporters can quickly evaluate the state of testing.

You can test-build the backport in your PPA with backportpackage:
$ backportpackage -u ppa:<lp username>/<ppa name> -s yakkety -d trusty gramps
$ backportpackage -u ppa:<lp username>/<ppa name> -s yakkety -d xenial gramps

* trusty:
[ ] Package builds without modification
[ ] gramps installs cleanly and runs
* xenial:
[ ] Package builds without modification
[ ] gramps installs cleanly and runs

Reverse dependencies:
=====================
The following reverse-dependencies need to be tested against the new version of gramps. For reverse-build-dependencies (-Indep), please test that the package still builds against the new gramps. For reverse-dependencies, please test that the version of the package currently in the release still works with the new gramps installed. Reverse- Recommends, Suggests, and Enhances don't need to be tested, and are listed for completeness-sake.

gramps
------
* edubuntu-desktop
  [ ] trusty (Reverse-Recommends)
  [ ] xenial (Reverse-Recommends)

** Affects: trusty-backports
     Importance: Undecided
     Assignee: Ross Gammon (rosco2)
         Status: New

** Affects: xenial-backports
     Importance: Undecided
     Assignee: Ross Gammon (rosco2)
         Status: New

** Changed in: xenial-backports
     Assignee: (unassigned) => Ross Gammon (rosco2)

** Changed in: trusty-backports
     Assignee: (unassigned) => Ross Gammon (rosco2)

--
You received this bug notification because you are a member of Ubuntu
Backporters, which is subscribed to trusty-backports.
Matching subscriptions: ubuntu-backporters
https://bugs.launchpad.net/bugs/1581643

Title:
  Please backport gramps 4.2.3~dfsg-1 (universe) from yakkety

To manage notifications about this bug go to:
https://bugs.launchpad.net/trusty-backports/+bug/1581643/+subscriptions

--
ubuntu-backports mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-backports
Reply | Threaded
Open this post in threaded view
|

[Bug 1581643] Re: Please backport gramps 4.2.3~dfsg-1 (universe) from yakkety

Ross Gammon-2
** Description changed:

  Please backport gramps 4.2.3~dfsg-1 (universe) from yakkety to trusty,
  xenial.
 
  Reason for the backport:
  ========================
  To have the latest Gramps from the 4.x.y upstream branch in all possible LTS releases.
 
  Testing:
  ========
  Mark off items in the checklist [X] as you test them, but please leave the checklist so that backporters can quickly evaluate the state of testing.
 
  You can test-build the backport in your PPA with backportpackage:
  $ backportpackage -u ppa:<lp username>/<ppa name> -s yakkety -d trusty gramps
  $ backportpackage -u ppa:<lp username>/<ppa name> -s yakkety -d xenial gramps
 
  * trusty:
  [ ] Package builds without modification
  [ ] gramps installs cleanly and runs
  * xenial:
- [ ] Package builds without modification
+ [X] Package builds without modification
  [ ] gramps installs cleanly and runs
 
  Reverse dependencies:
  =====================
  The following reverse-dependencies need to be tested against the new version of gramps. For reverse-build-dependencies (-Indep), please test that the package still builds against the new gramps. For reverse-dependencies, please test that the version of the package currently in the release still works with the new gramps installed. Reverse- Recommends, Suggests, and Enhances don't need to be tested, and are listed for completeness-sake.
 
  gramps
  ------
  * edubuntu-desktop
-   [ ] trusty (Reverse-Recommends)
-   [ ] xenial (Reverse-Recommends)
+   [ ] trusty (Reverse-Recommends)
+   [ ] xenial (Reverse-Recommends)

--
You received this bug notification because you are a member of Ubuntu
Backporters, which is subscribed to trusty-backports.
Matching subscriptions: ubuntu-backporters
https://bugs.launchpad.net/bugs/1581643

Title:
  Please backport gramps 4.2.3~dfsg-1 (universe) from yakkety

To manage notifications about this bug go to:
https://bugs.launchpad.net/trusty-backports/+bug/1581643/+subscriptions

--
ubuntu-backports mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-backports
Reply | Threaded
Open this post in threaded view
|

[Bug 1581643] Re: Please backport gramps 4.2.3~dfsg-1 (universe) from yakkety

Ross Gammon-2
In reply to this post by Ross Gammon-2
** Description changed:

  Please backport gramps 4.2.3~dfsg-1 (universe) from yakkety to trusty,
  xenial.
 
  Reason for the backport:
  ========================
  To have the latest Gramps from the 4.x.y upstream branch in all possible LTS releases.
 
  Testing:
  ========
  Mark off items in the checklist [X] as you test them, but please leave the checklist so that backporters can quickly evaluate the state of testing.
 
  You can test-build the backport in your PPA with backportpackage:
  $ backportpackage -u ppa:<lp username>/<ppa name> -s yakkety -d trusty gramps
  $ backportpackage -u ppa:<lp username>/<ppa name> -s yakkety -d xenial gramps
 
  * trusty:
- [ ] Package builds without modification
+ [ ] Package builds without modification (UPDATE: gramps not building in Trusty due to missing python3-django & python3-nose-exclude dependencies)
  [ ] gramps installs cleanly and runs
  * xenial:
  [X] Package builds without modification
- [ ] gramps installs cleanly and runs
+ [X] gramps installs cleanly and runs
 
  Reverse dependencies:
  =====================
  The following reverse-dependencies need to be tested against the new version of gramps. For reverse-build-dependencies (-Indep), please test that the package still builds against the new gramps. For reverse-dependencies, please test that the version of the package currently in the release still works with the new gramps installed. Reverse- Recommends, Suggests, and Enhances don't need to be tested, and are listed for completeness-sake.
 
  gramps
  ------
  * edubuntu-desktop
    [ ] trusty (Reverse-Recommends)
-   [ ] xenial (Reverse-Recommends)
+   [ ] xenial (Reverse-Recommends) - Edubuntu was not an official Xenial Release Flavour, so I am not able to do a fresh install. In any case, this is just a metapackage, so it only installs gramps as well as lots of other packages.

** Description changed:

  Please backport gramps 4.2.3~dfsg-1 (universe) from yakkety to trusty,
  xenial.
 
  Reason for the backport:
  ========================
  To have the latest Gramps from the 4.x.y upstream branch in all possible LTS releases.
 
  Testing:
  ========
  Mark off items in the checklist [X] as you test them, but please leave the checklist so that backporters can quickly evaluate the state of testing.
 
  You can test-build the backport in your PPA with backportpackage:
  $ backportpackage -u ppa:<lp username>/<ppa name> -s yakkety -d trusty gramps
  $ backportpackage -u ppa:<lp username>/<ppa name> -s yakkety -d xenial gramps
 
  * trusty:
  [ ] Package builds without modification (UPDATE: gramps not building in Trusty due to missing python3-django & python3-nose-exclude dependencies)
  [ ] gramps installs cleanly and runs
  * xenial:
  [X] Package builds without modification
  [X] gramps installs cleanly and runs
 
  Reverse dependencies:
  =====================
  The following reverse-dependencies need to be tested against the new version of gramps. For reverse-build-dependencies (-Indep), please test that the package still builds against the new gramps. For reverse-dependencies, please test that the version of the package currently in the release still works with the new gramps installed. Reverse- Recommends, Suggests, and Enhances don't need to be tested, and are listed for completeness-sake.
 
  gramps
  ------
  * edubuntu-desktop
    [ ] trusty (Reverse-Recommends)
-   [ ] xenial (Reverse-Recommends) - Edubuntu was not an official Xenial Release Flavour, so I am not able to do a fresh install. In any case, this is just a metapackage, so it only installs gramps as well as lots of other packages.
+   [-] xenial (Reverse-Recommends) - Edubuntu was not an official Xenial Release Flavour, so I am not able to do a fresh install. In any case, this is just a metapackage, so it only installs gramps as well as lots of other packages.

** Changed in: xenial-backports
       Status: New => Confirmed

--
You received this bug notification because you are a member of Ubuntu
Backporters, which is subscribed to trusty-backports.
Matching subscriptions: ubuntu-backporters
https://bugs.launchpad.net/bugs/1581643

Title:
  Please backport gramps 4.2.3~dfsg-1 (universe) from yakkety

To manage notifications about this bug go to:
https://bugs.launchpad.net/trusty-backports/+bug/1581643/+subscriptions

--
ubuntu-backports mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-backports
Reply | Threaded
Open this post in threaded view
|

[Bug 1581643] Re: Please backport gramps 4.2.3~dfsg-1 (universe) from yakkety

Ross Gammon-2
In reply to this post by Ross Gammon-2
Due to the missing dependencies in Trusty, I will only look after
backports to Xenial now. Updated the description.

** Changed in: trusty-backports
     Assignee: Ross Gammon (rosco2) => (unassigned)

** No longer affects: trusty-backports

** Description changed:

- Please backport gramps 4.2.3~dfsg-1 (universe) from yakkety to trusty,
- xenial.
+ Please backport gramps 4.2.3~dfsg-1 (universe) from yakkety to xenial.
 
  Reason for the backport:
  ========================
  To have the latest Gramps from the 4.x.y upstream branch in all possible LTS releases.
 
  Testing:
  ========
  Mark off items in the checklist [X] as you test them, but please leave the checklist so that backporters can quickly evaluate the state of testing.
 
  You can test-build the backport in your PPA with backportpackage:
- $ backportpackage -u ppa:<lp username>/<ppa name> -s yakkety -d trusty gramps
  $ backportpackage -u ppa:<lp username>/<ppa name> -s yakkety -d xenial gramps
 
- * trusty:
- [ ] Package builds without modification (UPDATE: gramps not building in Trusty due to missing python3-django & python3-nose-exclude dependencies)
- [ ] gramps installs cleanly and runs
  * xenial:
  [X] Package builds without modification
  [X] gramps installs cleanly and runs
 
  Reverse dependencies:
  =====================
  The following reverse-dependencies need to be tested against the new version of gramps. For reverse-build-dependencies (-Indep), please test that the package still builds against the new gramps. For reverse-dependencies, please test that the version of the package currently in the release still works with the new gramps installed. Reverse- Recommends, Suggests, and Enhances don't need to be tested, and are listed for completeness-sake.
 
  gramps
  ------
  * edubuntu-desktop
-   [ ] trusty (Reverse-Recommends)
-   [-] xenial (Reverse-Recommends) - Edubuntu was not an official Xenial Release Flavour, so I am not able to do a fresh install. In any case, this is just a metapackage, so it only installs gramps as well as lots of other packages.
+ [-] xenial (Reverse-Recommends) - Edubuntu was not an official Xenial Release Flavour, so I am not able to do a fresh install. In any case, this is just a metapackage, so it only installs gramps as well as lots of other packages.

--
You received this bug notification because you are a member of Ubuntu
Backporters, which is subscribed to trusty-backports.
Matching subscriptions: ubuntu-backporters
https://bugs.launchpad.net/bugs/1581643

Title:
  Please backport gramps 4.2.3~dfsg-1 (universe) from yakkety

To manage notifications about this bug go to:
https://bugs.launchpad.net/xenial-backports/+bug/1581643/+subscriptions

--
ubuntu-backports mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-backports
Reply | Threaded
Open this post in threaded view
|

[Bug 1581643] [NEW] Please backport gramps 5.0.1-1 (universe) from disco

Launchpad Bug Tracker-349
In reply to this post by Ross Gammon-2
You have been subscribed to a public bug by Ross Gammon (rosco2):

Please backport gramps 5.0.1-1 (universe) from disco to cosmic.

Reason for the backport:
========================
To have the latest Gramps from the 5.0 upstream branch in the latest Ubuntu releases. Gramps 5.0 allows the use of an SQL database back end in addition to the traditional BSDDB.

Please note that the Gramps code is currently not relocatable, and
thereofre it is not possible to distribute Gramps as a wheel (pip),
flatpak, or snap.

Testing:
========
Mark off items in the checklist [X] as you test them, but please leave the checklist so that backporters can quickly evaluate the state of testing.

You can test-build the backport in your PPA with backportpackage:
$ backportpackage -u ppa:<lp username>/<ppa name> -s disco -d cosmic gramps

* cosmic:
[X] Package builds without modification
[X] gramps installs cleanly and runs

Reverse dependencies:
=====================
The following reverse-dependencies need to be tested against the new version of gramps. For reverse-build-dependencies (-Indep), please test that the package still builds against the new gramps. For reverse-dependencies, please test that the version of the package currently in the release still works with the new gramps installed. Reverse- Recommends, Suggests, and Enhances don't need to be tested, and are listed for completeness-sake.

gramps
------
None.

-----------------------------------------------------------------------------

Please backport gramps 5.0.1-1 (universe) from disco to bionic.

Reason for the backport:
========================
To have the latest Gramps from the 5.0 upstream branch in the latest Ubuntu releases. Gramps 5.0 allows the use of an SQL database back end in addition to the traditional BSDDB.

Please note that the Gramps code is currently not relocatable, and
thereofre it is not possible to distribute Gramps as a wheel (pip),
flatpak, or snap.

Testing:
========
Mark off items in the checklist [X] as you test them, but please leave the checklist so that backporters can quickly evaluate the state of testing.

You can test-build the backport in your PPA with backportpackage:
$ backportpackage -u ppa:<lp username>/<ppa name> -s disco -d bionic gramps

* bionic:
[X] Package builds without modification
[X] gramps installs cleanly and runs

Reverse dependencies:
=====================
The following reverse-dependencies need to be tested against the new version of gramps. For reverse-build-dependencies (-Indep), please test that the package still builds against the new gramps. For reverse-dependencies, please test that the version of the package currently in the release still works with the new gramps installed. Reverse- Recommends, Suggests, and Enhances don't need to be tested, and are listed for completeness-sake.

gramps
------
* edubuntu-desktop
[-] bionic (Reverse-Recommends) - Edubuntu is no longer an official Release Flavour, so I am not able to do a fresh install. In any case, this is just a metapackage, so it only installs gramps as well as lots of other packages.

** Affects: bionic-backports
     Importance: Undecided
         Status: New

** Affects: xenial-backports
     Importance: Undecided
         Status: Invalid

** Affects: zesty-backports
     Importance: Undecided
         Status: Invalid


** Tags: cosmic
--
Please backport gramps 5.0.1-1 (universe) from disco
https://bugs.launchpad.net/bugs/1581643
You received this bug notification because you are a member of Ubuntu Backporters, which is subscribed to the bug report.

--
ubuntu-backports mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-backports
Reply | Threaded
Open this post in threaded view
|

[Bug 1581643] [NEW] Please backport gramps 5.0.1-1 (universe) from disco

Launchpad Bug Tracker-349
In reply to this post by Ross Gammon-2
You have been subscribed to a public bug by Ross Gammon (rosco2):

Please backport gramps 5.0.1-1 (universe) from disco to cosmic.

Reason for the backport:
========================
To have the latest Gramps from the 5.0 upstream branch in the latest Ubuntu releases. Gramps 5.0 allows the use of an SQL database back end in addition to the traditional BSDDB.

Please note that the Gramps code is currently not relocatable, and
thereofre it is not possible to distribute Gramps as a wheel (pip),
flatpak, or snap.

Testing:
========
Mark off items in the checklist [X] as you test them, but please leave the checklist so that backporters can quickly evaluate the state of testing.

You can test-build the backport in your PPA with backportpackage:
$ backportpackage -u ppa:<lp username>/<ppa name> -s disco -d cosmic gramps

* cosmic:
[X] Package builds without modification
[X] gramps installs cleanly and runs

Reverse dependencies:
=====================
The following reverse-dependencies need to be tested against the new version of gramps. For reverse-build-dependencies (-Indep), please test that the package still builds against the new gramps. For reverse-dependencies, please test that the version of the package currently in the release still works with the new gramps installed. Reverse- Recommends, Suggests, and Enhances don't need to be tested, and are listed for completeness-sake.

gramps
------
None.

-----------------------------------------------------------------------------

Please backport gramps 5.0.1-1 (universe) from disco to bionic.

Reason for the backport:
========================
To have the latest Gramps from the 5.0 upstream branch in the latest Ubuntu releases. Gramps 5.0 allows the use of an SQL database back end in addition to the traditional BSDDB.

Please note that the Gramps code is currently not relocatable, and
thereofre it is not possible to distribute Gramps as a wheel (pip),
flatpak, or snap.

Testing:
========
Mark off items in the checklist [X] as you test them, but please leave the checklist so that backporters can quickly evaluate the state of testing.

You can test-build the backport in your PPA with backportpackage:
$ backportpackage -u ppa:<lp username>/<ppa name> -s disco -d bionic gramps

* bionic:
[X] Package builds without modification
[X] gramps installs cleanly and runs

Reverse dependencies:
=====================
The following reverse-dependencies need to be tested against the new version of gramps. For reverse-build-dependencies (-Indep), please test that the package still builds against the new gramps. For reverse-dependencies, please test that the version of the package currently in the release still works with the new gramps installed. Reverse- Recommends, Suggests, and Enhances don't need to be tested, and are listed for completeness-sake.

gramps
------
* edubuntu-desktop
[-] bionic (Reverse-Recommends) - Edubuntu is no longer an official Release Flavour, so I am not able to do a fresh install. In any case, this is just a metapackage, so it only installs gramps as well as lots of other packages.

** Affects: bionic-backports
     Importance: Undecided
         Status: New

** Affects: xenial-backports
     Importance: Undecided
         Status: Invalid

** Affects: zesty-backports
     Importance: Undecided
         Status: Invalid


** Tags: cosmic
--
Please backport gramps 5.0.1-1 (universe) from disco
https://bugs.launchpad.net/bugs/1581643
You received this bug notification because you are a member of Ubuntu Backporters, which is subscribed to the bug report.

--
ubuntu-backports mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-backports