[Bug 50840] scilab 4

classic Classic list List threaded Threaded
14 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug 50840] scilab 4

89c51
Public bug reported:

request for scilab 4

** Affects: dapper-backports (upstream)
     Importance: Untriaged
         Status: Unconfirmed

--
scilab 4
https://launchpad.net/bugs/50840

--
ubuntu-backports mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-backports
Reply | Threaded
Open this post in threaded view
|

[Bug 50840] Re: scilab 4

John Dong
Not currently in Edgy repository. Marking as "Needs Info"

** Changed in: dapper-backports (upstream)
       Status: Unconfirmed => Needs Info

** Also affects: scilab (Ubuntu)
   Importance: Untriaged
       Status: Unconfirmed

--
scilab 4
https://launchpad.net/bugs/50840

--
ubuntu-backports mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-backports
Reply | Threaded
Open this post in threaded view
|

[Bug 50840] Re: scilab 4

John Dong
In reply to this post by 89c51
Subscribing source package scilab -- when you guys get the chance, there
is a request for a newer scilab in edgy.

** Changed in: scilab (Ubuntu)
       Status: Unconfirmed => Confirmed

--
scilab 4
https://launchpad.net/bugs/50840

--
ubuntu-backports mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-backports
Reply | Threaded
Open this post in threaded view
|

[Bug 50840] Re: scilab 4

John Shakespeare
In reply to this post by 89c51
Scilab 3.0-12 included in Dapper repositories has severe font problems.
It appears to use a Tamili font, which makes it useless for those who
don't understand English words in Tamili characters (probably most of
us). An upgrade to v4 might be better.

--
scilab 4
https://launchpad.net/bugs/50840

--
ubuntu-backports mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-backports
Reply | Threaded
Open this post in threaded view
|

[Bug 50840] Re: scilab 4

Gauvain Pocentek
In reply to this post by 89c51
Sync request reported in bug #58088

--
scilab 4
https://launchpad.net/bugs/50840

--
ubuntu-backports mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-backports
Reply | Threaded
Open this post in threaded view
|

[Bug 50840] Re: scilab 4

PeteDonnell
In reply to this post by 89c51
As a temporary workaround, while we're waiting for the new version to be
released, it's possible to run scilab in text (i.e. non-windowed) mode
using the command 'scilab -nw'. This avoids the problem with the fonts.
Not ideal but it may help some people.

--
scilab 4
https://launchpad.net/bugs/50840

--
ubuntu-backports mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-backports
Reply | Threaded
Open this post in threaded view
|

[Bug 50840] Re: scilab 4

DLC-2
In reply to this post by 89c51
Thanks for the workaround! Any status on the v4 package?

Thanks

--
scilab 4
https://launchpad.net/bugs/50840

--
ubuntu-backports mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-backports
Reply | Threaded
Open this post in threaded view
|

[Bug 50840] Re: scilab 4

Jordan Mantha
In reply to this post by 89c51
scilab 4 has been in edgy since 08-29

--
scilab 4
https://launchpad.net/bugs/50840

--
ubuntu-backports mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-backports
Reply | Threaded
Open this post in threaded view
|

[Bug 50840] Re: scilab 4

Jordan Mantha
In reply to this post by 89c51
although it appears to have only compiled on i386 :(

--
scilab 4
https://launchpad.net/bugs/50840

--
ubuntu-backports mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-backports
Reply | Threaded
Open this post in threaded view
|

[Bug 50840] Re: scilab 4

Julien Chiquet
In reply to this post by 89c51
I have just updated to Edgy. With Dapper, I used to run scilab 4.0 after
an installation through the tar.gz archive.

Now, I ve just installed scilab 4.0 through the .deb package from the
Edgy repositories.

Mainly, it seems to work fine. I just have a problem with the 'scipad'
command, which is a embedded editor of scilab. When I run in scilab
'scipad();', I get the following error :

-->scipad();
 !--error 999
TCL_EvalStr, invalid command name "wm" at line 1
at line      30 of function scipad called by :  
scipad;

I don't know if it a problem of tcl depency or something.

Please, tell me if I should report this bug elsewhere.

thanks,

J.

--
scilab 4
https://launchpad.net/bugs/50840

--
ubuntu-backports mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-backports
Reply | Threaded
Open this post in threaded view
|

[Bug 50840] Re: scilab 4 + scipad

Julien Chiquet
In reply to this post by 89c51
Ok, I have found a way to make the scipad editor works. In fact, Scilab
does not find the tk library libtk8.4.so, just because its name is
libtk8.4.so.0.

So, I have just made a copy of libtk8.4.so.0 in libtk8.4.so, this way :

$ sudo cp /usr/lib/libtk8.4.so.0 /usr/lib/libtk8.4.so

and then, after relaunching Scilab, the button "editor" in the menu or
the command "scipad()" in the interpretor works fine.

Julien

--
scilab 4
https://launchpad.net/bugs/50840

--
ubuntu-backports mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-backports
Reply | Threaded
Open this post in threaded view
|

[Bug 50840] Re: scilab 4

Sylvestre Ledru-4
In reply to this post by 89c51
This bug (libtk8.4.so instead of libtk8.4.so.0) has been fixed into the
upstream and into the debian packages.

Julien : there is a better way for this workaround :
ln -s /usr/lib/libtk8.4.so.0 /usr/lib/libtk8.4.so

--
scilab 4
https://launchpad.net/bugs/50840

--
ubuntu-backports mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-backports
Reply | Threaded
Open this post in threaded view
|

[Bug 50840] Re: scilab 4

William Grant-2
In reply to this post by 89c51
Scilab 4 is in Edgy, so the scilab task no longer needs to be open. The
libtk8.4.so bug is #70492.

** Changed in: scilab (Ubuntu)
       Status: Confirmed => Fix Released

--
scilab 4
https://launchpad.net/bugs/50840

--
ubuntu-backports mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-backports
Reply | Threaded
Open this post in threaded view
|

[Bug 50840] Re: scilab 4

John Dong
In reply to this post by 89c51
gfortran: /var/cache/prevu/src/7133/scilab-4.0/libs/libXaw3d.a: No such file or directory
gfortran: /var/cache/prevu/src/7133/scilab-4.0/libs/libXmu.a: No such file or directory
gfortran: /var/cache/prevu/src/7133/scilab-4.0/libs/libXaw3d.a: No such file or directory
gfortran: /var/cache/prevu/src/7133/scilab-4.0/libs/libXmu.a: No such file or directory


Does not build.

** Changed in: dapper-backports (upstream)
       Status: Needs Info => Rejected

--
scilab 4
https://launchpad.net/bugs/50840

--
ubuntu-backports mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-backports