Can't install latest docker-ce stable package on Ubuntu 16.04 LTS

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Can't install latest docker-ce stable package on Ubuntu 16.04 LTS

John Naggets
Hi,

I can't install the latest Docker CE package on my Ubuntu 16.04 LTS
because of a unmet dependecy as you can see below:

$ sudo apt-get install docker-ce=18.03.1~ce-0~ubuntu

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 docker-ce : Depends: libseccomp2 (>= 2.3.0) but 2.2.3-3ubuntu3 is to
be installed
E: Unable to correct problems, you have held broken packages

My APT sources.list looks like that:

deb http://ch.archive.ubuntu.com/ubuntu xenial main universe
deb http://ch.archive.ubuntu.com/ubuntu/ xenial-security main universe
deb [arch=amd64] https://download.docker.com/linux/ubuntu xenial stable

Any ideas what is wrong here?

Cheers,
J.

--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Can't install latest docker-ce stable package on Ubuntu 16.04 LTS

Liam Proven
On Wed, 4 Jul 2018 at 14:48, John Naggets <[hidden email]> wrote:
>
> Any ideas what is wrong here?

Well, yes. You need a newer version of libseccomp2. Apparently you
have (or are getting) 2.2.x but you need 2.3.x for Docker.

This might mean that you need a newer version of Ubuntu, I'm afraid,
but I have not used Docker on Ubuntu at all.

--
Liam Proven - Profile: https://about.me/liamproven
Email: [hidden email] - Google Mail/Hangouts/Plus: [hidden email]
Twitter/Facebook/Flickr: lproven - Skype/LinkedIn: liamproven
UK: +44 7939-087884 - ČR (+ WhatsApp/Telegram/Signal): +420 702 829 053

--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Can't install latest docker-ce stable package on Ubuntu 16.04 LTS

John Naggets
Hi Liam

So you mean I should upgrade my Ubuntu 16.04 to 18.04? Do I understand
correctly?

Cheers,
J.

On Wed, Jul 4, 2018 at 3:18 PM, Liam Proven <[hidden email]> wrote:

> On Wed, 4 Jul 2018 at 14:48, John Naggets <[hidden email]> wrote:
>>
>> Any ideas what is wrong here?
>
> Well, yes. You need a newer version of libseccomp2. Apparently you
> have (or are getting) 2.2.x but you need 2.3.x for Docker.
>
> This might mean that you need a newer version of Ubuntu, I'm afraid,
> but I have not used Docker on Ubuntu at all.
>
> --
> Liam Proven - Profile: https://about.me/liamproven
> Email: [hidden email] - Google Mail/Hangouts/Plus: [hidden email]
> Twitter/Facebook/Flickr: lproven - Skype/LinkedIn: liamproven
> UK: +44 7939-087884 - ČR (+ WhatsApp/Telegram/Signal): +420 702 829 053
>
> --
> ubuntu-users mailing list
> [hidden email]
> Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users

--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Can't install latest docker-ce stable package on Ubuntu 16.04 LTS

Liam Proven
On Thu, 5 Jul 2018 at 17:58, John Naggets <[hidden email]> wrote:
>
> Hi Liam
>
> So you mean I should upgrade my Ubuntu 16.04 to 18.04? Do I understand
> correctly?

It's worth a try.

Make a full backup first so you can go back if it doesn't work.

P.S. Please bottom-post on mailing lists.

--
Liam Proven - Profile: https://about.me/liamproven
Email: [hidden email] - Google Mail/Hangouts/Plus: [hidden email]
Twitter/Facebook/Flickr: lproven - Skype/LinkedIn: liamproven
UK: +44 7939-087884 - ČR (+ WhatsApp/Telegram/Signal): +420 702 829 053

--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users