Clipboard changes?

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Clipboard changes?

MR ZenWiz
Did anything change in any recent updates with the way the system
clipboard is handled?

I ask because the clipboard works fine on my Xubuntu 18.04 host, but
the bidirectional clipboard setup between the host and my VirtualBox
VMs no longer works.

I suspect this is a VB issue because at work I run Win 10 with an
Xubuntu VM and it fails there, too.  (At home I run Xubuntu with Win 7
VMs.)

Thanks.

Mark

--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Clipboard changes?

Liam Proven
On Tue, 24 Sep 2019 at 06:56, MR ZenWiz <[hidden email]> wrote:
>
> I ask because the clipboard works fine on my Xubuntu 18.04 host, but
> the bidirectional clipboard setup between the host and my VirtualBox
> VMs no longer works.

Are you on the latest VirtualBox (6.0.12)? If so, have you installed
the latest Guest Additions in your VMs? It's necessary to keep the
additions in sync with the hypervisor.


--
Liam Proven - Profile: https://about.me/liamproven
Email: [hidden email] - Google Mail/Hangouts/Plus: [hidden email]
Twitter/Facebook/Flickr: lproven - Skype/LinkedIn: liamproven
UK: +44 7939-087884 - ČR (+ WhatsApp/Telegram/Signal): +420 702 829 053

--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Clipboard changes?

robert rottermann

On 24/09/2019 10:15, Liam Proven wrote:
> On Tue, 24 Sep 2019 at 06:56, MR ZenWiz <[hidden email]> wrote:
>> I ask because the clipboard works fine on my Xubuntu 18.04 host, but
>> the bidirectional clipboard setup between the host and my VirtualBox
>> VMs no longer works.
> Are you on the latest VirtualBox (6.0.12)? If so, have you installed
> the latest Guest Additions in your VMs? It's necessary to keep the
> additions in sync with the hypervisor.
>
I made the experience, that you sometimes have to rerun the installation
of the guest additions after a change.

However this I experienced with a ubuntu and not a windows guest

robert


--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Clipboard changes?

Tommy Trussell
In reply to this post by MR ZenWiz
On Mon, Sep 23, 2019 at 11:56 PM MR ZenWiz <[hidden email]> wrote:
Did anything change in any recent updates with the way the system
clipboard is handled?

I ask because the clipboard works fine on my Xubuntu 18.04 host, but
the bidirectional clipboard setup between the host and my VirtualBox
VMs no longer works.

I suspect this is a VB issue because at work I run Win 10 with an
Xubuntu VM and it fails there, too.  (At home I run Xubuntu with Win 7
VMs.)
 
Think back on your behavior. Did you recently start using Google Chrome or Chromium inside or outside the VM? I was recently "bit" by this bug, where the clipboard didn't work between Chromium on the host and anything inside the VM:


The simplest workaround is to use Firefox or another non-Chrome-derived browser. Alternatively you can paste the text into something else (text editor or whatever) and then copy and paste inside or outside the VM.

--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Clipboard changes?

MR ZenWiz
In reply to this post by Liam Proven
On Tue, Sep 24, 2019 at 1:18 AM Liam Proven <[hidden email]> wrote:

>
> On Tue, 24 Sep 2019 at 06:56, MR ZenWiz <[hidden email]> wrote:
> >
> > I ask because the clipboard works fine on my Xubuntu 18.04 host, but
> > the bidirectional clipboard setup between the host and my VirtualBox
> > VMs no longer works.
>
> Are you on the latest VirtualBox (6.0.12)? If so, have you installed
> the latest Guest Additions in your VMs? It's necessary to keep the
> additions in sync with the hypervisor.
>
I was running 6.0.10 and I backed down to 5.2.32 - still no clipboard
in and out of the VM, only inside only or outside only.

And yes, I always install the extension packs and update the guest
additions.  Unfortunately no luck there either.

Thanks.

--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Clipboard changes?

MR ZenWiz
In reply to this post by Tommy Trussell
On Tue, Sep 24, 2019 at 8:43 AM Tommy Trussell <[hidden email]> wrote:
>
:
>
> Think back on your behavior. Did you recently start using Google Chrome or Chromium inside or outside the VM? I was recently "bit" by this bug, where the clipboard didn't work between Chromium on the host and anything inside the VM:
>
I have Chrome on both the host and VM, but I have been using Brave on
both for most ofmy browsing.  Also, this clipboard inaccessibility
happens in all apps, both in the VM and on the host - there is no way
to copy directly from VM to host or vice versa.

I had to resort to copying and writing to a file that is accessible to
both machines, then opening the file on the other to collect the
clipboard content.

Since this happens whether the native host is Xubuntu or Windows, I
strongly suspect it's broken in VB.

Thanks.

Mark

--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Clipboard changes?

Tommy Trussell
On Tue, Sep 24, 2019 at 3:25 PM MR ZenWiz <[hidden email]> wrote:
Since this happens whether the native host is Xubuntu or Windows, I
strongly suspect it's broken in VB.

Before you suggested you're having similar issues with different Host OSs I was going to suggest it might be caused by a HWE kernel update to your Bionic 18.04 LTS. But it sounds like that doesn't explain it.

I've had a few problems on random VMs getting the guest additions installed, but at the moment I'm not having any persistent clipboard issues with the VirtualBox 6.06 package install in Ubuntu 19.04. Only the Chrome / Chromium issue I mentioned before.

Another thing you might try is opening the VirtualBox Manager window, pointing to a running VM, and choosing Machine --> Show Log...

I just tried that and saw the clipboard events in the VirtualBox log. If you do (or don't) see them, maybe the details on your system will offer a clue about what's happening.



--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users