Default Boost Versions for "R"

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Default Boost Versions for "R"

Scott Kitterman-3
We had a bit of a discussion about this on #ubuntu-motu yesterday and, among
those discussing it (who are the ones who usually do most of the work on a
Boost transition), we concluded staying in line with Debian and keeping 1.49
as the default Boost is what we should do for "R".  As with Quantal, Boost1.50
will be available in Universe for developers or packages that need the newer
features, but it won't be in Main and should not generally be used for
packages unless it's really needed.

The good news is that means there there is nothing that needs doing for Boost
before "R" opens for development.

Scott K

--
ubuntu-devel mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel
Reply | Threaded
Open this post in threaded view
|

Re: Default Boost Versions for "R"

Didier Roche-3
Le 17/10/2012 18:51, Scott Kitterman a écrit :

> We had a bit of a discussion about this on #ubuntu-motu yesterday and, among
> those discussing it (who are the ones who usually do most of the work on a
> Boost transition), we concluded staying in line with Debian and keeping 1.49
> as the default Boost is what we should do for "R".  As with Quantal, Boost1.50
> will be available in Universe for developers or packages that need the newer
> features, but it won't be in Main and should not generally be used for
> packages unless it's really needed.
>
> The good news is that means there there is nothing that needs doing for Boost
> before "R" opens for development.

Thanks for the follow up, I'll keep the unity team informed about it.

Cheers,
Didier

--
ubuntu-devel mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel
Reply | Threaded
Open this post in threaded view
|

Re: Default Boost Versions for "R"

Ma Xiaojun
Q: 1.50
R: 1.49
?

--
ubuntu-devel mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel
Reply | Threaded
Open this post in threaded view
|

Re: Default Boost Versions for "R"

Scott Kitterman-3
On Wednesday, October 17, 2012 01:16:49 PM Ma Xiaojun wrote:
> Q: 1.50
> R: 1.49
> ?

$ rmadison boost-defaults|grep quantal
boost-defaults |   1.49.0.1 |       quantal | source

Both boost1.49 and boost1.50 are in Quantal (and will be in "R"), but 1.49 is
the default boost (the one upon which the unversioned boost packages depend)
and the one that Ubuntu packages should generally be using.

Scott K

--
ubuntu-devel mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel
Reply | Threaded
Open this post in threaded view
|

Re: Default Boost Versions for "R"

Dmitrijs Ledkovs-2
In reply to this post by Ma Xiaojun
On 17 October 2012 19:16, Ma Xiaojun <[hidden email]> wrote:
> Q: 1.50
> R: 1.49
> ?

No.
Q & R - Default (main): 1.49
Q & R - Available (universe): 1.50

Please note that many gcc-4.7 fail-to-build-from-source bugfixes from
1.50 have been cherry-picked into the current 1.49 packages.
The new 1.50 api / abis are only in the 1.50 packages.

Regards,

Dmitrijs.

--
ubuntu-devel mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel