Disabling RAID autodetecion at boot time

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Disabling RAID autodetecion at boot time

James Lee-4
I'm having a problem which I'm not having much success getting around at the
moment:

I'm trying to disable autostarting of my software RAID array at startup
(because this is interfereing with EVMS's management of them).  I've tried
removing the mdadm and mdadm-raid startup scripts from /etc/init.d/, I've
added a "raid=noautodetect" boot parameter to the bootloader, and I've made
sure that the partition types on the disks are not set to raid autodetect.  
For good measure, i've also made sure that there's no mention of the array
in the mdadm.conf file.

However the array is still being autostarted (not by EVMS) at startup.  I've
tried to get some advice on this on the EVMS mailing lists, and it's been
suggested that the array may be being started in my initrd (see
http://marc.theaimsgroup.com/?t=113493016200002&r=1&w=2).

I'm sort of running out of ideas here... does anyone have any suggestions as
to how to disable autostarting of md devices?  Any help would be much
appreciated...



--
ubuntu-users mailing list
[hidden email]
http://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Disabling RAID autodetecion at boot time

Bugzilla from jake.nelson@gmail.com
On 1/8/06, James Lee <[hidden email]> wrote:
I'm having a problem which I'm not having much success getting around at the
moment:

I'm trying to disable autostarting of my software RAID array at startup
(because this is interfereing with EVMS's management of them).  I've tried
removing the mdadm and mdadm-raid startup scripts from /etc/init.d/, I've
added a "raid=noautodetect" boot parameter to the bootloader, and I've made
sure that the partition types on the disks are not set to raid autodetect.
For good measure, i've also made sure that there's no mention of the array
in the mdadm.conf file.

However the array is still being autostarted (not by EVMS) at startup.  I've
tried to get some advice on this on the EVMS mailing lists, and it's been
suggested that the array may be being started in my initrd (see
http://marc.theaimsgroup.com/?t=113493016200002&r=1&w=2).

I'm sort of running out of ideas here... does anyone have any suggestions as
to how to disable autostarting of md devices?  Any help would be much
appreciated...



--
ubuntu-users mailing list
[hidden email]
http://lists.ubuntu.com/mailman/listinfo/ubuntu-users

Check your /etc/fstab file I believe and add the option noauto after defaults for the /dev/md0 device (i think would be your first software raid device?) 

--
ubuntu-users mailing list
[hidden email]
http://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Disabling RAID autodetecion at boot time

Phillip Susi
In reply to this post by James Lee-4
If you don't want md raid to start in the initramfs, move
/usr/share/initramfs-tools/scripts/local-top/md out of the way ( like to
your home dir ), and update-initramfs.

James Lee wrote:

> I'm having a problem which I'm not having much success getting around
> at the moment:
>
> I'm trying to disable autostarting of my software RAID array at
> startup (because this is interfereing with EVMS's management of
> them).  I've tried removing the mdadm and mdadm-raid startup scripts
> from /etc/init.d/, I've added a "raid=noautodetect" boot parameter to
> the bootloader, and I've made sure that the partition types on the
> disks are not set to raid autodetect.  For good measure, i've also
> made sure that there's no mention of the array in the mdadm.conf file.
>
> However the array is still being autostarted (not by EVMS) at
> startup.  I've tried to get some advice on this on the EVMS mailing
> lists, and it's been suggested that the array may be being started in
> my initrd (see http://marc.theaimsgroup.com/?t=113493016200002&r=1&w=2).
>
> I'm sort of running out of ideas here... does anyone have any
> suggestions as to how to disable autostarting of md devices?  Any help
> would be much appreciated...
>
>
>


--
ubuntu-users mailing list
[hidden email]
http://lists.ubuntu.com/mailman/listinfo/ubuntu-users