Error xulrunner al actualizar a Ubuntu 18

classic Classic list List threaded Threaded
38 messages Options
12
Reply | Threaded
Open this post in threaded view
|

Error xulrunner al actualizar a Ubuntu 18

evangelsan evangelsan

Hola amigos de la lista.

Hace un par de meses actualicé al Ubuntu 18 a través de internet.

Algo falló porque me dio el mensaje de error siguiente:

"Paquete xulrunner-1.9.1 no se ha instalado."

Desde entonces, aunque funciona bien el Ubuntu 18, no puedo realizar ninguna actualización del sistema.

He probado las órdenes de "upgrade", "update", "aptitude reinstall" y las pocas que conozco, pero nada.

Me dice que el paquete xulrunner está roto y me quedo como antes.

¿Sabéis que puedo hacer?

Muchas gracias por anticipado.

Saludos de Angel


--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
Reply | Threaded
Open this post in threaded view
|

Re: Error xulrunner al actualizar a Ubuntu 18

evangelsan evangelsan

Gracias por la respuesta Rafa.

Pero este tipo de acciones que aparecen en esa página ya las he intentado y nada.

La consola me responde que no se puede acceder a dpkg, que solo es de lectura y vuelvo a la casilla de salida.

Alguien sabe que puedo hacer?

Saludos y gracias.

Angel

El 10 de enero de 2019 a las 15:01 [hidden email] escribió:


https://compuadictosamg.wordpress.com/2018/03/26/reparar-paquetes-rotos-en-linux/amp/

Prueba haber 

Rafa 

El 10 ene 2019, a las 11:11, evangelsan evangelsan < [hidden email]> escribió:

Hola amigos de la lista.

Hace un par de meses actualicé al Ubuntu 18 a través de internet.

Algo falló porque me dio el mensaje de error siguiente:

"Paquete xulrunner-1.9.1 no se ha instalado."

Desde entonces, aunque funciona bien el Ubuntu 18, no puedo realizar ninguna actualización del sistema.

He probado las órdenes de "upgrade", "update", "aptitude reinstall" y las pocas que conozco, pero nada.

Me dice que el paquete xulrunner está roto y me quedo como antes.

¿Sabéis que puedo hacer?

Muchas gracias por anticipado.

Saludos de Angel


 


--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
Reply | Threaded
Open this post in threaded view
|

Re: Error xulrunner al actualizar a Ubuntu 18

arriero
In reply to this post by evangelsan evangelsan
Puedes usar este enlace es casi lo mismo pero hay varios comandos más.

El jue., 10 ene. 2019 11:13, evangelsan evangelsan <[hidden email]> escribió:

Hola amigos de la lista.

Hace un par de meses actualicé al Ubuntu 18 a través de internet.

Algo falló porque me dio el mensaje de error siguiente:

"Paquete xulrunner-1.9.1 no se ha instalado."

Desde entonces, aunque funciona bien el Ubuntu 18, no puedo realizar ninguna actualización del sistema.

He probado las órdenes de "upgrade", "update", "aptitude reinstall" y las pocas que conozco, pero nada.

Me dice que el paquete xulrunner está roto y me quedo como antes.

¿Sabéis que puedo hacer?

Muchas gracias por anticipado.

Saludos de Angel

--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es

--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
Reply | Threaded
Open this post in threaded view
|

Re: Error xulrunner al actualizar a Ubuntu 18

evangelsan evangelsan

¿Que enlace, Arriero?

Saludos

Angel

El 13 de enero de 2019 a las 8:20 arriero <[hidden email]> escribió:

Puedes usar este enlace es casi lo mismo pero hay varios comandos más.

El jue., 10 ene. 2019 11:13, evangelsan evangelsan < [hidden email]> escribió:

Hola amigos de la lista.

Hace un par de meses actualicé al Ubuntu 18 a través de internet.

Algo falló porque me dio el mensaje de error siguiente:

"Paquete xulrunner-1.9.1 no se ha instalado."

Desde entonces, aunque funciona bien el Ubuntu 18, no puedo realizar ninguna actualización del sistema.

He probado las órdenes de "upgrade", "update", "aptitude reinstall" y las pocas que conozco, pero nada.

Me dice que el paquete xulrunner está roto y me quedo como antes.

¿Sabéis que puedo hacer?

Muchas gracias por anticipado.

Saludos de Angel

--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es

--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
Reply | Threaded
Open this post in threaded view
|

Re: Error xulrunner al actualizar a Ubuntu 18

arriero

El dom., 13 ene. 2019 13:08, evangelsan evangelsan <[hidden email]> escribió:

¿Que enlace, Arriero?

Saludos

Angel

El 13 de enero de 2019 a las 8:20 arriero <[hidden email]> escribió:

Puedes usar este enlace es casi lo mismo pero hay varios comandos más.

El jue., 10 ene. 2019 11:13, evangelsan evangelsan < [hidden email]> escribió:

Hola amigos de la lista.

Hace un par de meses actualicé al Ubuntu 18 a través de internet.

Algo falló porque me dio el mensaje de error siguiente:

"Paquete xulrunner-1.9.1 no se ha instalado."

Desde entonces, aunque funciona bien el Ubuntu 18, no puedo realizar ninguna actualización del sistema.

He probado las órdenes de "upgrade", "update", "aptitude reinstall" y las pocas que conozco, pero nada.

Me dice que el paquete xulrunner está roto y me quedo como antes.

¿Sabéis que puedo hacer?

Muchas gracias por anticipado.

Saludos de Angel

--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es

--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
Reply | Threaded
Open this post in threaded view
|

Re: Error xulrunner al actualizar a Ubuntu 18

arriero
In reply to this post by evangelsan evangelsan
Esta claro que desde un smartphone no se puede contestar este tipo de enlaces.

El dom., 13 ene. 2019 13:08, evangelsan evangelsan <[hidden email]> escribió:

¿Que enlace, Arriero?

Saludos

Angel

El 13 de enero de 2019 a las 8:20 arriero <[hidden email]> escribió:

Puedes usar este enlace es casi lo mismo pero hay varios comandos más.

El jue., 10 ene. 2019 11:13, evangelsan evangelsan < [hidden email]> escribió:

Hola amigos de la lista.

Hace un par de meses actualicé al Ubuntu 18 a través de internet.

Algo falló porque me dio el mensaje de error siguiente:

"Paquete xulrunner-1.9.1 no se ha instalado."

Desde entonces, aunque funciona bien el Ubuntu 18, no puedo realizar ninguna actualización del sistema.

He probado las órdenes de "upgrade", "update", "aptitude reinstall" y las pocas que conozco, pero nada.

Me dice que el paquete xulrunner está roto y me quedo como antes.

¿Sabéis que puedo hacer?

Muchas gracias por anticipado.

Saludos de Angel

--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es

--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
Reply | Threaded
Open this post in threaded view
|

Re: Error xulrunner al actualizar a Ubuntu 18

evangelsan evangelsan
In reply to this post by arriero

Hola Arriero y demás compañeros de la lista.

Sigo intentando desinstalar el paquete xulrunner-1.9.1 pero el sistema no me deja.

Y este paquete es el que me está dando problemas.

Esto es lo que me responde la terminal:

Los siguientes paquetes se ELIMINARÁN:
xulrunner-1.9.1
0 actualizados, 0 nuevos se instalarán, 1 para eliminar y 429 no actualizados.
Se liberarán 21,9 MB después de esta operación.
¿Desea continuar? [S/n] s
(Leyendo la base de datos ... 281664 ficheros o directorios instalados actualmente.)
Desinstalando xulrunner-1.9.1 (1.9.1.16+build2+nobinonly-0ubuntu0.9.10.1) ...
/var/lib/dpkg/info/xulrunner-1.9.1.prerm: 8: /var/lib/dpkg/info/xulrunner-1.9.1.prerm: /usr/sbin/update-alternatives: not found
dpkg: error al procesar el paquete xulrunner-1.9.1 (--remove):
instalado xulrunner-1.9.1 paquete pre-removal guión el subproceso devolvió un error con estado de salida 127
Se encontraron errores al procesar:
xulrunner-1.9.1
E: Sub-process /usr/bin/dpkg returned an error code (1)

Y así constantemente.

He probado todas las órdenes que conozco y que me habéis señalado pero nada.

¿Alguien sabe como puedo forzar la eliminación de este paquete?

¿y que es?

Saludos.

Angel

El 13 de enero de 2019 a las 19:55 arriero <[hidden email]> escribió:


El dom., 13 ene. 2019 13:08, evangelsan evangelsan < [hidden email]> escribió:

¿Que enlace, Arriero?

Saludos

Angel

El 13 de enero de 2019 a las 8:20 arriero < [hidden email]> escribió:

Puedes usar este enlace es casi lo mismo pero hay varios comandos más.

El jue., 10 ene. 2019 11:13, evangelsan evangelsan < [hidden email]> escribió:

Hola amigos de la lista.

Hace un par de meses actualicé al Ubuntu 18 a través de internet.

Algo falló porque me dio el mensaje de error siguiente:

"Paquete xulrunner-1.9.1 no se ha instalado."

Desde entonces, aunque funciona bien el Ubuntu 18, no puedo realizar ninguna actualización del sistema.

He probado las órdenes de "upgrade", "update", "aptitude reinstall" y las pocas que conozco, pero nada.

Me dice que el paquete xulrunner está roto y me quedo como antes.

¿Sabéis que puedo hacer?

Muchas gracias por anticipado.

Saludos de Angel

--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es

--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
Reply | Threaded
Open this post in threaded view
|

Re: Error xulrunner al actualizar a Ubuntu 18

Juan Francisco Guil Vázquez
prueba borrando el paquete con
dpkg --purge 
-force xulrunner-1.9.1 (o algo parecido)

man dpkg

Saludos


 
El 14/01/2019 a las 10:05, evangelsan evangelsan escribió:

Hola Arriero y demás compañeros de la lista.

Sigo intentando desinstalar el paquete xulrunner-1.9.1 pero el sistema no me deja.

Y este paquete es el que me está dando problemas.

Esto es lo que me responde la terminal:

Los siguientes paquetes se ELIMINARÁN:
xulrunner-1.9.1
0 actualizados, 0 nuevos se instalarán, 1 para eliminar y 429 no actualizados.
Se liberarán 21,9 MB después de esta operación.
¿Desea continuar? [S/n] s
(Leyendo la base de datos ... 281664 ficheros o directorios instalados actualmente.)
Desinstalando xulrunner-1.9.1 (1.9.1.16+build2+nobinonly-0ubuntu0.9.10.1) ...
/var/lib/dpkg/info/xulrunner-1.9.1.prerm: 8: /var/lib/dpkg/info/xulrunner-1.9.1.prerm: /usr/sbin/update-alternatives: not found
dpkg: error al procesar el paquete xulrunner-1.9.1 (--remove):
instalado xulrunner-1.9.1 paquete pre-removal guión el subproceso devolvió un error con estado de salida 127
Se encontraron errores al procesar:
xulrunner-1.9.1
E: Sub-process /usr/bin/dpkg returned an error code (1)

Y así constantemente.

He probado todas las órdenes que conozco y que me habéis señalado pero nada.

¿Alguien sabe como puedo forzar la eliminación de este paquete?

¿y que es?

Saludos.

Angel

El 13 de enero de 2019 a las 19:55 arriero [hidden email] escribió:


El dom., 13 ene. 2019 13:08, evangelsan evangelsan < [hidden email]> escribió:

¿Que enlace, Arriero?

Saludos

Angel

El 13 de enero de 2019 a las 8:20 arriero < [hidden email]> escribió:

Puedes usar este enlace es casi lo mismo pero hay varios comandos más.

El jue., 10 ene. 2019 11:13, evangelsan evangelsan < [hidden email]> escribió:

Hola amigos de la lista.

Hace un par de meses actualicé al Ubuntu 18 a través de internet.

Algo falló porque me dio el mensaje de error siguiente:

"Paquete xulrunner-1.9.1 no se ha instalado."

Desde entonces, aunque funciona bien el Ubuntu 18, no puedo realizar ninguna actualización del sistema.

He probado las órdenes de "upgrade", "update", "aptitude reinstall" y las pocas que conozco, pero nada.

Me dice que el paquete xulrunner está roto y me quedo como antes.

¿Sabéis que puedo hacer?

Muchas gracias por anticipado.

Saludos de Angel

--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es


--

--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
Reply | Threaded
Open this post in threaded view
|

Re: Error xulrunner al actualizar a Ubuntu 18

evangelsan evangelsan

Parece que no funciona.

Esto me dice al poner esa acción:

dpkg: error: acciones en conflicto -f (--field) y -P (--purge)

Saludos.

El 14 de enero de 2019 a las 12:49 Juan Francisco Guil Vázquez <[hidden email]> escribió:

prueba borrando el paquete con
dpkg --purge 
-force xulrunner-1.9.1 (o algo parecido)

man dpkg

Saludos


 
El 14/01/2019 a las 10:05, evangelsan evangelsan escribió:

Hola Arriero y demás compañeros de la lista.

Sigo intentando desinstalar el paquete xulrunner-1.9.1 pero el sistema no me deja.

Y este paquete es el que me está dando problemas.

Esto es lo que me responde la terminal:

Los siguientes paquetes se ELIMINARÁN:
xulrunner-1.9.1
0 actualizados, 0 nuevos se instalarán, 1 para eliminar y 429 no actualizados.
Se liberarán 21,9 MB después de esta operación.
¿Desea continuar? [S/n] s
(Leyendo la base de datos ... 281664 ficheros o directorios instalados actualmente.)
Desinstalando xulrunner-1.9.1 (1.9.1.16+build2+nobinonly-0ubuntu0.9.10.1) ...
/var/lib/dpkg/info/xulrunner-1.9.1.prerm: 8: /var/lib/dpkg/info/xulrunner-1.9.1.prerm: /usr/sbin/update-alternatives: not found
dpkg: error al procesar el paquete xulrunner-1.9.1 (--remove):
instalado xulrunner-1.9.1 paquete pre-removal guión el subproceso devolvió un error con estado de salida 127
Se encontraron errores al procesar:
xulrunner-1.9.1
E: Sub-process /usr/bin/dpkg returned an error code (1)

Y así constantemente.

He probado todas las órdenes que conozco y que me habéis señalado pero nada.

¿Alguien sabe como puedo forzar la eliminación de este paquete?

¿y que es?

Saludos.

Angel

El 13 de enero de 2019 a las 19:55 arriero [hidden email] escribió:


El dom., 13 ene. 2019 13:08, evangelsan evangelsan < [hidden email]> escribió:

¿Que enlace, Arriero?

Saludos

Angel

El 13 de enero de 2019 a las 8:20 arriero < [hidden email]> escribió:

Puedes usar este enlace es casi lo mismo pero hay varios comandos más.

El jue., 10 ene. 2019 11:13, evangelsan evangelsan < [hidden email]> escribió:

Hola amigos de la lista.

Hace un par de meses actualicé al Ubuntu 18 a través de internet.

Algo falló porque me dio el mensaje de error siguiente:

"Paquete xulrunner-1.9.1 no se ha instalado."

Desde entonces, aunque funciona bien el Ubuntu 18, no puedo realizar ninguna actualización del sistema.

He probado las órdenes de "upgrade", "update", "aptitude reinstall" y las pocas que conozco, pero nada.

Me dice que el paquete xulrunner está roto y me quedo como antes.

¿Sabéis que puedo hacer?

Muchas gracias por anticipado.

Saludos de Angel

--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es


--


 

--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es


 


--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
Reply | Threaded
Open this post in threaded view
|

Re: Error xulrunner al actualizar a Ubuntu 18

Javier Garcia-3
In reply to this post by Juan Francisco Guil Vázquez

 

Puedes probar lo siguiente

 

Ejectuta estos tres comandos

sudo du -sh /var/cache/apt

sudo apt clean

sudo apt autoclean

 

sudo apt install --reinstall xulrunner

 

si sigue fallando prueba

 

apt install -f

 

y vuelve a instalarlo

 

> prueba borrando el paquete con

> dpkg --purge -force xulrunner-1.9.1 (o algo parecido)

>

> man dpkg

>

> Saludos

>

> El 14/01/2019 a las 10:05, evangelsan evangelsan escribió:

> > Hola Arriero y demás compañeros de la lista.

> >

> > Sigo intentando desinstalar el paquete xulrunner-1.9.1 pero el sistema

> > no me deja.

> >

> > Y este paquete es el que me está dando problemas.

> >

> > Esto es lo que me responde la terminal:

> >

> > Los siguientes paquetes se ELIMINARÁN:

> > xulrunner-1.9.1

> > 0 actualizados, 0 nuevos se instalarán, 1 para eliminar y 429 no

> > actualizados.

> > Se liberarán 21,9 MB después de esta operación.

> > ¿Desea continuar? [S/n] s

> > (Leyendo la base de datos ... 281664 ficheros o directorios instalados

> > actualmente.)

> > Desinstalando xulrunner-1.9.1

> > (1.9.1.16+build2+nobinonly-0ubuntu0.9.10.1) ...

> > /var/lib/dpkg/info/xulrunner-1.9.1.prerm: 8:

> > /var/lib/dpkg/info/xulrunner-1.9.1.prerm:

> > /usr/sbin/update-alternatives: not found

> > dpkg: error al procesar el paquete xulrunner-1.9.1 (--remove):

> > instalado xulrunner-1.9.1 paquete pre-removal guión el subproceso

> > devolvió un error con estado de salida 127

> > Se encontraron errores al procesar:

> > xulrunner-1.9.1

> > E: Sub-process /usr/bin/dpkg returned an error code (1)

> >

> > Y así constantemente.

> >

> > He probado todas las órdenes que conozco y que me habéis señalado pero

> > nada.

> >

> > ¿Alguien sabe como puedo forzar la eliminación de este paquete?

> >

> > ¿y que es?

> >

> > Saludos.

> >

> > Angel

> >

> >> El 13 de enero de 2019 a las 19:55 arriero <[hidden email]>

> >> escribió:

> >>

> >> Perdón por la perdida del enlace.

> >>

> >>

> >> http://curioseandolinux.blogspot.com/2010/10/reparar-paquetes-rotos-o-mal

> >> -instalados.html?m=1

> >>

> >>

> >> El dom., 13 ene. 2019 13:08, evangelsan evangelsan <

> >>

> >> [hidden email] <mailto:[hidden email]>> escribió:

> >> ¿Que enlace, Arriero?

> >>

> >> Saludos

> >>

> >> Angel

> >>

> >>> El 13 de enero de 2019 a las 8:20 arriero < [hidden email]

> >>> <mailto:[hidden email]>> escribió:

> >>>

> >>> Puedes usar este enlace es casi lo mismo pero hay varios

> >>> comandos más.

> >>>

> >>> El jue., 10 ene. 2019 11:13, evangelsan evangelsan <

> >>> [hidden email] <mailto:[hidden email]>>

> >>>

> >>> escribió:

> >>> Hola amigos de la lista.

> >>>

> >>> Hace un par de meses actualicé al Ubuntu 18 a través de

> >>> internet.

> >>>

> >>> Algo falló porque me dio el mensaje de error siguiente:

> >>>

> >>> "Paquete xulrunner-1.9.1 no se ha instalado."

> >>>

> >>> Desde entonces, aunque funciona bien el Ubuntu 18, no puedo

> >>> realizar ninguna actualización del sistema.

> >>>

> >>> He probado las órdenes de "upgrade", "update", "aptitude

> >>> reinstall" y las pocas que conozco, pero nada.

> >>>

> >>> Me dice que el paquete xulrunner está roto y me quedo como

> >>> antes.

> >>>

> >>> ¿Sabéis que puedo hacer?

> >>>

> >>> Muchas gracias por anticipado.

> >>>

> >>> Saludos de Angel

 

 


--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
Reply | Threaded
Open this post in threaded view
|

Re: Error xulrunner al actualizar a Ubuntu 18

Javier Garcia-3
In reply to this post by evangelsan evangelsan

Debes poner sudo dpkg --purge --force nombredelpaquete (con doble guion)

 

 

El lunes, 14 de enero de 2019 13:15:44 (CET) evangelsan evangelsan escribió:

> Parece que no funciona.

>

> Esto me dice al poner esa acción:

>

> dpkg: error: acciones en conflicto -f (--field) y -P (--purge)

>

> Saludos.

>

> > El 14 de enero de 2019 a las 12:49 Juan Francisco Guil Vázquez <[hidden email]> escribió:

> > prueba borrando el paquete con

> > dpkg --purge -force xulrunner-1.9.1 (o algo parecido)

> >

> > man dpkg

> >

> > Saludos

> >

> > El 14/01/2019 a las 10:05, evangelsan evangelsan escribió:

> > > Hola Arriero y demás compañeros de la lista.

> > >

> > > Sigo intentando desinstalar el paquete xulrunner-1.9.1 pero el

> > > sistema no me deja.

> > >

> > > Y este paquete es el que me está dando problemas.

> > >

> > > Esto es lo que me responde la terminal:

> > >

> > > Los siguientes paquetes se ELIMINARÁN:

> > > xulrunner-1.9.1

> > > 0 actualizados, 0 nuevos se instalarán, 1 para eliminar y 429 no

> > > actualizados. Se liberarán 21,9 MB después de esta operación.

> > > ¿Desea continuar? [S/n] s

> > > (Leyendo la base de datos ... 281664 ficheros o directorios

> > > instalados actualmente.) Desinstalando xulrunner-1.9.1

> > > (1.9.1.16+build2+nobinonly-0ubuntu0.9.10.1) ...

> > > /var/lib/dpkg/info/xulrunner-1.9.1.prerm: 8:

> > > /var/lib/dpkg/info/xulrunner-1.9.1.prerm:

> > > /usr/sbin/update-alternatives: not found dpkg: error al

> > > procesar el paquete xulrunner-1.9.1 (--remove):

> > > instalado xulrunner-1.9.1 paquete pre-removal guión el

> > > subproceso devolvió un error con estado de salida 127 Se

> > > encontraron errores al procesar:

> > > xulrunner-1.9.1

> > > E: Sub-process /usr/bin/dpkg returned an error code (1)

> > >

> > > Y así constantemente.

> > >

> > > He probado todas las órdenes que conozco y que me habéis

> > > señalado pero nada.

> > >

> > > ¿Alguien sabe como puedo forzar la eliminación de este paquete?

> > >

> > > ¿y que es?

> > >

> > > Saludos.

> > >

> > > Angel

> > >

> > > > > > El 13 de enero de 2019 a las 19:55 arriero <[hidden email]> mailto:[hidden email] escribió:

> > > > Perdón por la perdida del enlace.

> > > >

> > > >

> > > > http://curioseandolinux.blogspot.com/2010/10/reparar-paque

> > > > tes-rotos-o-mal-instalados.html?m=1> > >

> > > > El dom., 13 ene. 2019 13:08, evangelsan evangelsan < [hidden email] mailto:[hidden email] > escribió:

> > > > > ¿Que enlace, Arriero?

> > > > >

> > > > > Saludos

> > > > >

> > > > > Angel

> > > > >

> > > > > > > > > > El 13 de enero de 2019 a las 8:20 arriero < [hidden email] mailto:[hidden email] > escribió:

> > > > > > Puedes usar este enlace es casi lo mismo pero

> > > > > > hay varios comandos más.

> > > > > >

> > > > > > El jue., 10 ene. 2019 11:13, evangelsan evangelsan < [hidden email] mailto:[hidden email] > escribió:

> > > > > > > Hola amigos de la lista.

> > > > > > >

> > > > > > > Hace un par de meses actualicé al Ubuntu

> > > > > > > 18 a través de internet.

> > > > > > >

> > > > > > > Algo falló porque me dio el mensaje de

> > > > > > > error siguiente:

> > > > > > >

> > > > > > > "Paquete xulrunner-1.9.1 no se ha

> > > > > > > instalado."

> > > > > > >

> > > > > > > Desde entonces, aunque funciona bien el

> > > > > > > Ubuntu 18, no puedo realizar ninguna

> > > > > > > actualización del sistema.

> > > > > > >

> > > > > > > He probado las órdenes de "upgrade",

> > > > > > > "update", "aptitude reinstall" y las

> > > > > > > pocas que conozco, pero nada.

> > > > > > >

> > > > > > > Me dice que el paquete xulrunner está

> > > > > > > roto y me quedo como antes.

> > > > > > >

> > > > > > > ¿Sabéis que puedo hacer?

> > > > > > >

> > > > > > > Muchas gracias por anticipado.

> > > > > > >

> > > > > > > Saludos de Angel

> > > > > > >

> > > > > > > --

> > > > > > > ubuntu-es mailing list

> > > > > > > [hidden email]

> > > > > > > mailto:[hidden email]

> > > > > > > https://lists.ubuntu.com/mailman/listinf

> > > > > > > o/ubuntu-es

> > > >

> > > > --

>

> ubuntu-es mailing list

> [hidden email]

> https://lists.ubuntu.com/mailman/listinfo/ubuntu-es

 

 


--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
Reply | Threaded
Open this post in threaded view
|

Re: Error xulrunner al actualizar a Ubuntu 18

evangelsan evangelsan

Hola Javier.

Parece que tampoco funciona.

Esto me responde:

sudo du -sh /var/cache/apt
[sudo] contraseña para fugitiv1:
124M /var/cache/apt
fugitiv1@ordenador-desktop:~$ sudo apt clean
E: No se pudo bloquear /var/cache/apt/archives/lock - open (11: Recurso no disponible temporalmente)
E: No se pudo bloquear el directorio /var/cache/apt/archives/
fugitiv1@ordenador-desktop:~$ sudo apt autoclean
E: No se pudo bloquear /var/cache/apt/archives/lock - open (11: Recurso no disponible temporalmente)
E: No se puede bloquear el directorio de descarga
fugitiv1@ordenador-desktop:~$ sudo apt install --reinstall xulrunner
E: No se pudo bloquear /var/lib/dpkg/lock - open (11: Recurso no disponible temporalmente)
E: No se pudo bloquear el directorio de administración (/var/lib/dpkg/), ¿quizás haya algún otro proceso utilizándolo?
fugitiv1@ordenador-desktop:~$ apt install -f
E: No se pudo abrir el fichero de bloqueo «/var/lib/dpkg/lock» - open (13: Permiso denegado)
E: No se pudo bloquear el directorio de administración (/var/lib/dpkg/), ¿está como superusuario?

Y esto:

sudo dpkg --purge --force --xulrunner-1.9.1
dpkg: error: opción «force/refuse» desconocida `--xulrunner-1.9.1'

Escriba dpkg --help para ayuda sobre instalar y desinstalar paquetes [*];
Use `apt' o `aptitude' para una gestión de los paquetes más amigable;
Escriba dpkg -Dhelp para una lista de los valores de depuración de dpkg;
Escriba dpkg --force-help para una lista de las opciones para forzar cosas;
Escriba dpkg-deb --help para obtener ayuda sobre manipulación de archivos .deb;

Las opciones marcadas con [*] producen una salida extensa,
¡fíltrela con `less' o con `more'!

Es desesperante...

Saludos

El 14 de enero de 2019 a las 19:37 Javier Garcia <[hidden email]> escribió:

Debes poner sudo dpkg --purge --force nombredelpaquete (con doble guion)

 

 

El lunes, 14 de enero de 2019 13:15:44 (CET) evangelsan evangelsan escribió:

> Parece que no funciona.

>

> Esto me dice al poner esa acción:

>

> dpkg: error: acciones en conflicto -f (--field) y -P (--purge)

>

> Saludos.

>

> > El 14 de enero de 2019 a las 12:49 Juan Francisco Guil Vázquez <[hidden email]> escribió:

> > prueba borrando el paquete con

> > dpkg --purge -force xulrunner-1.9.1 (o algo parecido)

> >

> > man dpkg

> >

> > Saludos

> >

> > El 14/01/2019 a las 10:05, evangelsan evangelsan escribió:

> > > Hola Arriero y demás compañeros de la lista.

> > >

> > > Sigo intentando desinstalar el paquete xulrunner-1.9.1 pero el

> > > sistema no me deja.

> > >

> > > Y este paquete es el que me está dando problemas.

> > >

> > > Esto es lo que me responde la terminal:

> > >

> > > Los siguientes paquetes se ELIMINARÁN:

> > > xulrunner-1.9.1

> > > 0 actualizados, 0 nuevos se instalarán, 1 para eliminar y 429 no

> > > actualizados. Se liberarán 21,9 MB después de esta operación.

> > > ¿Desea continuar? [S/n] s

> > > (Leyendo la base de datos ... 281664 ficheros o directorios

> > > instalados actualmente.) Desinstalando xulrunner-1.9.1

> > > (1.9.1.16+build2+nobinonly-0ubuntu0.9.10.1) ...

> > > /var/lib/dpkg/info/xulrunner-1.9.1.prerm: 8:

> > > /var/lib/dpkg/info/xulrunner-1.9.1.prerm:

> > > /usr/sbin/update-alternatives: not found dpkg: error al

> > > procesar el paquete xulrunner-1.9.1 (--remove):

> > > instalado xulrunner-1.9.1 paquete pre-removal guión el

> > > subproceso devolvió un error con estado de salida 127 Se

> > > encontraron errores al procesar:

> > > xulrunner-1.9.1

> > > E: Sub-process /usr/bin/dpkg returned an error code (1)

> > >

> > > Y así constantemente.

> > >

> > > He probado todas las órdenes que conozco y que me habéis

> > > señalado pero nada.

> > >

> > > ¿Alguien sabe como puedo forzar la eliminación de este paquete?

> > >

> > > ¿y que es?

> > >

> > > Saludos.

> > >

> > > Angel

> > >

> > > > > > El 13 de enero de 2019 a las 19:55 arriero <[hidden email]> mailto:[hidden email] escribió:

> > > > Perdón por la perdida del enlace.

> > > >

> > > >

> > > > http://curioseandolinux.blogspot.com/2010/10/reparar-paque

> > > > tes-rotos-o-mal-instalados.html?m=1> > >

> > > > El dom., 13 ene. 2019 13:08, evangelsan evangelsan < [hidden email] mailto:[hidden email] > escribió:

> > > > > ¿Que enlace, Arriero?

> > > > >

> > > > > Saludos

> > > > >

> > > > > Angel

> > > > >

> > > > > > > > > > El 13 de enero de 2019 a las 8:20 arriero < [hidden email] mailto:[hidden email] > escribió:

> > > > > > Puedes usar este enlace es casi lo mismo pero

> > > > > > hay varios comandos más.

> > > > > >

> > > > > > El jue., 10 ene. 2019 11:13, evangelsan evangelsan < [hidden email] mailto:[hidden email] > escribió:

> > > > > > > Hola amigos de la lista.

> > > > > > >

> > > > > > > Hace un par de meses actualicé al Ubuntu

> > > > > > > 18 a través de internet.

> > > > > > >

> > > > > > > Algo falló porque me dio el mensaje de

> > > > > > > error siguiente:

> > > > > > >

> > > > > > > "Paquete xulrunner-1.9.1 no se ha

> > > > > > > instalado."

> > > > > > >

> > > > > > > Desde entonces, aunque funciona bien el

> > > > > > > Ubuntu 18, no puedo realizar ninguna

> > > > > > > actualización del sistema.

> > > > > > >

> > > > > > > He probado las órdenes de "upgrade",

> > > > > > > "update", "aptitude reinstall" y las

> > > > > > > pocas que conozco, pero nada.

> > > > > > >

> > > > > > > Me dice que el paquete xulrunner está

> > > > > > > roto y me quedo como antes.

> > > > > > >

> > > > > > > ¿Sabéis que puedo hacer?

> > > > > > >

> > > > > > > Muchas gracias por anticipado.

> > > > > > >

> > > > > > > Saludos de Angel

> > > > > > >

> > > > > > > --

> > > > > > > ubuntu-es mailing list

> > > > > > > [hidden email]

> > > > > > > mailto:[hidden email]

> > > > > > > https://lists.ubuntu.com/mailman/listinf

> > > > > > > o/ubuntu-es

> > > >

> > > > --

>

> ubuntu-es mailing list

> [hidden email]

> https://lists.ubuntu.com/mailman/listinfo/ubuntu-es

 

 


 

--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es


 


--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
Reply | Threaded
Open this post in threaded view
|

Re: Error xulrunner al actualizar a Ubuntu 18

Juan Francisco Guil Vázquez


El 15/01/2019 a las 9:09, evangelsan evangelsan escribió:

> fugitiv1@ordenador-desktop:~$ sudo apt install --reinstall xulrunner
> E: No se pudo bloquear /var/lib/dpkg/lock - open (11: Recurso no
> disponible temporalmente)
> E: No se pudo bloquear el directorio de administración
> (/var/lib/dpkg/), ¿quizás haya algún otro proceso utilizándolo?
> fugitiv1@ordenador-desktop:~$ apt install -f
> E: No se pudo abrir el fichero de bloqueo «/var/lib/dpkg/lock» - open
> (13: Permiso denegado)
> E: No se pudo bloquear el directorio de administración
> (/var/lib/dpkg/), ¿está como superusuario?
Has visto estos mensajes?

Para mi que lanzar un apt sin root y sin sudo como que no va a funcionar.

Saludos

--


--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
Reply | Threaded
Open this post in threaded view
|

Re: Error xulrunner al actualizar a Ubuntu 18

Juan Francisco Guil Vázquez
In reply to this post by evangelsan evangelsan


El 15/01/2019 a las 9:09, evangelsan evangelsan escribió:

sudo dpkg --purge --force --xulrunner-1.9.1
dpkg: error: opción «force/refuse» desconocida `--xulrunner-1.9.1'

Escriba dpkg --help para ayuda sobre instalar y desinstalar paquetes [*];
Use `apt' o `aptitude' para una gestión de los paquetes más amigable;
Escriba dpkg -Dhelp para una lista de los valores de depuración de dpkg;
Escriba dpkg --force-help para una lista de las opciones para forzar cosas;
Escriba dpkg-deb --help para obtener ayuda sobre manipulación de archivos .deb;

Las opciones marcadas con [*] producen una salida extensa,
¡fíltrela con `less' o con `more'!

Otra cosa, no lees que el comando esta mal lanzado?
Igual si practicas y miras en el man como se lanza bien, igual funciona.
Entiendo que la persona que te mando el comando lo mando de cabeza.

Saludos!
--


--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
Reply | Threaded
Open this post in threaded view
|

Re: Error xulrunner al actualizar a Ubuntu 18

Javier Garcia-3

El martes, 15 de enero de 2019 9:48:41 (CET) Juan Francisco Guil Vázquez escribió:

 

Mirate esta pagina, dicen como puedes solucionarlo.

 

https://itsfoss.com/fix-ubuntu-install-error/

 

 

> El 15/01/2019 a las 9:09, evangelsan evangelsan escribió:

> > sudo dpkg --purge --force --xulrunner-1.9.1

> > *dpkg: error: opción «force/refuse» desconocida `--xulrunner-1.9.1'*

> >

> > Escriba dpkg --help para ayuda sobre instalar y desinstalar paquetes [*];

> > Use `apt' o `aptitude' para una gestión de los paquetes más amigable;

> > Escriba dpkg -Dhelp para una lista de los valores de depuración de dpkg;

> > Escriba dpkg --force-help para una lista de las opciones para forzar

> > cosas;

> > Escriba dpkg-deb --help para obtener ayuda sobre manipulación de

> > archivos .deb;

> >

> > Las opciones marcadas con [*] producen una salida extensa,

> > ¡fíltrela con `less' o con `more'!

 

 


--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
Reply | Threaded
Open this post in threaded view
|

Re: Error xulrunner al actualizar a Ubuntu 18

evangelsan evangelsan

Parece que tampoco funciona.

Esto me da la terminal:

Tal vez quiera ejecutar «apt --fix-broken install» para corregirlo.
Los siguientes paquetes tienen dependencias incumplidas:
xulrunner-1.9.1 : Depende: libnspr4-0d (>= 4.7.3-0ubuntu1~) pero no es instalable
Depende: libnss3-1d (>= 3.12.6) pero no es instalable
E: Dependencias incumplidas. Intente «apt --fix-broken install» sin paquetes (o especifique una solución).
fugitiv1@ordenador-desktop:~$ apt --fix-broken install
E: No se pudo abrir el fichero de bloqueo «/var/lib/dpkg/lock» - open (13: Permiso denegado)
E: No se pudo bloquear el directorio de administración (/var/lib/dpkg/), ¿está como superusuario?
fugitiv1@ordenador-desktop:~$ sudo killall apt-get
apt-get: proceso no encontrado
fugitiv1@ordenador-desktop:~$ sudo rm /var/lib/apt/lists/lock
rm: no se puede borrar '/var/lib/apt/lists/lock': No existe el archivo o el directorio
fugitiv1@ordenador-desktop:~$ sudo rm /var/cache/apt/archives/lock
fugitiv1@ordenador-desktop:~$ sudo rm /var/lib/dpkg/lock
fugitiv1@ordenador-desktop:~$ sudo dpkg --configure -a

Saludos

El 15 de enero de 2019 a las 12:27 Javier Garcia <[hidden email]> escribió:

El martes, 15 de enero de 2019 9:48:41 (CET) Juan Francisco Guil Vázquez escribió:

 

Mirate esta pagina, dicen como puedes solucionarlo.

 

https://itsfoss.com/fix-ubuntu-install-error/

 

 

> El 15/01/2019 a las 9:09, evangelsan evangelsan escribió:

> > sudo dpkg --purge --force --xulrunner-1.9.1

> > *dpkg: error: opción «force/refuse» desconocida `--xulrunner-1.9.1'*

> >

> > Escriba dpkg --help para ayuda sobre instalar y desinstalar paquetes [*];

> > Use `apt' o `aptitude' para una gestión de los paquetes más amigable;

> > Escriba dpkg -Dhelp para una lista de los valores de depuración de dpkg;

> > Escriba dpkg --force-help para una lista de las opciones para forzar

> > cosas;

> > Escriba dpkg-deb --help para obtener ayuda sobre manipulación de

> > archivos .deb;

> >

> > Las opciones marcadas con [*] producen una salida extensa,

> > ¡fíltrela con `less' o con `more'!

 

 


 

--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es


 


--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
Reply | Threaded
Open this post in threaded view
|

Re: Error xulrunner al actualizar a Ubuntu 18

braiam
Hola,

Por favor, envia el resultado de dpkg -C y haz reiniciado el equipo
desde que tienes este
problema?

On Wed, Jan 16, 2019 at 5:42 AM evangelsan evangelsan
<[hidden email]> wrote:

>
> Parece que tampoco funciona.
>
> Esto me da la terminal:
>
> Tal vez quiera ejecutar «apt --fix-broken install» para corregirlo.
> Los siguientes paquetes tienen dependencias incumplidas:
> xulrunner-1.9.1 : Depende: libnspr4-0d (>= 4.7.3-0ubuntu1~) pero no es instalable
> Depende: libnss3-1d (>= 3.12.6) pero no es instalable
> E: Dependencias incumplidas. Intente «apt --fix-broken install» sin paquetes (o especifique una solución).
> fugitiv1@ordenador-desktop:~$ apt --fix-broken install
> E: No se pudo abrir el fichero de bloqueo «/var/lib/dpkg/lock» - open (13: Permiso denegado)
> E: No se pudo bloquear el directorio de administración (/var/lib/dpkg/), ¿está como superusuario?
> fugitiv1@ordenador-desktop:~$ sudo killall apt-get
> apt-get: proceso no encontrado
> fugitiv1@ordenador-desktop:~$ sudo rm /var/lib/apt/lists/lock
> rm: no se puede borrar '/var/lib/apt/lists/lock': No existe el archivo o el directorio
> fugitiv1@ordenador-desktop:~$ sudo rm /var/cache/apt/archives/lock
> fugitiv1@ordenador-desktop:~$ sudo rm /var/lib/dpkg/lock
> fugitiv1@ordenador-desktop:~$ sudo dpkg --configure -a
>
> Saludos
>
> El 15 de enero de 2019 a las 12:27 Javier Garcia <[hidden email]> escribió:
>
> El martes, 15 de enero de 2019 9:48:41 (CET) Juan Francisco Guil Vázquez escribió:
>
>
>
> Mirate esta pagina, dicen como puedes solucionarlo.
>
>
>
> https://itsfoss.com/fix-ubuntu-install-error/
>
>
>
>
>
> > El 15/01/2019 a las 9:09, evangelsan evangelsan escribió:
>
> > > sudo dpkg --purge --force --xulrunner-1.9.1
>
> > > *dpkg: error: opción «force/refuse» desconocida `--xulrunner-1.9.1'*
>
> > >
>
> > > Escriba dpkg --help para ayuda sobre instalar y desinstalar paquetes [*];
>
> > > Use `apt' o `aptitude' para una gestión de los paquetes más amigable;
>
> > > Escriba dpkg -Dhelp para una lista de los valores de depuración de dpkg;
>
> > > Escriba dpkg --force-help para una lista de las opciones para forzar
>
> > > cosas;
>
> > > Escriba dpkg-deb --help para obtener ayuda sobre manipulación de
>
> > > archivos .deb;
>
> > >
>
> > > Las opciones marcadas con [*] producen una salida extensa,
>
> > > ¡fíltrela con `less' o con `more'!
>
>
>
>
>
>
>
>
> --
> ubuntu-es mailing list
> [hidden email]
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
>
>
>
>
> --
> ubuntu-es mailing list
> [hidden email]
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-es



--
Braiam

--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
Reply | Threaded
Open this post in threaded view
|

Re: Error xulrunner al actualizar a Ubuntu 18

evangelsan evangelsan
Hola Braiam.
No entiendo que me quieres decir exactamente.
El equipo lo he reiniciado unas cuantas veces desde que tengo este problema.
Saludos.

> El 16 de enero de 2019 a las 14:22 Braiam Peguero <[hidden email]> escribió:
>
>
> Hola,
>
> Por favor, envia el resultado de dpkg -C y haz reiniciado el equipo
> desde que tienes este
> problema?
>
> On Wed, Jan 16, 2019 at 5:42 AM evangelsan evangelsan
> <[hidden email]> wrote:
> >
> > Parece que tampoco funciona.
> >
> > Esto me da la terminal:
> >
> > Tal vez quiera ejecutar «apt --fix-broken install» para corregirlo.
> > Los siguientes paquetes tienen dependencias incumplidas:
> > xulrunner-1.9.1 : Depende: libnspr4-0d (>= 4.7.3-0ubuntu1~) pero no es instalable
> > Depende: libnss3-1d (>= 3.12.6) pero no es instalable
> > E: Dependencias incumplidas. Intente «apt --fix-broken install» sin paquetes (o especifique una solución).
> > fugitiv1@ordenador-desktop:~$ apt --fix-broken install
> > E: No se pudo abrir el fichero de bloqueo «/var/lib/dpkg/lock» - open (13: Permiso denegado)
> > E: No se pudo bloquear el directorio de administración (/var/lib/dpkg/), ¿está como superusuario?
> > fugitiv1@ordenador-desktop:~$ sudo killall apt-get
> > apt-get: proceso no encontrado
> > fugitiv1@ordenador-desktop:~$ sudo rm /var/lib/apt/lists/lock
> > rm: no se puede borrar '/var/lib/apt/lists/lock': No existe el archivo o el directorio
> > fugitiv1@ordenador-desktop:~$ sudo rm /var/cache/apt/archives/lock
> > fugitiv1@ordenador-desktop:~$ sudo rm /var/lib/dpkg/lock
> > fugitiv1@ordenador-desktop:~$ sudo dpkg --configure -a
> >
> > Saludos
> >
> > El 15 de enero de 2019 a las 12:27 Javier Garcia <[hidden email]> escribió:
> >
> > El martes, 15 de enero de 2019 9:48:41 (CET) Juan Francisco Guil Vázquez escribió:
> >
> >
> >
> > Mirate esta pagina, dicen como puedes solucionarlo.
> >
> >
> >
> > https://itsfoss.com/fix-ubuntu-install-error/
> >
> >
> >
> >
> >
> > > El 15/01/2019 a las 9:09, evangelsan evangelsan escribió:
> >
> > > > sudo dpkg --purge --force --xulrunner-1.9.1
> >
> > > > *dpkg: error: opción «force/refuse» desconocida `--xulrunner-1.9.1'*
> >
> > > >
> >
> > > > Escriba dpkg --help para ayuda sobre instalar y desinstalar paquetes [*];
> >
> > > > Use `apt' o `aptitude' para una gestión de los paquetes más amigable;
> >
> > > > Escriba dpkg -Dhelp para una lista de los valores de depuración de dpkg;
> >
> > > > Escriba dpkg --force-help para una lista de las opciones para forzar
> >
> > > > cosas;
> >
> > > > Escriba dpkg-deb --help para obtener ayuda sobre manipulación de
> >
> > > > archivos .deb;
> >
> > > >
> >
> > > > Las opciones marcadas con [*] producen una salida extensa,
> >
> > > > ¡fíltrela con `less' o con `more'!
> >
> >
> >
> >
> >
> >
> >
> >
> > --
> > ubuntu-es mailing list
> > [hidden email]
> > https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
> >
> >
> >
> >
> > --
> > ubuntu-es mailing list
> > [hidden email]
> > https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
>
>
>
> --
> Braiam

--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
Reply | Threaded
Open this post in threaded view
|

Re: Error xulrunner al actualizar a Ubuntu 18

braiam
> E: No se pudo bloquear /var/cache/apt/archives/lock - open (11: Recurso no disponible temporalmente)

Usualmente significa que otra instancia de apt esta corriendo. Algunas
veces apt se queda atascado y
un reinicio lo soluciona.

> /var/lib/dpkg/info/xulrunner-1.9.1.prerm: 8: /var/lib/dpkg/info/xulrunner-1.9.1.prerm: /usr/sbin/update-alternatives: not found

Indica que dpkg fallo al correr el preremoval script. dpkg -C puede
dar indicación de cuales paquetes
faltan por configurar correctamente y si existen alguna dependencia
que no se cumple. Por favor
corre dpkg -C en la linea de comandos y envía *todo* lo que dice.

On Thu, Jan 17, 2019 at 4:43 AM evangelsan evangelsan
<[hidden email]> wrote:

>
> Hola Braiam.
> No entiendo que me quieres decir exactamente.
> El equipo lo he reiniciado unas cuantas veces desde que tengo este problema.
> Saludos.
>
> > El 16 de enero de 2019 a las 14:22 Braiam Peguero <[hidden email]> escribió:
> >
> >
> > Hola,
> >
> > Por favor, envia el resultado de dpkg -C y haz reiniciado el equipo
> > desde que tienes este
> > problema?
> >
> > On Wed, Jan 16, 2019 at 5:42 AM evangelsan evangelsan
> > <[hidden email]> wrote:
> > >
> > > Parece que tampoco funciona.
> > >
> > > Esto me da la terminal:
> > >
> > > Tal vez quiera ejecutar «apt --fix-broken install» para corregirlo.
> > > Los siguientes paquetes tienen dependencias incumplidas:
> > > xulrunner-1.9.1 : Depende: libnspr4-0d (>= 4.7.3-0ubuntu1~) pero no es instalable
> > > Depende: libnss3-1d (>= 3.12.6) pero no es instalable
> > > E: Dependencias incumplidas. Intente «apt --fix-broken install» sin paquetes (o especifique una solución).
> > > fugitiv1@ordenador-desktop:~$ apt --fix-broken install
> > > E: No se pudo abrir el fichero de bloqueo «/var/lib/dpkg/lock» - open (13: Permiso denegado)
> > > E: No se pudo bloquear el directorio de administración (/var/lib/dpkg/), ¿está como superusuario?
> > > fugitiv1@ordenador-desktop:~$ sudo killall apt-get
> > > apt-get: proceso no encontrado
> > > fugitiv1@ordenador-desktop:~$ sudo rm /var/lib/apt/lists/lock
> > > rm: no se puede borrar '/var/lib/apt/lists/lock': No existe el archivo o el directorio
> > > fugitiv1@ordenador-desktop:~$ sudo rm /var/cache/apt/archives/lock
> > > fugitiv1@ordenador-desktop:~$ sudo rm /var/lib/dpkg/lock
> > > fugitiv1@ordenador-desktop:~$ sudo dpkg --configure -a
> > >
> > > Saludos
> > >
> > > El 15 de enero de 2019 a las 12:27 Javier Garcia <[hidden email]> escribió:
> > >
> > > El martes, 15 de enero de 2019 9:48:41 (CET) Juan Francisco Guil Vázquez escribió:
> > >
> > >
> > >
> > > Mirate esta pagina, dicen como puedes solucionarlo.
> > >
> > >
> > >
> > > https://itsfoss.com/fix-ubuntu-install-error/
> > >
> > >
> > >
> > >
> > >
> > > > El 15/01/2019 a las 9:09, evangelsan evangelsan escribió:
> > >
> > > > > sudo dpkg --purge --force --xulrunner-1.9.1
> > >
> > > > > *dpkg: error: opción «force/refuse» desconocida `--xulrunner-1.9.1'*
> > >
> > > > >
> > >
> > > > > Escriba dpkg --help para ayuda sobre instalar y desinstalar paquetes [*];
> > >
> > > > > Use `apt' o `aptitude' para una gestión de los paquetes más amigable;
> > >
> > > > > Escriba dpkg -Dhelp para una lista de los valores de depuración de dpkg;
> > >
> > > > > Escriba dpkg --force-help para una lista de las opciones para forzar
> > >
> > > > > cosas;
> > >
> > > > > Escriba dpkg-deb --help para obtener ayuda sobre manipulación de
> > >
> > > > > archivos .deb;
> > >
> > > > >
> > >
> > > > > Las opciones marcadas con [*] producen una salida extensa,
> > >
> > > > > ¡fíltrela con `less' o con `more'!
> > >
> > >
> > >
> > >
> > >
> > >
> > >
> > >
> > > --
> > > ubuntu-es mailing list
> > > [hidden email]
> > > https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
> > >
> > >
> > >
> > >
> > > --
> > > ubuntu-es mailing list
> > > [hidden email]
> > > https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
> >
> >
> >
> > --
> > Braiam



--
Braiam

--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
Reply | Threaded
Open this post in threaded view
|

Re: Error xulrunner al actualizar a Ubuntu 18

Mauricio J. Adonis C.
In reply to this post by evangelsan evangelsan
El jue, 10-01-2019 a las 11:11 +0100, evangelsan evangelsan escribió:

> Hola amigos de la lista.
> Hace un par de meses actualicé al Ubuntu 18 a través de internet.
> Algo falló porque me dio el mensaje de error siguiente:
> "Paquete xulrunner-1.9.1 no se ha instalado."
> Desde entonces, aunque funciona bien el Ubuntu 18, no puedo realizar
> ninguna actualización del sistema.
> He probado las órdenes de "upgrade", "update", "aptitude reinstall" y
> las pocas que conozco, pero nada.
> Me dice que el paquete xulrunner está roto y me quedo como antes.
> ¿Sabéis que puedo hacer?
> Muchas gracias por anticipado.
> Saludos de Angel

Hola Angel.
'XULRunner es un esquema de funcionalidades (framework) que puede ser
utilizado para ejecutarse independientemente (standalone) o embebido en
aplicaciones basadas en el framework Mozilla.', es optativo, no es
dependencia de nada y NO está en los repositorios de Bionic (Ubuntu
18.04), así que simplemente eliminando el paquete debería solucionarse
el problema...

sudo apt-get purge xulrunner
sudo apt-get autoremove
sudo apt-get clean

Si necesitaras el software puedes ir al sitio...
https://developer.mozilla.org/es/docs/Archive/Mozilla/XULRunner

Saludos,
Mauricio J. Adonis C.


--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
12