Quantcast

Errors during upgrade from 16.04 to 16.10

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Errors during upgrade from 16.04 to 16.10

Valter Mura-2
Hi All

after having run the upgrade manager, it freezed before installing all the packages.

Luckily, my system still works but I get some errors which I'm not able to solve by myself, and some features are lost. These are the errors that apt-get returns to me:

=====
It is useful to execute "apt-get -f install" to correct this.
I seguenti pacchetti hanno dipendenze non soddisfatte:
 gwenview : Dipende: libkf5kipi-bin (>= 16.04) ma non è installato
 hplip : Dipende: hplip-data (= 3.16.7+repack0-1ubuntu1) ma la versione 3.16.3+repack0-1 è installata
         Dipende: printer-driver-hpcups (= 3.16.7+repack0-1ubuntu1) ma la versione 3.16.3+repack0-1 è installata
 kde-runtime : Dipende: libwebp6 (>= 0.5.1) ma non è installato
 kde-spectacle : Dipende: libkf5kipi-bin (>= 16.04) ma non è installato
                 Dipende: libkf5screen7 (>= 4:5.6.3) ma non è installato
 kscreen : Dipende: libkf5screen7 (>= 4:5.6.3) ma non è installato
 libkf5i18n-data : Rompe: kde-l10n-it (< 4:16.04.2) ma la versione 4:15.12.3-0ubuntu1.1 è installata
 plasma-desktop-data : Rompe: kde-l10n-it (< 4:15.12.3-0ubuntu3~) ma la versione 4:15.12.3-0ubuntu1.1 è installata
 python : Pre-dipende: python-minimal (= 2.7.11-1) ma la versione 2.7.11-2 è installata
 samba-libs : Dipende: python-talloc (>= 2.1.6) ma la versione 2.1.5-2 è installata
E: Dipendenze non trovate. Riprovare usando -f.
=====

I tried "apt-get -f install" with no success, because I get:

===========
valter@valter-desktop:~$ sudo apt-get -f install
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
  linux-headers-4.4.0-21 linux-headers-4.4.0-21-generic linux-headers-4.4.0-22
  linux-headers-4.4.0-22-generic linux-headers-4.4.0-23 linux-headers-4.4.0-23-generic
  linux-headers-4.4.0-24 linux-headers-4.4.0-24-generic linux-headers-4.4.0-27
  linux-headers-4.4.0-27-generic linux-headers-4.4.0-34 linux-headers-4.4.0-34-generic
  linux-headers-4.4.0-36 linux-headers-4.4.0-36-generic linux-headers-4.4.0-43
  linux-headers-4.4.0-43-generic linux-headers-4.4.0-45 linux-headers-4.4.0-45-generic
  linux-image-4.4.0-21-generic linux-image-4.4.0-22-generic
  linux-image-4.4.0-23-generic linux-image-4.4.0-24-generic
  linux-image-4.4.0-27-generic linux-image-4.4.0-34-generic
  linux-image-4.4.0-36-generic linux-image-4.4.0-43-generic
  linux-image-4.4.0-45-generic linux-image-extra-4.4.0-21-generic
  linux-image-extra-4.4.0-22-generic linux-image-extra-4.4.0-23-generic
  linux-image-extra-4.4.0-24-generic linux-image-extra-4.4.0-27-generic
  linux-image-extra-4.4.0-34-generic linux-image-extra-4.4.0-36-generic
  linux-image-extra-4.4.0-43-generic linux-image-extra-4.4.0-45-generic
  python3-dbus.mainloop.qt
Usare "sudo apt autoremove" per rimuoverli.
The following additional packages will be installed:
  hplip-data kde-l10n-it libkf5kexiv2-15.0.0 libkf5kipi-bin libkf5screen-bin
  libkf5screen7 libpowerdevilcore2 libpython-stdlib libwebp6 printer-driver-hpcups
  python python-talloc
Pacchetti suggeriti:
  hplip-doc python-doc python-tk
I seguenti pacchetti saranno RIMOSSI:
  libkf5kipi30.0.0 libkf5screen6
I seguenti pacchetti NUOVI saranno installati:
  libkf5kexiv2-15.0.0 libkf5kipi-bin libkf5screen7 libwebp6
I seguenti pacchetti saranno aggiornati:
  hplip-data kde-l10n-it libkf5screen-bin libpowerdevilcore2 libpython-stdlib
  printer-driver-hpcups python python-talloc
8 aggiornati, 4 installati, 2 da rimuovere e 753 non aggiornati.
712 non completamente installati o rimossi.
È necessario scaricare 0 B/17,2 MB di archivi.
Dopo quest'operazione, verranno occupati 2.161 kB di spazio su disco.
Continuare? [S/n] s
(Lettura del database... 500886 file e directory attualmente installati.)
Preparativi per estrarre .../kde-l10n-it_4%3a16.04.3-0ubuntu1_all.deb...
Estrazione di kde-l10n-it (4:16.04.3-0ubuntu1) su (4:15.12.3-0ubuntu1.1)...
dpkg: errore nell'elaborare l'archivio /var/cache/apt/archives/kde-l10n-it_4%3a16.04.3-0ubuntu1_all.deb (--unpack):
 tentata sovrascrittura di "/usr/share/doc/HTML/it/khelpcenter/index.cache.bz2" presente anche nel pacchetto khelpcenter 4:5.5.5-0ubuntu1
dpkg-deb: errore: il sottoprocesso paste è stato terminato dal segnale (Pipe interrotta)
Si sono verificati degli errori nell'elaborazione:
 /var/cache/apt/archives/kde-l10n-it_4%3a16.04.3-0ubuntu1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
==============

Does anybody has any hint/suggestion? TIA

Regards

--
Valter
*Open Source is better!*
KDE: www.kde.org
Kubuntu: www.kubuntu.org
LibreOffice: www.libreoffice.org

--
kubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Errors during upgrade from 16.04 to 16.10

Nils Kassube-2
Valter Mura wrote:

> after having run the upgrade manager, it freezed before installing all
> the packages.
>
> Luckily, my system still works but I get some errors which I'm not
> able to solve by myself, and some features are lost. These are the
> errors that apt-get returns to me:
>
> =====
> It is useful to execute "apt-get -f install" to correct this.
> I seguenti pacchetti hanno dipendenze non soddisfatte:
>  gwenview : Dipende: libkf5kipi-bin (>= 16.04) ma non è installato
>  hplip : Dipende: hplip-data (= 3.16.7+repack0-1ubuntu1) ma la
> versione 3.16.3+repack0-1 è installata
>          Dipende: printer-driver-hpcups (= 3.16.7+repack0-1ubuntu1) ma
> la versione 3.16.3+repack0-1 è installata

I'm not sure what those messages mean - could you run the command again
as

LC_ALL=C sudo apt-get -f install

to have the messages in English. That would make it easier for us to
diagnose.

But from what I remember, it probably means something like gwenview
depends on libkf5kipi-bin (>= 16.04) which can't be installed because
another version is already installed and another package depends on it.
And hplip depends on hplip-data (= 3.16.7+repack0-1ubuntu1) but version
3.16.3+repack0-1 is installed.

I think for each package that can't be installed you should search for
the package which prevents installing the new version and manually
remove that offending package and then try to install the new version.
It may take a long time though to resolve everything manually.


Nils


--
kubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
Loading...