Ethernet Network device not managed

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Ethernet Network device not managed

Giovanni Pili
Buongiorno a tutti,

prima di tutto grazie a chiunque prenda in considerazione questa e-mail e grazie a chi riuscirà a darmi una mano.

Sto cercando di portare linux nella scuola con cui collaboro. Purtroppo come da oggetto attraverso la GUI non riesco a gestire l'interfaccia di rete.
Per cercare di risolvere il problema ho installato sul mio pc VirtualBox versione 5.2.28 r121009 e mi sono creato una macchina virtuale con UBUNTU SERVER 17.10 (senza GUI).
La scheda di rete risulta correttamente configurata in quanto posso pingare qualunque indirizzo ip.

Questo è il risultato dopo aver eseguito il comando ifconfig -a
enp0s3: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 79.6.22.2  netmask 255.255.255.0  broadcast 79.6.22.255
        inet6 fe80::a00:27ff:fe02:d12f  prefixlen 64  scopeid 0x20<link>
        ether 08:00:27:02:d1:2f  txqueuelen 1000  (Ethernet)
        RX packets 4301  bytes 1251138 (1.2 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 721  bytes 56344 (56.3 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Loopback locale)
        RX packets 128  bytes 10316 (10.3 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 128  bytes 10316 (10.3 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Con il comando lspci potete vedere le varie caratteristiche
00:00.0 Host bridge: Intel Corporation 440FX - 82441FX PMC [Natoma] (rev 02)
00:01.0 ISA bridge: Intel Corporation 82371SB PIIX3 ISA [Natoma/Triton II]
00:01.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:02.0 VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter
00:03.0 Ethernet controller: Intel Corporation 82540EM Gigabit Ethernet Controller (rev 02)
00:04.0 System peripheral: InnoTek Systemberatung GmbH VirtualBox Guest Service
00:05.0 Multimedia audio controller: Intel Corporation 82801AA AC'97 Audio Controller (rev 01)
00:07.0 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 08)
00:0c.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller
00:0d.0 SATA controller: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) SATA Controller [AHCI mode] (rev 02)

Questo è il contenuto del file /etc/network/interfaces
# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
# Generated by debian-installer.

# The loopback interface
auto lo
iface lo inet loopback

Questo è il contenuto del file /etc/NetworkManager/NetworkManager.conf
[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false

[device]
wifi.scan-rand-mac-address=no

Poiché il server dovrà essere una postazione utilizzata dal professore sono obbligato, mio malgrado, ad installare una GUI e siccome le caratteristiche hardware non sono di ultima generazione ho deciso di installare la GUI di XUBUNTU. Per fare ciò ho quindi proceduto come segue:

sudo tasksel

Selezionato ed installato la GUI xubuntu-desktop-minimal (la configurazione di tutti i pacchetti è avvenuta automaticamente)

Reboot

Dopo che la GUI si è avviata automaticamente ed aver effettuato l'accesso come Administrator ho constatato che l'interfaccia grafica per la gestione delle connessioni di rete restituisce il messaggio "Ethernet Network device not managed". Di fatto da terminale o da browser sono in grado di pingare e visualizzare qualunque sito web

Rimango in attesa di un vostro gentile supporto.

Saluti e buon lavoro.
Giovanni Pili


--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette
Reply | Threaded
Open this post in threaded view
|

Re: Ethernet Network device not managed

Daniele Piccoli
Il 02/03/2018 15:20, Giovanni Pili ha scritto:

> Buongiorno a tutti,
>
> prima di tutto grazie a chiunque prenda in considerazione questa e-mail
> e grazie a chi riuscirà a darmi una mano.
>
> Sto cercando di portare linux nella scuola con cui collaboro. Purtroppo
> come da oggetto attraverso la GUI non riesco a gestire l'interfaccia di
> rete.
> Per cercare di risolvere il problema ho installato sul mio pc VirtualBox
> versione 5.2.28 r121009 e mi sono creato una macchina virtuale con
> UBUNTU SERVER 17.10 (senza GUI).
> La scheda di rete risulta correttamente configurata in quanto posso
> pingare qualunque indirizzo ip.

[cut]

>
> _Questo è il contenuto del file */etc/network/interfaces
> *_# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
> # Generated by debian-installer.
>
> # The loopback interface
> auto lo
> iface lo inet loopback
>
> _Questo è il contenuto del file */etc/NetworkManager/NetworkManager.conf
> *_[main]
> plugins=ifupdown,keyfile
>
> [ifupdown]
> managed=false
>
> [device]
> wifi.scan-rand-mac-address=no

Ti suggerirei di provare a cambiare la linea managed=false in managed=true

Dopo di che salvi il file e fai un restart di NetworkManager (systemctl
restart NetworkManager.service)

> Poiché il server dovrà essere una postazione utilizzata dal professore
> sono obbligato, mio malgrado, ad installare una GUI e siccome le
> caratteristiche hardware non sono di ultima generazione ho deciso di
> installare la GUI di XUBUNTU. Per fare ciò ho quindi proceduto come segue:
>
> *sudo tasksel*
>
> *Selezionato ed installato la GUI xubuntu-desktop-minimal* /(la
> configurazione di tutti i pacchetti è avvenuta automaticamente)/
>
> *Reboot*
>
> Dopo che la GUI si è avviata automaticamente ed aver effettuato
> l'accesso come Administrator ho constatato che l'interfaccia grafica per
> la gestione delle connessioni di rete restituisce il messaggio
> *"_/Ethernet Network device not managed/_/"/*. Di fatto da terminale o
> da browser sono in grado di pingare e visualizzare qualunque sito web
>
> Rimango in attesa di un vostro gentile supporto.
>
> Saluti e buon lavoro.
> Giovanni Pili

Buona serata
Daniele

--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette
Reply | Threaded
Open this post in threaded view
|

Re: Ethernet Network device not managed

Giovanni Pili
Ciao,

prima di tutto ti ringrazio per la risposta Daniele. Nella precedente e-mail ho commesso un errore di copia/incolla in quanto ho lasciato intendere che il Network Manager fosse già installato quando ho installato la GUI. Ho comunque apportato le modifiche come da te indicato e purtroppo nulla è cambiato. Di seguito ti elenco i siti web che ho visitato per riuscire a risolvere il problema:
  1. https://ubuntuforums.org/showthread.php?t=2358631
  2. https://ubuntuforums.org/showthread.php?t=1007294
  3. https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1658921
In realtà ho googlato anche altri siti web ma nessuno mi è stato utile.

In attesa di una possibile soluzione ancora grazie.

Buona serata

Giovanni Pili


Il giorno 3 marzo 2018 19:56, Daniele Piccoli <[hidden email]> ha scritto:
Il 02/03/2018 15:20, Giovanni Pili ha scritto:
> Buongiorno a tutti,
>
> prima di tutto grazie a chiunque prenda in considerazione questa e-mail
> e grazie a chi riuscirà a darmi una mano.
>
> Sto cercando di portare linux nella scuola con cui collaboro. Purtroppo
> come da oggetto attraverso la GUI non riesco a gestire l'interfaccia di
> rete.
> Per cercare di risolvere il problema ho installato sul mio pc VirtualBox
> versione 5.2.28 r121009 e mi sono creato una macchina virtuale con
> UBUNTU SERVER 17.10 (senza GUI).
> La scheda di rete risulta correttamente configurata in quanto posso
> pingare qualunque indirizzo ip.

[cut]

>
> _Questo è il contenuto del file */etc/network/interfaces
> *_# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
> # Generated by debian-installer.
>
> # The loopback interface
> auto lo
> iface lo inet loopback
>
> _Questo è il contenuto del file */etc/NetworkManager/NetworkManager.conf
> *_[main]
> plugins=ifupdown,keyfile
>
> [ifupdown]
> managed=false
>
> [device]
> wifi.scan-rand-mac-address=no

Ti suggerirei di provare a cambiare la linea managed=false in managed=true

Dopo di che salvi il file e fai un restart di NetworkManager (systemctl
restart NetworkManager.service)

> Poiché il server dovrà essere una postazione utilizzata dal professore
> sono obbligato, mio malgrado, ad installare una GUI e siccome le
> caratteristiche hardware non sono di ultima generazione ho deciso di
> installare la GUI di XUBUNTU. Per fare ciò ho quindi proceduto come segue:
>
> *sudo tasksel*
>
> *Selezionato ed installato la GUI xubuntu-desktop-minimal* /(la
> configurazione di tutti i pacchetti è avvenuta automaticamente)/
>
> *Reboot*
>
> Dopo che la GUI si è avviata automaticamente ed aver effettuato
> l'accesso come Administrator ho constatato che l'interfaccia grafica per
> la gestione delle connessioni di rete restituisce il messaggio
> *"_/Ethernet Network device not managed/_/"/*. Di fatto da terminale o
> da browser sono in grado di pingare e visualizzare qualunque sito web
>
> Rimango in attesa di un vostro gentile supporto.
>
> Saluti e buon lavoro.
> Giovanni Pili

Buona serata
Daniele

--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette


--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette
Reply | Threaded
Open this post in threaded view
|

Re: Ethernet Network device not managed

Daniele Piccoli
Il 04/03/2018 21:41, Giovanni Pili ha scritto:

> Ciao,
>
> prima di tutto ti ringrazio per la risposta Daniele. Nella precedente
> e-mail ho commesso un errore di copia/incolla in quanto ho lasciato
> intendere che il Network Manager fosse già installato quando ho
> installato la GUI. Ho comunque apportato le modifiche come da te
> indicato e purtroppo nulla è cambiato. Di seguito ti elenco i siti web
> che ho visitato per riuscire a risolvere il problema:
>
>  1. https://ubuntuforums.org/showthread.php?t=2358631
>  2. https://ubuntuforums.org/showthread.php?t=1007294
>  3. https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1658921

Partendo dal link n° 3, hai provato i consigli suggeriti nei commenti #6
e #7 ?

> In realtà ho googlato anche altri siti web ma nessuno mi è stato utile.
>
> In attesa di una possibile soluzione ancora grazie.
>
> Buona serata
>
> Giovanni Pili
>

Ciao

Daniele

--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette
Reply | Threaded
Open this post in threaded view
|

Re: Ethernet Network device not managed

Giovanni Pili
Ciao,

ho eseguito tutte le istruzioni suggerite nel link n° 3. Purtroppo nessuna di queste istruzioni è stata utile. E' possibile che nella versione ubuntu 17.10 il problema non sia stato ancora risolto? Inoltre ho letto che il network-manager risulta "deprecated" e al suo posto viene utilizzato "netplan" Non sarebbe opportuno disinstallare il NetworkManager in favore di Netplan?

Rimango in attesa di un riscontro.

Buona giornata

Giovanni Pili


Il giorno 5 marzo 2018 18:32, Daniele Piccoli <[hidden email]> ha scritto:
Il 04/03/2018 21:41, Giovanni Pili ha scritto:
> Ciao,
>
> prima di tutto ti ringrazio per la risposta Daniele. Nella precedente
> e-mail ho commesso un errore di copia/incolla in quanto ho lasciato
> intendere che il Network Manager fosse già installato quando ho
> installato la GUI. Ho comunque apportato le modifiche come da te
> indicato e purtroppo nulla è cambiato. Di seguito ti elenco i siti web
> che ho visitato per riuscire a risolvere il problema:
>
>  1. https://ubuntuforums.org/showthread.php?t=2358631
>  2. https://ubuntuforums.org/showthread.php?t=1007294
>  3. https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1658921

Partendo dal link n° 3, hai provato i consigli suggeriti nei commenti #6
e #7 ?

> In realtà ho googlato anche altri siti web ma nessuno mi è stato utile.
>
> In attesa di una possibile soluzione ancora grazie.
>
> Buona serata
>
> Giovanni Pili
>

Ciao


--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette
Reply | Threaded
Open this post in threaded view
|

Re: Ethernet Network device not managed

Daniele Piccoli
Il 06/03/2018 15:28, Giovanni Pili ha scritto:
> Ciao,
>
> ho eseguito tutte le istruzioni suggerite nel link n° 3. Purtroppo
> nessuna di queste istruzioni è stata utile. E' possibile che nella
> versione ubuntu 17.10 il problema non sia stato ancora risolto? Inoltre
> ho letto che il network-manager risulta "deprecated" e al suo posto
> viene utilizzato "netplan" Non sarebbe opportuno disinstallare il
> NetworkManager in favore di Netplan?

A me non sembra che Netplan possa sostituire NetworkManager, ma che sia
piuttosto un configuratore di rete che può usare diversi backend
(NetworkManager e systemd-networkd) e comunque è necessario preparare
dei file di configurazione .yaml [0], quindi credo non sia quello che vuoi.

Se proprio io proverei ad utilizzare uno strumento come widc [1] al
posto di NetworkManager.

Ma piuttosto io mi chiedo: perché usare ubuntu 17.10? e sopratutto
perché usarla per farci un server? io se devo fare server ubuntu uso
_solo_ versioni LTS, molto meglio a mio avviso.

> Rimango in attesa di un riscontro.
>
> Buona giornata
>
> Giovanni Pili
>

Daniele

[0] https://wiki.ubuntu.com/Netplan

[1] https://launchpad.net/wicd

--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette
Reply | Threaded
Open this post in threaded view
|

Re: Ethernet Network device not managed

Giovanni Pili
Buona sera Daniele,

ho seguito il tuo suggerimento e ho installato un nuovo server virtuale di prova con 16.04.4 LTS. Dopo aver installato la GUI "xubuntu-desktop" e aver modificato il file NetworkManager.conf ed aver impostato a "true" il parametro "manage" e riavviato il "network-manager" posso gestire le connessioni di rete perfettamente.

Ti ringrazio per il supporto.

Buona serata.
Giovanni Pili


Il giorno 6 marzo 2018 16:26, Daniele Piccoli <[hidden email]> ha scritto:
Il 06/03/2018 15:28, Giovanni Pili ha scritto:
> Ciao,
>
> ho eseguito tutte le istruzioni suggerite nel link n° 3. Purtroppo
> nessuna di queste istruzioni è stata utile. E' possibile che nella
> versione ubuntu 17.10 il problema non sia stato ancora risolto? Inoltre
> ho letto che il network-manager risulta "deprecated" e al suo posto
> viene utilizzato "netplan" Non sarebbe opportuno disinstallare il
> NetworkManager in favore di Netplan?

A me non sembra che Netplan possa sostituire NetworkManager, ma che sia
piuttosto un configuratore di rete che può usare diversi backend
(NetworkManager e systemd-networkd) e comunque è necessario preparare
dei file di configurazione .yaml [0], quindi credo non sia quello che vuoi.

Se proprio io proverei ad utilizzare uno strumento come widc [1] al
posto di NetworkManager.

Ma piuttosto io mi chiedo: perché usare ubuntu 17.10? e sopratutto
perché usarla per farci un server? io se devo fare server ubuntu uso
_solo_ versioni LTS, molto meglio a mio avviso.

> Rimango in attesa di un riscontro.
>
> Buona giornata
>
> Giovanni Pili
>

Daniele

[0] https://wiki.ubuntu.com/Netplan

[1] https://launchpad.net/wicd


--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette