Incomplete autopkgtest dependencies installed from test-trigger.

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Incomplete autopkgtest dependencies installed from test-trigger.

Dimitri John Ledkov
Hi,

I'm confused by this run of snapd test, as triggered by systemd from proposed.
The one in release pocket, ends in 4 and the one in proposed ends in 5

log url is: https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-cosmic/cosmic/amd64/s/snapd/20180829_233437_6cb77@/log.gz
artifacts url is:
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-cosmic/cosmic/amd64/s/snapd/20180829_233437_6cb77@/artifacts.tar.gz

--apt-pocket=proposed=src:systemd --apt-upgrade snapd
--env=ADT_TEST_TRIGGERS=systemd/239-7ubuntu5

are arguments to autopkgtest Later it goes to calculate the transaction:

The following packages will be upgraded:
  dpkg dpkg-dev gir1.2-glib-2.0 libdb5.3 libdpkg-perl libgirepository-1.0-1
  libglib2.0-0 libglib2.0-data mokutil python-apt-common python3-apt
  python3-distupgrade shim shim-signed systemd-sysv
15 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

And upgrades systemd-sysv only, which is symlinks only and not systemd itself.

Get:2 http://ftpmaster.internal/ubuntu cosmic-proposed/main amd64
systemd-sysv amd64 239-7ubuntu5 [13.7 kB]

Later there is:
autopkgtest: WARNING: Test dependencies are unsatisfiable with using
apt pinning. Retrying with using all packages from cosmic-proposed

which is better, cause then udev is installed from proposed

Get:43 http://ftpmaster.internal/ubuntu cosmic-proposed/main amd64
udev amd64 239-7ubuntu5 [1128 kB]

And again systemd was not upgraded.

When things are triggered by a src package, I would have expected for
all binaries to be upgraded from proposed for said package.... if they
are installed in the base system. It seems like this is not happening
here.

The autopkgtest in question depends on:

Depends: @builddeps@,
         bzr,
         ca-certificates,
         git,
         golang-golang-x-net-dev,
         locales,
         openssh-server,
         netcat-openbsd,
         net-tools,
         snapd

With snapd -> systemd, and @builddeps@ expanding udev and libudev-dev.

Is there something wrong with dependencies somewhere?
Should udev package depend on systemd (= ${binary:Version})?
Should systemd-sysv depend on systemd (= ${binary:Version})?
Should snapd's autopkgtest list 'systemd' in the debian/tests/control
as a dependency?

I'm worried now that, my uploads of systemd trigger tests which run
against old systemd with results actually not gating the migration.
(and only simply upgrading systemd-sysv).

--
Regards,

Dimitri.

--
ubuntu-devel mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel