Install Brackets removes Boinc ???

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Install Brackets removes Boinc ???

Wade Smart-2
In installed Brackets and when I did it uninstalled Boinc.
So I started to reinstall Boinc and it said it had to uninstall Brackets.

Ive never seen this before. Has anyone else seen this?

Wade
--
Registered Linux User: #480675
Registered Linux Machine: #408606
Linux since June 2005

--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Install Brackets removes Boinc ???

Ralf Mardorf-2
On Thu, 23 Aug 2018 19:36:47 -0500, Wade Smart wrote:
>In installed Brackets and when I did it uninstalled Boinc.
>So I started to reinstall Boinc and it said it had to uninstall
>Brackets.
>
>Ive never seen this before. Has anyone else seen this?

Please read http://www.catb.org/esr/faqs/smart-questions.html .

Regarding https://packages.ubuntu.com/ brackets is not provided as a
regular deb packages for any Ubuntu release. It seems to be available as
a snap as well as a regular deb package by a PPA. The PPA I found
seemingly installs brackets, including required libraries that do not
conflict with library versions provided by official repositories.
However, you might use another source to install it.

You missed to provide information.

What Ubuntu release are you using?

From what source do you install brackets?

How did you install brackets?

What output do you get? There's a reason, if installing one package does
remove another package and the package management will inform you about
this reason.


--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Install Brackets removes Boinc ???

Nils Kassube-2
Ralf Mardorf wrote:
> Please read http://www.catb.org/esr/faqs/smart-questions.html .

Please don't refer people to that article. While there are certainly
some good points in the article, it is written in an intimidating way.
Therefore I don't think it is helpful for an ordinary user.


Nils


--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Install Brackets removes Boinc ???

Wynona Stacy Lockwood
On Thu, Aug 23, 2018 at 10:58 PM, Nils Kassube <[hidden email]> wrote:
Ralf Mardorf wrote:
> Please read http://www.catb.org/esr/faqs/smart-questions.html .

Please don't refer people to that article. While there are certainly
some good points in the article, it is written in an intimidating way.
Therefore I don't think it is helpful for an ordinary user.

Seconded. In fact, anything by ESR should be titled "How to write like a pompous windbag." 

--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Install Brackets removes Boinc ???

Oliver Grawert
In reply to this post by Wade Smart-2
hi,
Am Donnerstag, den 23.08.2018, 19:36 -0500 schrieb Wade Smart:
> In installed Brackets and when I did it uninstalled Boinc.
> So I started to reinstall Boinc and it said it had to uninstall
> Brackets.
>
> Ive never seen this before. Has anyone else seen this?
>
while your message above is a very cryptic "package uninstalls distro",
there is a brackets package in the snap store [1], just do a:

sudo snap install brackets --classic

and you should be good to go.

ciao
        oli

[1] https://snapcraft.io/brackets
--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users

signature.asc (188 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Install Brackets removes Boinc ???

Wade Smart-2
Kubuntu 18.04
Brackets from the brackets site.
It was a .deb.
The output on Brackets was: installing Bracket, uninstalling Boinc including:
libcurl4, boinc-client, boinc-manager, install libcurl3.

When Installing Boinc it just says uninstalling Boinc.

Ill look at the snap.

Wade
--
Registered Linux User: #480675
Registered Linux Machine: #408606
Linux since June 2005

--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Install Brackets removes Boinc ???

Ralf Mardorf-2
On Fri, 2018-08-24 at 04:15 -0500, Wade Smart wrote:
> Kubuntu 18.04
> Brackets from the brackets site.
> It was a .deb.
> The output on Brackets was: installing Bracket, uninstalling Boinc including:
> libcurl4, boinc-client, boinc-manager, install libcurl3.
>
> When Installing Boinc it just says uninstalling Boinc.
>
> Ill look at the snap.

You also could install from this PPA, since it avoids a conflict, by
providing the needed dependencies:

 https://launchpad.net/~webupd8team/+archive/ubuntu/brackets

"Changelog

brackets (1.13.0libgcrypt11-17696+1~webupd8~0) bionic; urgency=medium

  * New upstream release
  * Readd:
    - added libcrypt11.so to the package to get it to work in newer
      Ubuntu
      or Linux Mint releases
    - StartupWMClass=brackets in brackets.desktop to
      fix duplicate icons on some DEs like Pantheon
    - added libcurl4 dependency (libcurl3 | libcurl4) so it's
      installable on Ubuntu Bionic

 -- Alin Andrei <email address hidden>  Mon, 12 Mar 2018 12:53:14 +0200"



--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Install Brackets removes Boinc ???

Ralf Mardorf-2
On Fri, 2018-08-24 at 11:23 +0200, Ralf Mardorf wrote:

> On Fri, 2018-08-24 at 04:15 -0500, Wade Smart wrote:
> > Kubuntu 18.04
> > Brackets from the brackets site.
> > It was a .deb.
> > The output on Brackets was: installing Bracket, uninstalling Boinc including:
> > libcurl4, boinc-client, boinc-manager, install libcurl3.
> >
> > When Installing Boinc it just says uninstalling Boinc.
> >
> > Ill look at the snap.
>
> You also could install from this PPA, since it avoids a conflict, by
> providing the needed dependencies:

Regarding libcurl it seems even not to provide the lib, but just has got
the "or" in the dependency array to workaround the issue.

>  https://launchpad.net/~webupd8team/+archive/ubuntu/brackets
>
> "Changelog
>
> brackets (1.13.0libgcrypt11-17696+1~webupd8~0) bionic; urgency=medium
>
>   * New upstream release
>   * Readd:
>     - added libcrypt11.so to the package to get it to work in newer
>       Ubuntu
>       or Linux Mint releases
>     - StartupWMClass=brackets in brackets.desktop to
>       fix duplicate icons on some DEs like Pantheon
>     - added libcurl4 dependency (libcurl3 | libcurl4) so it's
>       installable on Ubuntu Bionic
>
>  -- Alin Andrei <email address hidden>  Mon, 12 Mar 2018 12:53:14 +0200"



--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Install Brackets removes Boinc ???

Wade Smart-2
--
Registered Linux User: #480675
Registered Linux Machine: #408606
Linux since June 2005

On Fri, Aug 24, 2018 at 4:28 AM Ralf Mardorf <[hidden email]> wrote:

>
> On Fri, 2018-08-24 at 11:23 +0200, Ralf Mardorf wrote:
> > On Fri, 2018-08-24 at 04:15 -0500, Wade Smart wrote:
> > > Kubuntu 18.04
> > > Brackets from the brackets site.
> > > It was a .deb.
> > > The output on Brackets was: installing Bracket, uninstalling Boinc including:
> > > libcurl4, boinc-client, boinc-manager, install libcurl3.
> > >
> > > When Installing Boinc it just says uninstalling Boinc.
> > >
> > > Ill look at the snap.
> >
> > You also could install from this PPA, since it avoids a conflict, by
> > providing the needed dependencies:
>
> Regarding libcurl it seems even not to provide the lib, but just has got
> the "or" in the dependency array to workaround the issue.
>
> >  https://launchpad.net/~webupd8team/+archive/ubuntu/brackets
> >
> > "Changelog
> >
> > brackets (1.13.0libgcrypt11-17696+1~webupd8~0) bionic; urgency=medium
> >
> >   * New upstream release
> >   * Readd:
> >     - added libcrypt11.so to the package to get it to work in newer
> >       Ubuntu
> >       or Linux Mint releases
> >     - StartupWMClass=brackets in brackets.desktop to
> >       fix duplicate icons on some DEs like Pantheon
> >     - added libcurl4 dependency (libcurl3 | libcurl4) so it's
> >       installable on Ubuntu Bionic
> >
> >  -- Alin Andrei <email address hidden>  Mon, 12 Mar 2018 12:53:14 +0200"
>

Ill try this.
I like Brackets but Im trying out KDevelop
Thanks Ralf.

--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users