Installing kubuntu

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Installing kubuntu

David Caldwell-2
Hi,

I couldn't see this issue in the archives, so I hope I'm not repeating another post...

I installed edubuntu without problem and can connect with a thin client with no problem (I had to add a hosts entry and alter dhcpd.conf, but not a lot else). I then wanted to install the KDE desktop so I did the following:

"sudo chroot /opt/ltsp/i386 apt-get install kubuntu-desktop"

and all seemed fine apart from some messages about not being able to find locale information during the setup of some KDE packages. I rebooted the server and then turned the client on and was greeted by the following errors just before the kubuntu logon box:

Message 1: "could not read network connection list." and a reference to "/root/.dcopserver_ltsp_0"
Message 2: "Could not write to configuration file /root/share/config/kdegreetrc" and the same for "/root/share/config/kdeglobals"
Message 3: same as message 1
Message 4: same as message 2

After these message, I am greeted by the kubuntu logon screen. However, whatever credentials I use, it tells me my logon is incorrect.

I've tried looking for clues in log files when the client starts but have not found anything useful.

Another thing I've noticed is that the new KDE session starts on terminal 9 and Gnome is still available and works fine on terminal 7.

Does anyone have any ideas about how to fix this?

Many thanks,

David.

______________________

David Caldwell
Access IT Limited
t: +44(0)1227 750555
f: +44(0)1227 750070
w: www.accessit.co.uk
______________________


*************************************************************************************************
Disclaimer: This message may only be read in context and with common sense. 
If concerned by it or in doubt, please destroy it. If this message is not meant for you, 
we have made a mistake and would appreciate your help. We promise that we mean 
no offence and will endeavour to rectify our mistake. 

Our full contact details can be found on www.accessit.co.uk
*************************************************************************************************

--
edubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/edubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Installing kubuntu

Mario Đanić


Hey,

first I'll go by admitting that I only briefly looked over you message, but ...

Does anyone have any ideas about how to fix this?

you could try rebuilding ssh toolchain/keyset:

sudo ltsp-build-sshkeys 

Many thanks,

David.

Kind regards and  take care,
Mario Danic

______________________

David Caldwell
Access IT Limited
t: +44(0)1227 750555
f: +44(0)1227 750070
w: <a href="http://www.accessit.co.uk" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)"> www.accessit.co.uk
______________________


*************************************************************************************************
Disclaimer: This message may only be read in context and with common sense. 
If concerned by it or in doubt, please destroy it. If this message is not meant for you, 
we have made a mistake and would appreciate your help. We promise that we mean 
no offence and will endeavour to rectify our mistake. 

Our full contact details can be found on <a href="http://www.accessit.co.uk" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">www.accessit.co.uk
*************************************************************************************************

--
edubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: <a onclick="return top.js.OpenExtLink(window,event,this)" href="https://lists.ubuntu.com/mailman/listinfo/edubuntu-users" target="_blank"> https://lists.ubuntu.com/mailman/listinfo/edubuntu-users



--
edubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/edubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Installing kubuntu

Gavin McCullagh-3
In reply to this post by David Caldwell-2
On Tue, 20 Feb 2007, David Caldwell wrote:

> I installed edubuntu without problem and can connect with a thin client
> with no problem (I had to add a hosts entry and alter dhcpd.conf, but not
> a lot else).

Out of pure curiosity, what hosts entry was that?

> I then wanted to install the KDE desktop so I did the
> following:
>
> "sudo chroot /opt/ltsp/i386 apt-get install kubuntu-desktop"

Ah.  I don't think you wanted to do this.  The /opt/ltsp/i386 chroot is
where the thin client's filesystem lives.  However you don't want KDE to
run on the thin client -- you want it to run on the server but display on
the thin client.  So, you need to install it as normal on the server

  sudo aptitude install kubuntu-desktop

(I'd also suggest using aptitude rather than apt-get which is a little
smarter).

> and all seemed fine apart from some messages about not being able to find
> locale information during the setup of some KDE packages. I rebooted the
> server and then turned the client on and was greeted by the following
> errors just before the kubuntu logon box:

Sounds like kdm is now install on the chroot.  You can try and remove the
kubuntu system from the chroot but it would probably be easier just to
remove the chroot entirely and rebuild it:

        sudo ltsp-build-client

> Another thing I've noticed is that the new KDE session starts on terminal
> 9 and Gnome is still available and works fine on terminal 7.

I'd guess that's ldm on 7.

Gavin


--
edubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/edubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Installing kubuntu

David Caldwell-2
In reply to this post by Mario Đanić
Thanks forthe suggestion. No, this didn't work...

______________________

David Caldwell
Access IT Limited
t: +44(0)1227 750555
f: +44(0)1227 750070
w: www.accessit.co.uk
______________________

From: Mario Đanić [mailto:[hidden email]]
To: [hidden email]
Cc: [hidden email]
Sent: Tue, 20 Feb 2007 12:14:25 +0000
Subject: Re: Installing kubuntu



Hey,

first I'll go by admitting that I only briefly looked over you message, but ...

Does anyone have any ideas about how to fix this?

you could try rebuilding ssh toolchain/keyset:

sudo ltsp-build-sshkeys 

Many thanks,

David.

Kind regards and  take care,
Mario Danic

______________________

David Caldwell
Access IT Limited
t: +44(0)1227 750555
f: +44(0)1227 750070
w: www.accessit.co.uk
______________________


*************************************************************************************************
Disclaimer: This message may only be read in context and with common sense. 
If concerned by it or in doubt, please destroy it. If this message is not meant for you, 
we have made a mistake and would appreciate your help. We promise that we mean 
no offence and will endeavour to rectify our mistake. 

Our full contact details can be found on www.accessit.co.uk
*************************************************************************************************

--
edubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/edubuntu-users





*************************************************************************************************
Disclaimer: This message may only be read in context and with common sense. 
If concerned by it or in doubt, please destroy it. If this message is not meant for you, 
we have made a mistake and would appreciate your help. We promise that we mean 
no offence and will endeavour to rectify our mistake. 

Our full contact details can be found on www.accessit.co.uk
*************************************************************************************************

--
edubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/edubuntu-users