[Intrepid/Jaunty-meta] SRU Adding linux-restricted modules for server

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[Intrepid/Jaunty-meta] SRU Adding linux-restricted modules for server

Stefan Bader-2
https://bugs.launchpad.net/ubuntu/+source/linux-meta/+bug/220781

There are requests to have a dependency on lrm for server as well.

Tim, after we got meta as repo, may I suggest this one again? I would
likely add id to Intrepid as well. Server team did (to my knowledge) not
yell with pain. Did you hear something?

Stefan



--
kernel-team mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/kernel-team
Reply | Threaded
Open this post in threaded view
|

[PATCH] Adding linux-restricted modules for server

Stefan Bader-2
Bug: #220781

There are requests to have a dependency on lrm for server as well.

Signed-off-by: Stefan Bader <[hidden email]>
---
 meta-source/debian/control.d/server |   11 ++++++++++-
 1 files changed, 10 insertions(+), 1 deletions(-)

diff --git a/meta-source/debian/control.d/server b/meta-source/debian/control.d/server
index 312e9ef..9249fed 100644
--- a/meta-source/debian/control.d/server
+++ b/meta-source/debian/control.d/server
@@ -16,11 +16,20 @@ Description: Linux kernel image on Server Equipment.
  This package will always depend on the latest kernel image available
  for Server Equipment.
 
+Package: linux-restricted-modules-server
+Architecture: i386 amd64
+Section: restricted/metapackages
+Priority: optional
+Depends: linux-restricted-modules-${kernel-abi-version}-server
+Description: Restricted Linux modules for server kernels
+ This package will always depend on the latest restricted modules available
+ for server kernels.
+
 Package: linux-server
 Architecture: i386 amd64
 Section: metapackages
 Priority: optional
-Depends: linux-image-server (= ${binary:Version})
+Depends: linux-image-server (= ${binary:Version}), linux-restricted-modules-server (= ${binary:Version})
 Description: Complete Linux kernel on Server Equipment.
  This package will always depend on the latest complete Linux kernel available
  for Server Equipment.
--
1.5.4.3


--
kernel-team mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/kernel-team
Reply | Threaded
Open this post in threaded view
|

Re: [PATCH] Adding linux-restricted modules for server

Stefan Bader-2
Doh, if you take it, re-create control...
Stefan Bader wrote:

> Bug: #220781
>
> There are requests to have a dependency on lrm for server as well.
>
> Signed-off-by: Stefan Bader <[hidden email]>
> ---
>  meta-source/debian/control.d/server |   11 ++++++++++-
>  1 files changed, 10 insertions(+), 1 deletions(-)
>
> diff --git a/meta-source/debian/control.d/server b/meta-source/debian/control.d/server
> index 312e9ef..9249fed 100644
> --- a/meta-source/debian/control.d/server
> +++ b/meta-source/debian/control.d/server
> @@ -16,11 +16,20 @@ Description: Linux kernel image on Server Equipment.
>   This package will always depend on the latest kernel image available
>   for Server Equipment.
>  
> +Package: linux-restricted-modules-server
> +Architecture: i386 amd64
> +Section: restricted/metapackages
> +Priority: optional
> +Depends: linux-restricted-modules-${kernel-abi-version}-server
> +Description: Restricted Linux modules for server kernels
> + This package will always depend on the latest restricted modules available
> + for server kernels.
> +
>  Package: linux-server
>  Architecture: i386 amd64
>  Section: metapackages
>  Priority: optional
> -Depends: linux-image-server (= ${binary:Version})
> +Depends: linux-image-server (= ${binary:Version}), linux-restricted-modules-server (= ${binary:Version})
>  Description: Complete Linux kernel on Server Equipment.
>   This package will always depend on the latest complete Linux kernel available
>   for Server Equipment.



--

When all other means of communication fail, try words!



--
kernel-team mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/kernel-team
Reply | Threaded
Open this post in threaded view
|

Re: [Intrepid/Jaunty-meta] SRU Adding linux-restricted modules for server

Tim Gardner-2
In reply to this post by Stefan Bader-2
Stefan Bader wrote:

> https://bugs.launchpad.net/ubuntu/+source/linux-meta/+bug/220781
>
> There are requests to have a dependency on lrm for server as well.
>
> Tim, after we got meta as repo, may I suggest this one again? I would
> likely add id to Intrepid as well. Server team did (to my knowledge) not
> yell with pain. Did you hear something?
>
> Stefan
>
>
>

ACK

--
Tim Gardner [hidden email]

--
kernel-team mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/kernel-team
Reply | Threaded
Open this post in threaded view
|

Re: [PATCH] Adding linux-restricted modules for server

Tim Gardner-2
In reply to this post by Stefan Bader-2
Stefan Bader wrote:

> Bug: #220781
>
> There are requests to have a dependency on lrm for server as well.
>
> Signed-off-by: Stefan Bader <[hidden email]>
> ---
>  meta-source/debian/control.d/server |   11 ++++++++++-
>  1 files changed, 10 insertions(+), 1 deletions(-)
>
> diff --git a/meta-source/debian/control.d/server b/meta-source/debian/control.d/server
> index 312e9ef..9249fed 100644
> --- a/meta-source/debian/control.d/server
> +++ b/meta-source/debian/control.d/server
> @@ -16,11 +16,20 @@ Description: Linux kernel image on Server Equipment.
>   This package will always depend on the latest kernel image available
>   for Server Equipment.
>  
> +Package: linux-restricted-modules-server
> +Architecture: i386 amd64
> +Section: restricted/metapackages
> +Priority: optional
> +Depends: linux-restricted-modules-${kernel-abi-version}-server
> +Description: Restricted Linux modules for server kernels
> + This package will always depend on the latest restricted modules available
> + for server kernels.
> +
>  Package: linux-server
>  Architecture: i386 amd64
>  Section: metapackages
>  Priority: optional
> -Depends: linux-image-server (= ${binary:Version})
> +Depends: linux-image-server (= ${binary:Version}), linux-restricted-modules-server (= ${binary:Version})
>  Description: Complete Linux kernel on Server Equipment.
>   This package will always depend on the latest complete Linux kernel available
>   for Server Equipment.

applied

--
Tim Gardner [hidden email]

--
kernel-team mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/kernel-team