LibreOffice for natty, replacing the current OpenOffice packaging

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

LibreOffice for natty, replacing the current OpenOffice packaging

Matthias Klose-6
Hi,

had to cancel my skiing vacation because of an injury, and had a look at the
current OOo/LO situation for 11.04 instead.  The OOo packaging is only available
for version 3.2.1, there doesn't exist any packaging for 3.3 based on our
ooo-build packaging.  ooo-build is now used in LO, and the packaging is
converted to use LO.  The uno framework is one of the basic things which is
shared with the OOo packaging, and I don't see any easy way how to make the two
uno frameworks from both source packages available. The consequence is that the
old OOo packages are removed/replaced with the installation of the LO packages.
  As long as we want to update to *O 3.3 there currently is no other way than to
go with LO.

The OOo packaging did accumulate a lot of changes, hacks and workarounds, which
I didn't apply to the LO packaging, plus some Ubuntu specific changes are not
yet ported to LO 3.3.  As long as there is no libreoffice package in Ubuntu,
these issues are tracked in [1].  If you report new issues, please tag these
issues with `lo33'.

Test packages including backports for lucid and maverick can be found at

   https://launchpad.net/~libreoffice/+archive/ppa/+packages

Note that a reinstallation of the old OOo packages is not automatic and requires
manual removal of all LO packages before trying the reinstallation.

The packages definitely need some testing, but else they look ok-ish for
inclusion in natty for alpha-2.  See the list of issues, and maybe target some
of these for alpha-2 or alpha-3.  The most important thing seems to be the KDE
build and maybe the ARM build (although it's not yet found anymore on the ARM
images).

   Matthias

[1] https://launchpad.net/ubuntu/+bugs?field.tag=lo33

--
ubuntu-devel mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel