[Linux on DeX] Internetzugang im Container funktioniert nicht

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[Linux on DeX] Internetzugang im Container funktioniert nicht

Marcus Glöder
Hallo alle zusammen,

seit kurzem besitze ich ein SAMSUNG Galaxy Tab 4.  Auf diesem Gerät habe ich Linux on DeX installiert. Es handelt sich dabei um ein experimentelles System (Beta-Phase), bei dem ein speziell angepasstes Ubuntu-Linux (die Version weiß ich jetzt nicht) in einem Container innerhalb von SAMSUNG DeX gestartet wird. SAMSUNG DeX ist eine Desktop-Darstellung des Android-Systems, die nur auf SAMSUNG Galaxy Note 9 und SAMSUNG Galaxy Tab 4 existiert.

Das Ubuntu-Linux läuft mit den vorinstallierten Anwendungen weitgehend problemfrei (soweit ich das sehen kann). Allerdings funktioniert der Internetzugang nicht, mit der Folge, dass ich weder über Synaptic neue Programme installieren noch über Firefox oder Chromium auf Websites zugreifen kann.

Im Terminalfenster führt

ping www.google.de

zu der Ausgabe

ping: unknown host www.google.de

und 

ping 192.168.178.1

zu der Ausgabe

ping: icmp open socket: Operation not permitted

Wenn ich beide Befehle mit einem sudo davor eingebe, wird erst das sudo-Passwort abgefragt und dann folgen jeweils identische Ausgaben. Der Befehl

ifconfig

führt zu der folgenden Ausgabe:

---- Beginn ifconfig-Ausgabe ----
dummy0    Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
          inet6 addr: fe80::5448:99ff:fe83:d44/64 Scope:Link
          UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:77 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:8136 (8.1 KB)

lo        Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:2641 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2641 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:9652882 (9.6 MB)  TX bytes:9652882 (9.6 MB)

p2p0      Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan0     Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
          inet addr:192.168.178.31  Bcast:192.168.178.255  Mask:255.255.255.0
          inet6 addr: 2a02:908:950:40c0:d99:d510:db2b:9665/64 Scope:Global
          inet6 addr: fe80::fa7a:77ea:298e:8e22/64 Scope:Link
          inet6 addr: 2a02:908:950:40c0:917b:2f3d:5bc1:b511/64 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5124647 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2034221 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3000 
          RX bytes:6919652584 (6.9 GB)  TX bytes:361593955 (361.5 MB)
---- Ende ifconfig-Ausgabe ----

Danach wird die Wireless-LAN-Verbindung also durchaus erkannt und ist auch eingerichtet. Warum der Internetzugang trotzdem nicht funktioniert, verstehe ich nicht. ping sagt, dass irgendwelche Berechtigungen fehlen, um auf den Router zuzugreifen. Aber mit sudo (das mir eigentlich alle Berechtigungen der Welt verschaffen sollte) bekomme ich dieselbe Meldung.

Hat hier irgendjemand eine Idee, woran das liegen könnte und wie ich das Problem beheben kann? Auch ein Workaround würde helfen. Es geht mir nicht um den Webseitenzugriff. Den habe ich problemlos außerhalb des Containers. Es geht mir um die Möglichkeit, mit Synaptic Programme nachzuinstallieren (konkret LaTeX und LyX).

Vielen Dank und viele Grüße
Jake2042


--
ubuntu-de mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-de
Reply | Threaded
Open this post in threaded view
|

Re: [Linux on DeX] Internetzugang im Container funktioniert nicht

Marcus Glöder
Leider hat der E-Mail-Client, von dem ich meine Amfrage ursprünglich gesendet habe, die E-Mail in HTML versandt. :-( 

Jetzt versuche ich es mit einem anderen Client noch einmal, in der Hoffnung, dass die E-Mail jetzt als Plain Text versandt wird. Da es sich auch hierbei um eine Android-App handelt und nicht um ein Programm wie Thunderbird auf dem PC, kann ich das aber nicht garantieren, leider.

Viele Grüße
Jake2042

Von Samsung-Tablet gesendet

-------- Ursprüngliche Nachricht --------
Von: Marcus Glöder <[hidden email]>
Datum: 30.11.18 10:32 (GMT+01:00)
Betreff: [Linux on DeX] Internetzugang im Container funktioniert nicht

Hallo alle zusammen,

seit kurzem besitze ich ein SAMSUNG Galaxy Tab 4.  Auf diesem Gerät habe ich Linux on DeX installiert. Es handelt sich dabei um ein experimentelles System (Beta-Phase), bei dem ein speziell angepasstes Ubuntu-Linux (die Version weiß ich jetzt nicht) in einem Container innerhalb von SAMSUNG DeX gestartet wird. SAMSUNG DeX ist eine Desktop-Darstellung des Android-Systems, die nur auf SAMSUNG Galaxy Note 9 und SAMSUNG Galaxy Tab 4 existiert.

Das Ubuntu-Linux läuft mit den vorinstallierten Anwendungen weitgehend problemfrei (soweit ich das sehen kann). Allerdings funktioniert der Internetzugang nicht, mit der Folge, dass ich weder über Synaptic neue Programme installieren noch über Firefox oder Chromium auf Websites zugreifen kann.

Im Terminalfenster führt

ping www.google.de

zu der Ausgabe

ping: unknown host www.google.de

und 

ping 192.168.178.1

zu der Ausgabe

ping: icmp open socket: Operation not permitted

Wenn ich beide Befehle mit einem sudo davor eingebe, wird erst das sudo-Passwort abgefragt und dann folgen jeweils identische Ausgaben. Der Befehl

ifconfig

führt zu der folgenden Ausgabe:

---- Beginn ifconfig-Ausgabe ----
dummy0    Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
          inet6 addr: fe80::5448:99ff:fe83:d44/64 Scope:Link
          UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:77 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:8136 (8.1 KB)

lo        Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:2641 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2641 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:9652882 (9.6 MB)  TX bytes:9652882 (9.6 MB)

p2p0      Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan0     Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
          inet addr:192.168.178.31  Bcast:192.168.178.255  Mask:255.255.255.0
          inet6 addr: 2a02:908:950:40c0:d99:d510:db2b:9665/64 Scope:Global
          inet6 addr: fe80::fa7a:77ea:298e:8e22/64 Scope:Link
          inet6 addr: 2a02:908:950:40c0:917b:2f3d:5bc1:b511/64 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5124647 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2034221 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3000 
          RX bytes:6919652584 (6.9 GB)  TX bytes:361593955 (361.5 MB)
---- Ende ifconfig-Ausgabe ----

Danach wird die Wireless-LAN-Verbindung also durchaus erkannt und ist auch eingerichtet. Warum der Internetzugang trotzdem nicht funktioniert, verstehe ich nicht. ping sagt, dass irgendwelche Berechtigungen fehlen, um auf den Router zuzugreifen. Aber mit sudo (das mir eigentlich alle Berechtigungen der Welt verschaffen sollte) bekomme ich dieselbe Meldung.

Hat hier irgendjemand eine Idee, woran das liegen könnte und wie ich das Problem beheben kann? Auch ein Workaround würde helfen. Es geht mir nicht um den Webseitenzugriff. Den habe ich problemlos außerhalb des Containers. Es geht mir um die Möglichkeit, mit Synaptic Programme nachzuinstallieren (konkret LaTeX und LyX).

Vielen Dank und viele Grüße
Jake2042

--
ubuntu-de mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-de