Make Java work. How?

classic Classic list List threaded Threaded
15 messages Options
Reply | Threaded
Open this post in threaded view
|

Make Java work. How?

Herman Aalderink

I need to install JAVA.
Do I?
Synaptic tells me that many Java packages are installed.

If I have a webpage that needs Java, it wants to install Java.
 (the plug-in tries to install JRE, Java Runtime Environment)

I use Ubunti 6.06, default installation.


I tried it out on this website: (and it does not work)
Java Morse Code Translator
http://morsecode.scphillips.com/jtranslator.html

How do I get Java to work for me?

Herman in PHL.
--
Using Linux-Ubuntu. No more Windows.


--
ubuntu-users mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Make Java work. How?

Justin Gallardo
Herman wrote:

> I need to install JAVA.
> Do I?
> Synaptic tells me that many Java packages are installed.
>
> If I have a webpage that needs Java, it wants to install Java.
>  (the plug-in tries to install JRE, Java Runtime Environment)
>
> I use Ubunti 6.06, default installation.
>
>
> I tried it out on this website: (and it does not work)
> Java Morse Code Translator
> http://morsecode.scphillips.com/jtranslator.html
>
> How do I get Java to work for me?
>
> Herman in PHL.
>  
http://ubuntuguide.org/wiki/Dapper#How_to_install_J2SE_Runtime_Environment_.28JRE.29_with_Plug-in_for_Mozilla_Firefox

I think that this will help you out.
Cheers!

--
Justin Gallardo
[hidden email]



--
ubuntu-users mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Make Java work. How?

Lorin Pino-2
In reply to this post by Herman Aalderink
Herman wrote:

> I need to install JAVA.
> Do I?
> Synaptic tells me that many Java packages are installed.
>
> If I have a webpage that needs Java, it wants to install Java.
>  (the plug-in tries to install JRE, Java Runtime Environment)
>
> I use Ubunti 6.06, default installation.
>
>
> I tried it out on this website: (and it does not work)
> Java Morse Code Translator
> http://morsecode.scphillips.com/jtranslator.html
>
> How do I get Java to work for me?
>
> Herman in PHL.
>  
Did you install the java plug-in for your browser?
~Lorin

--
ubuntu-users mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Make Java work. How?

Mo Pringles
In reply to this post by Herman Aalderink
Herman schreef:

> I need to install JAVA.
> Do I?
> Synaptic tells me that many Java packages are installed.
>
> If I have a webpage that needs Java, it wants to install Java.
>  (the plug-in tries to install JRE, Java Runtime Environment)
>
> I use Ubunti 6.06, default installation.
>
>
> I tried it out on this website: (and it does not work)
> Java Morse Code Translator
> http://morsecode.scphillips.com/jtranslator.html
>
> How do I get Java to work for me?
>
> Herman in PHL.
Do you have a 64 bit CPU?

--
Regards Mo

--
ubuntu-users mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Make Java work. How?

Dieter Schicker-3
In reply to this post by Herman Aalderink
On Fri, 2006-09-08 at 05:00 +0000, Herman wrote:

> I need to install JAVA.
> Do I?
> Synaptic tells me that many Java packages are installed.
>
> If I have a webpage that needs Java, it wants to install Java.
>  (the plug-in tries to install JRE, Java Runtime Environment)
>
> I use Ubunti 6.06, default installation.
>
>
> I tried it out on this website: (and it does not work)
> Java Morse Code Translator
> http://morsecode.scphillips.com/jtranslator.html
>
> How do I get Java to work for me?
>
> Herman in PHL.
> --
> Using Linux-Ubuntu. No more Windows.
>
>

Hi,

I suggest to install the following packages:

sun-java5-jre
sun-java5-plugin

If you are a java developer also install:

sun-java5-jdk

Best,
Dieter


--
ubuntu-users mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Make Java work. How?

AC Perdon
In reply to this post by Herman Aalderink
Hi,

I hope this steps could help you,

1.Download Java Runtime Environment (JRE) 5.0 Update 8: http://java.sun.com/javase/downloads/index.jsp pick Linux self-extracting file. Download it to your Desktop.

2.Open a terminal then cd Desktop.

3. sudo apt-get install build-essential.

4.sudo apt-get install fakeroot java-package java-common

5.fakeroot make-jpkg jre-1_5_0_08-linux-i586.bin

6.sudo dpkg -i sun-j2re1.5_1.5.0+update08_i386.deb

7.sudo update-alternatives --config java

8.When asking for which version you want to choose pick;

          3 /usr/lib/j2sdk1.5-sun/bin/java

9.Test if you java is installed

             java -version


--
AC Perdon
Registered GNU/Linux User #340122



On 9/8/06, Herman <[hidden email]> wrote:

I need to install JAVA.
Do I?
Synaptic tells me that many Java packages are installed.

If I have a webpage that needs Java, it wants to install Java.
(the plug-in tries to install JRE, Java Runtime Environment)

I use Ubunti 6.06, default installation.


I tried it out on this website: (and it does not work)
Java Morse Code Translator
http://morsecode.scphillips.com/jtranslator.html

How do I get Java to work for me?

Herman in PHL.
--
Using Linux-Ubuntu. No more Windows.


--
ubuntu-users mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-users





--
ubuntu-users mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Make Java work. How?

noop-3
In reply to this post by Justin Gallardo
Justin Gallardo wrote:

> Herman wrote:
>> I need to install JAVA.
>> Do I?
>> Synaptic tells me that many Java packages are installed.
>>
>> If I have a webpage that needs Java, it wants to install Java.
>>  (the plug-in tries to install JRE, Java Runtime Environment)
>>
>> I use Ubunti 6.06, default installation.
>>
>>
>> I tried it out on this website: (and it does not work)
>> Java Morse Code Translator
>> http://morsecode.scphillips.com/jtranslator.html
>>
>> How do I get Java to work for me?
>>
>> Herman in PHL.
>>  
> http://ubuntuguide.org/wiki/Dapper#How_to_install_J2SE_Runtime_Environment_.28JRE.29_with_Plug-in_for_Mozilla_Firefox
>
> I think that this will help you out.
> Cheers!
>

I don't think that he is a developer. It appears that all he needs to
install is JRE not JSE. Plus he'll still need to install JRE to get his
application to work. I think that the next set of instructions is more
appropriate:

http://ubuntuguide.org/wiki/Dapper#How_to_install_JRE_v5.0_Update_8
====
 How to install JRE v5.0 Update 8

    * Read #General Notes

    * Download the "Linux (self-extracting file)" from
http://java.com/en/download/manual.jsp

    * Copy it to /usr/java/

sudo chmod a+x jre-1_5_0_08-linux-i586.bin
sudo ./jre-1_5_0_08-linux-i586.bin
cd /usr/lib/firefox/plugins
ln -s /usr/java/jre1.5.0_08/plugin/i386/ns7/libjavaplugin_oji.so
cd /usr/lib/mozilla/plugins
ln -s /usr/java/jre1.5.0_08/plugin/i386/ns7/libjavaplugin_oji.so

    * Restart Mozilla Firefox
====

However, be aware that the manual download from the link provided
http://java.com/en/download/manual.jsp) does *not* download Update 08,
it downloads jre-1_5_0_06-linux-i586.bin. So change the code to
reference 06 inststead of 08:

Note: if no /usr/java/ directory exists _make one_ and only run the
following from that directory.

sudo chmod a+x jre-1_5_0_06-linux-i586.bin
sudo ./jre-1_5_0_06-linux-i586.bin
cd /usr/lib/firefox/plugins
ln -s /usr/java/jre1.5.0_06/plugin/i386/ns7/libjavaplugin_oji.so
cd /usr/lib/mozilla/plugins
ln -s /usr/java/jre1.5.0_06/plugin/i386/ns7/libjavaplugin_oji.so

If you really want to download & install JRE 08 then you'll need to us
this link instead:
http://java.sun.com/javase/downloads/index.jsp
 - click on the download button for
   Java Runtime Environment (JRE) 5.0 Update 8
 - this will take you to the Sun download page
 - click the "Accept" Licence Agreement button
 - select "Linux self-extracting file" jre-1_5_0_08-linux-i586.bin
Then follow the original code for 08.

Note: if you are running Seamonkey instead of, or in addition to,
Firefox, you'll need to modify the instructions above to: 1) show the
proper version number (06,07,08 etc), and 2) change the directory to
point to the Seamonkey plugins directory. My SM plugin is:

/usr/local/seamonkey/plugins

so installing 08 for both Firefox _and_ Seamonkey would be:

* Close Mozilla Firefox and/or Seamonkey

cd /usr/java/
sudo chmod a+x jre-1_5_0_08-linux-i586.bin
sudo ./jre-1_5_0_08-linux-i586.bin
cd /usr/lib/firefox/plugins
ln -s /usr/java/jre1.5.0_08/plugin/i386/ns7/libjavaplugin_oji.so
cd /usr/lib/mozilla/plugins
ln -s /usr/java/jre1.5.0_08/plugin/i386/ns7/libjavaplugin_oji.so
cd /usr/local/seamonkey/plugins
ln -s /usr/java/jre1.5.0_08/plugin/i386/ns7/libjavaplugin_oji.so

* Restart Mozilla Firefox and/or Seamonkey

Check to ensure that the plugin is installed properly:

Seamonkey - click on Help|About Plugins and you should see the newly
installed Java(TM) Plug-in installation references. If you do not, then
you've done something wrong.

Firefox - in the URL toolbar enter "about:plugins" as the URL and then enter
You should see the newly installed Java(TM) Plug-in installation
references. If you do not, then you've done something wrong.







--
ubuntu-users mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Make Java work. How?

Michael R. Head
In reply to this post by Herman Aalderink
On Fri, 2006-09-08 at 05:00 +0000, Herman wrote:

> I need to install JAVA.
> Do I?
> Synaptic tells me that many Java packages are installed.
>
> If I have a webpage that needs Java, it wants to install Java.
>  (the plug-in tries to install JRE, Java Runtime Environment)
>
> I use Ubunti 6.06, default installation.
>
>
> I tried it out on this website: (and it does not work)
> Java Morse Code Translator
> http://morsecode.scphillips.com/jtranslator.html
>
> How do I get Java to work for me?
Don't bother downloading java from Sun. The packages are available in
synaptic.

Just install the sun-java5-jre and sun-java5-plugin packages.

After this, you may need to incant this on the command line:
sudo update-java-alternatives --jre --plugin -s java-1.5.0-sun

In firefox, if you want to see what plugins are availble, browse to the
location "about:plugins"

mike

> Herman in PHL.
> --
> Using Linux-Ubuntu. No more Windows.
>
>
--
Michael R. Head <[hidden email]>
suppressingfire.org

--
ubuntu-users mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-users

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Make Java work. How?

Justin Gallardo
In reply to this post by noop-3
NoOp wrote:
> I don't think that he is a developer. It appears that all he needs to
> install is JRE not JSE. Plus he'll still need to install JRE to get his
> application to work. I think that the next set of instructions is more
> appropriate:

I believe you had actually went to the link, you would realize that J2SE
doesn't always refer to a SDK. This link indeed is a walk through on how
to install J2SE runtimes with a Firefox plugin(which is the point of the
whole thing).

--
Justin Gallardo
[hidden email]



--
ubuntu-users mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Make Java work. How?

noop-3
Justin Gallardo wrote:

> NoOp wrote:
>> I don't think that he is a developer. It appears that all he needs to
>> install is JRE not JSE. Plus he'll still need to install JRE to get his
>> application to work. I think that the next set of instructions is more
>> appropriate:
>
> I believe you had actually went to the link, you would realize that J2SE
> doesn't always refer to a SDK. This link indeed is a walk through on how
> to install J2SE runtimes with a Firefox plugin(which is the point of the
> whole thing).
>

Argh... you are absolutely correct, my humble apologies.



--
ubuntu-users mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Make Java work. How?

Norman Silverstone-2
In reply to this post by Herman Aalderink
On Fri, 2006-09-08 at 05:00 +0000, Herman wrote:

> I need to install JAVA.
> Do I?
> Synaptic tells me that many Java packages are installed.
>
> If I have a webpage that needs Java, it wants to install Java.
>  (the plug-in tries to install JRE, Java Runtime Environment)
>
> I use Ubunti 6.06, default installation.
>
>
> I tried it out on this website: (and it does not work)
> Java Morse Code Translator
> http://morsecode.scphillips.com/jtranslator.html
>
> How do I get Java to work for me?

This helped me a great deal.

> https://help.ubuntu.com/community/Java

Norman


--
ubuntu-users mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Make Java work. How?

chrisccoulson

Any hints for firefox 2 users? The instructions here don't work.


--
one_stinky_bum

--
ubuntu-users mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Make Java work. How?

mike williams-13
just go to this link,DL,and run this,it should take care of it(http://easyubuntu.freecontrib.org/get.html)

----- Original Message ----
From: one_stinky_bum <[hidden email]>
To: [hidden email]
Sent: Sunday, September 10, 2006 8:37:25 PM
Subject: Re: Make Java work. How?

Any hints for firefox 2 users? The instructions here don't work.


--
one_stinky_bum

--
ubuntu-users mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-users


--
ubuntu-users mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Make Java work. How?

Herman Aalderink
In reply to this post by Herman Aalderink
On Fri, 2006-09-08 at 13:02 -0700, NoOp wrote:
> Justin Gallardo wrote:
> > Herman wrote:
> >> I need to install JAVA.
> >> Do I?
> >> Synaptic tells me that many Java packages are installed.
.................

> >> How do I get Java to work for me?
> >>
> >> Herman in PHL.
> >>
> > http://ubuntuguide.org/wiki/Dapper#How_to_install_J2SE_Runtime_Environment_.28JRE.29_with_Plug-in_for_Mozilla_Firefox
> >
> > I think that this will help you out.
> > Cheers!
> >
>
> I don't think that he is a developer. It appears that all he needs to
> install is JRE not JSE. Plus he'll still need to install JRE to get his
> application to work. I think that the next set of instructions is more
> appropriate:
>
> http://ubuntuguide.org/wiki/Dapper#How_to_install_JRE_v5.0_Update_8
> ====
>  How to install JRE v5.0 Update 8

All I need is Java on my default Ubuntu 6.06. (+ auto-updates)
My FireFox is 1.5.0.5
JAVA is installed acc to synaptic. (why doesn't it work??)

Thank you for the many suggestions.
I am trying them out one by one.
EasyUbuntu did not work for me (I have a report on file).
Still to try the other suggestions. Incl the above one.
I am enjoying Ubuntu. Even if without JAVA and Macromedia-FlashPlayer.

Herman (lost Dutchman) in Philippines.

--
Using Linux-Ubuntu. No more Windows.
If we lost contact, look for me here: www.QRZ.com/n0jn.

--
ubuntu-users mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Make Java work. How?

albi@scii.nl
Herman Aalderink wrote:

>> http://ubuntuguide.org/wiki/Dapper#How_to_install_JRE_v5.0_Update_8
>> ====
>>  How to install JRE v5.0 Update 8
>
> All I need is Java on my default Ubuntu 6.06. (+ auto-updates)
> My FireFox is 1.5.0.5
> JAVA is installed acc to synaptic. (why doesn't it work??)
>
> Thank you for the many suggestions.
> I am trying them out one by one.
> EasyUbuntu did not work for me (I have a report on file).
> Still to try the other suggestions. Incl the above one.
> I am enjoying Ubuntu. Even if without JAVA and Macromedia-FlashPlayer.

if you have installed the sun-jre, then remove the gnu-java package OR
do an update-alternatives in a terminal :

sudo update-alternatives --set java
/usr/lib/jvm/java-1.5.0-sun-1.5.0.06/jre/bin/java

(on 1 line!)

then try in a terminal : java -version


--
ubuntu-users mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-users