Moving Ubunto to New Laptop....

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Moving Ubunto to New Laptop....

Mario Splivalo-2
I sucsessfuly installed Ubuntu 5.10 on new laptop. On old laptop, I also
have Ubuntu 5.10, fresly installed a month ago.

On old laptop i did:

dpkg --get-selections | awk '{print $1}' > /tmp/installed.list

Then I vi'ed the /tmp/installed.list, held "J" key untill all the
packages were in one line, added text "apt-get install" before the first
package, and saved the file.

Then I copied the file on the new laptop.

I also copied the /etc/apt/sources.list file from the old laptop to new
one.

I did apt-get update.

Then I did sh /tmp/installed.list, to install all those packages. But, I
got this:

[...cut...]
libcupsys2-gnutls10 is already the newest version.
libcurl3 is already the newest version.
libdb1-compat is already the newest version.
libdb3 is already the newest version.
libdb4.2 is already the newest version.
Package libdb4.2++ is not available, but is referred to by another
package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  libdb4.2++c2
E: Package libdb4.2++ has no installation candidate

Now, on my old laptop I have libdb4.2++ installed. If I do, on old
laptop:

root@ekim:~ # apt-cache search libdb4.2++
libdb4.2 - Berkeley v4.2 Database Libraries [runtime]
libdb4.2++-dev - Berkeley v4.2 Database Libraries for C++ [development]
libdb4.2++c2 - Berkeley v4.2 Database Libraries for C++ [runtime]
libdb4.2-dev - Berkeley v4.2 Database Libraries [development]
libdb4.2-java - Berkeley v4.2 Database Libraries for Java
libdb4.2-java-dev - Berkeley v4.2 Database Libraries for Java
[development]
libdb4.2-ruby1.6 - Interface to Berkeley DB for Ruby 1.6
libdb4.2-ruby1.8 - Interface to Berkeley DB for Ruby 1.8
libdb4.2-tcl - Berkeley v4.2 Database Libraries for TCL [module]
libdb4.2++ - Berkeley v4.2 Database Libraries for C++ [runtime]


But, on new laptop I don't have libdb4.2++:

root@mike:~/gericom_installed# apt-cache search libdb4.2++
libdb4.2 - Berkeley v4.2 Database Libraries [runtime]
libdb4.2++-dev - Berkeley v4.2 Database Libraries for C++ [development]
libdb4.2++c2 - Berkeley v4.2 Database Libraries for C++ [runtime]
libdb4.2-dev - Berkeley v4.2 Database Libraries [development]
libdb4.2-java - Berkeley v4.2 Database Libraries for Java
libdb4.2-java-dev - Berkeley v4.2 Database Libraries for Java
[development]
libdb4.2-ruby1.6 - Interface to Berkeley DB for Ruby 1.6
libdb4.2-ruby1.8 - Interface to Berkeley DB for Ruby 1.8
libdb4.2-tcl - Berkeley v4.2 Database Libraries for TCL [module]

Now, it's easy to see that libdb4.2++c2 is replacing libb4.2++, but, how
come I can still find it using apt-cache search on old laptop?

Similair happened with dozen packages, for instance, libavifile-0.7c102
(replaced by: libavifile-0.7).

Why is that so? Is that ok?

        Mike
--
"I can do it quick, I can do it cheap, I can do it well. Pick any two."

Mario Splivalo
[hidden email]



--
ubuntu-users mailing list
[hidden email]
http://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Moving Ubunto to New Laptop....

Yannick Le Saint (kyncani)
On Sun, 11 Dec 2005 13:06:07 +0100
Mario Splivalo <[hidden email]> wrote:
> Now, it's easy to see that libdb4.2++c2 is replacing libb4.2++, but, how
> come I can still find it using apt-cache search on old laptop?

You can use debfoster to remove old libraries.


---
Regards.

Yannick Le Saint (kyncani) <[hidden email]>
http://y.lesaint.free.fr/

--
ubuntu-users mailing list
[hidden email]
http://lists.ubuntu.com/mailman/listinfo/ubuntu-users

attachment0 (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Moving Ubunto to New Laptop....

Mario Splivalo-2
On Sun, 2005-12-11 at 17:08 +0100, Yannick Le Saint wrote:
> On Sun, 11 Dec 2005 13:06:07 +0100
> Mario Splivalo <[hidden email]> wrote:
> > Now, it's easy to see that libdb4.2++c2 is replacing libb4.2++, but, how
> > come I can still find it using apt-cache search on old laptop?
>
> You can use debfoster to remove old libraries.

I'll post results here, I have never used debfoster before.

        Mike
--
"I can do it quick, I can do it cheap, I can do it well. Pick any two."

Mario Splivalo
[hidden email]



--
ubuntu-users mailing list
[hidden email]
http://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Moving Ubunto to New Laptop....

Mario Splivalo-2
In reply to this post by Yannick Le Saint (kyncani)
On Sun, 2005-12-11 at 17:08 +0100, Yannick Le Saint wrote:
> On Sun, 11 Dec 2005 13:06:07 +0100
> Mario Splivalo <[hidden email]> wrote:
> > Now, it's easy to see that libdb4.2++c2 is replacing libb4.2++, but, how
> > come I can still find it using apt-cache search on old laptop?
>
> You can use debfoster to remove old libraries.

I tried using debfoster, but it tells me there are no orphaned packages.

        Mike
--
"I can do it quick, I can do it cheap, I can do it well. Pick any two."

Mario Splivalo
[hidden email]



--
ubuntu-users mailing list
[hidden email]
http://lists.ubuntu.com/mailman/listinfo/ubuntu-users