OpenOffice 3.0 - currently broken

classic Classic list List threaded Threaded
47 messages Options
123
Reply | Threaded
Open this post in threaded view
|

OpenOffice 3.0 - currently broken

Paul Lemmons
Just a heads up, if you were waiting for OO 3 to return to the PPA, the
good news ia that your wait is over! The bad news is that is is broken.
When you stry to start it, it fails. Information seen in the console
when you start it from the command line is:

.
.
.
QPainter::begin: A paint device can only be painted by one painter at a
time.
QPainter::setWorldTransform: Painter not active
ASSERT: "slOpt" in file
/build/buildd/kde4libs-4.1.3/kdeui/kernel/kstyle.cpp, line 3314
QPainter::begin: A paint device can only be painted by one painter at a
time.
QPainter::setWorldTransform: Painter not active
.
.
.

I found a German discussion on the topic but not an English one. So I
thought I would first warn others and second get a thread started.

--
kubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users

smime.p7s (4K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: OpenOffice 3.0 - currently broken

lanzen
On Tuesday 09 December 2008 20:58:28 Paul Lemmons wrote:

> Just a heads up, if you were waiting for OO 3 to return to the PPA, the
> good news ia that your wait is over! The bad news is that is is broken.

Indeed I'm one of the lucky ones... upgraded this morning.
Thanks anyway.

The funny thing is that the previous launchpad version - the one that
disappeared sometime ago - worked nicely in kubuntu.

I think the problem is in openoffice.org-kde (1:3.0.0-6ubuntu0intrepid1)

Let's hope they get it fixed soon.

--
lanzen

--
kubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: OpenOffice 3.0 - currently broken

Art Alexion-3
On Tuesday 09 December 2008 03:32:18 pm lanzen wrote:

> On Tuesday 09 December 2008 20:58:28 Paul Lemmons wrote:
> > Just a heads up, if you were waiting for OO 3 to return to the PPA, the
> > good news ia that your wait is over! The bad news is that is is broken.
>
> Indeed I'm one of the lucky ones... upgraded this morning.
> Thanks anyway.
>
> The funny thing is that the previous launchpad version - the one that
> disappeared sometime ago - worked nicely in kubuntu.
>
> I think the problem is in openoffice.org-kde (1:3.0.0-6ubuntu0intrepid1)
>
> Let's hope they get it fixed soon.


Mine broken as well.

--
kubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: OpenOffice 3.0 - currently broken

Art Alexion-3
On Tuesday 09 December 2008 3:36:21 pm Art Alexion wrote:

> On Tuesday 09 December 2008 03:32:18 pm lanzen wrote:
> > On Tuesday 09 December 2008 20:58:28 Paul Lemmons wrote:
> > > Just a heads up, if you were waiting for OO 3 to return to the PPA, the
> > > good news ia that your wait is over! The bad news is that is is broken.
> >
> > Indeed I'm one of the lucky ones... upgraded this morning.
> > Thanks anyway.
> >
> > The funny thing is that the previous launchpad version - the one that
> > disappeared sometime ago - worked nicely in kubuntu.
> >
> > I think the problem is in openoffice.org-kde (1:3.0.0-6ubuntu0intrepid1)
> >
> > Let's hope they get it fixed soon.
>
> Mine broken as well.
Wait, it is a KDE incompatibility thing.  Working fine under Gnome.



--
kubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users

signature.asc (316 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: OpenOffice 3.0 - currently broken

lanzen
On Tuesday 09 December 2008 22:12:18 Art Alexion wrote:

> Wait, it is a KDE incompatibility thing.  Working fine under Gnome.

Yes, it does. I removed openoffice.org-kde and it doesn't crash anymore, but
it's dammned ugly. The toolbar vanishes grasfully along with the menus.

--
lanzen

--
kubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: OpenOffice 3.0 - currently broken

Bugzilla from mailinglist@endosquid.com
Honestly, it's super easy to install it yourself. One of the few apps that
isn't ./configure;make;sudo make install.

Just remove the OO packages from the system, and install the OO Debs from the
site, along with the kde menu ones included. Works like a charm.

--
kubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: OpenOffice 3.0 - currently broken

O. Sinclair
Brendan wrote:
> Honestly, it's super easy to install it yourself. One of the few apps that
> isn't ./configure;make;sudo make install.
>
> Just remove the OO packages from the system, and install the OO Debs from the
> site, along with the kde menu ones included. Works like a charm.
>
Did you manage to get the filepicker to be KDE instead of OO ugly ones?
That actually scared me off the OOo 3...

--
kubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: OpenOffice 3.0 - currently broken

Bugzilla from mailinglist@endosquid.com
On Wednesday 10 December 2008, O. Sinclair wrote:
> Brendan wrote:
> > Honestly, it's super easy to install it yourself. One of the few apps
> > that isn't ./configure;make;sudo make install.
> >
> > Just remove the OO packages from the system, and install the OO Debs from
> > the site, along with the kde menu ones included. Works like a charm.
>
> Did you manage to get the filepicker to be KDE instead of OO ugly ones?
> That actually scared me off the OOo 3...

I did not try that one. The file picker in KDE 4 is not my fave yet...close,
but twitchy still.


--
kubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: OpenOffice 3.0 - currently broken

lanzen
In reply to this post by Bugzilla from mailinglist@endosquid.com
On Wednesday 10 December 2008 09:36:34 Brendan wrote:

> Just remove the OO packages from the system, and install the OO Debs from
> the site, along with the kde menu ones included. Works like a charm.

You mean from http://download.openoffice.org/?

--
lanzen

--
kubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: OpenOffice 3.0 - currently broken

Bruce Marshall
On Wednesday 10 December 2008, lanzen wrote:
> On Wednesday 10 December 2008 09:36:34 Brendan wrote:
> > Just remove the OO packages from the system, and install the OO Debs from
> > the site, along with the kde menu ones included. Works like a charm.
>
> You mean from http://download.openoffice.org/?
>
> --
> lanzen

Yes...   works like a charm...

--
kubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: OpenOffice 3.0 - currently broken

lanzen
On Wednesday 10 December 2008 18:43:22 Bruce Marshall wrote:

> Yes...   works like a charm...

Thanks. Just downloaded. Now I'll have a look.

--
lanzen

--
kubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: OpenOffice 3.0 - currently broken

Bruce Marshall
On Wednesday 10 December 2008, lanzen wrote:
> On Wednesday 10 December 2008 18:43:22 Bruce Marshall wrote:
> > Yes...   works like a charm...
>
> Thanks. Just downloaded. Now I'll have a look.
>
> --
> lanzen

After you extract it all from the tar ball, go down to the DEBS directory and
then issue:

dpkg -i *.deb

but if I recall, there are some 'redhat' pkgs (two maybe) that need to be
deleted first.   It will give an error on dependencies if they are not
deleted.  No harm done to try it first.

--
kubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: OpenOffice 3.0 - currently broken

Art Alexion-3
In reply to this post by Bugzilla from mailinglist@endosquid.com
On Wednesday 10 December 2008 3:36:34 am Brendan wrote:
> Honestly, it's super easy to install it yourself. One of the few apps that
> isn't ./configure;make;sudo make install.
>
> Just remove the OO packages from the system, and install the OO Debs from
> the site, along with the kde menu ones included. Works like a charm.

The difference is that the OOo packages install to /opt alongside 2.4 from
Kubuntu.  The PPA packages replace the Ubuntu 2.4.


--
kubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users

signature.asc (316 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: OpenOffice 3.0 - currently broken

Bugzilla from mailinglist@endosquid.com
On Wednesday 10 December 2008, Art Alexion wrote:
> On Wednesday 10 December 2008 3:36:34 am Brendan wrote:
> > Honestly, it's super easy to install it yourself. One of the few apps
> > that isn't ./configure;make;sudo make install.
> >
> > Just remove the OO packages from the system, and install the OO Debs from
> > the site, along with the kde menu ones included. Works like a charm.
>
> The difference is that the OOo packages install to /opt alongside 2.4 from
> Kubuntu.  The PPA packages replace the Ubuntu 2.4.

Yep, and there's no reason to go back to 2.4, so there isn't a downside. You
can always uninstall them and go back to the Intrepid stream.

--
kubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: OpenOffice 3.0 - currently broken

lanzen
In reply to this post by Bugzilla from mailinglist@endosquid.com
On Wednesday 10 December 2008 16:32:34 Brendan wrote:
> > Did you manage to get the filepicker to be KDE instead of OO ugly ones?
> > That actually scared me off the OOo 3...
>
> I did not try that one. The file picker in KDE 4 is not my fave
> yet...close, but twitchy still.

I cannot find an option in kubuntu, Strange, because there is one when running
in gnome.

--
lanzen


--
kubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: OpenOffice 3.0 - currently broken

lanzen
In reply to this post by Bruce Marshall
On Wednesday 10 December 2008 20:08:34 Bruce Marshall wrote:

> After you extract it all from the tar ball, go down to the DEBS directory
> and then issue:
>
> dpkg -i *.deb
>
> but if I recall, there are some 'redhat' pkgs (two maybe) that need to be
> deleted first.   It will give an error on dependencies if they are not
> deleted.  No harm done to try it first.

Thanks Bruce, I eventually followed your advice and it worked nicely and
flawlessly at the first try, no error on dependencies.

Now I'm trying to get OOo documents with OOo3 and I've managed to get an "Open
file with" option for it, By any chance, do you know of any better way to do
it? I'd rather have OOo3 by default than 2.4.

--
lanzen

--
kubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: OpenOffice 3.0 - currently broken

O. Sinclair
In reply to this post by lanzen
lanzen wrote:
> On Wednesday 10 December 2008 16:32:34 Brendan wrote:
>>> Did you manage to get the filepicker to be KDE instead of OO ugly ones?
>>> That actually scared me off the OOo 3...
>> I did not try that one. The file picker in KDE 4 is not my fave
>> yet...close, but twitchy still.
>
> I cannot find an option in kubuntu, Strange, because there is one when running
> in gnome.
>
makes me think there is a problem with the kde-package, can not remember
what it is called now. I stayed with 2.4 eventually and have installed
support for MS Office 2007 files and my favvo extension Bookmarks

--
kubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: OpenOffice 3.0 - currently broken

James Tappin
In reply to this post by Bruce Marshall
On Wed, 10 Dec 2008 12:43:22 -0500
Bruce Marshall <[hidden email]> wrote:

BM> On Wednesday 10 December 2008, lanzen wrote:
BM> > On Wednesday 10 December 2008 09:36:34 Brendan wrote:
BM> > > Just remove the OO packages from the system, and install the OO
BM> > > Debs from the site, along with the kde menu ones included. Works
BM> > > like a charm.
BM> >
BM> > You mean from http://download.openoffice.org/?
BM> >
BM> > --
BM> > lanzen
BM>
BM> Yes...   works like a charm...
BM>


Apart from the multimedia aspects. The versions from openoffice.org only
support inclusion of multimedia via JMF, whereas the ppa versions
support gstreamer.

--
+------------------------+-------------------------------+---------+
| James Tappin           | School of Physics & Astronomy |  O__    |
| [hidden email] | University of Birmingham      | --  \/` |
| Ph: 0121-414-6462. Fax: 0121-414-3722                  |         |
+--------------------------------------------------------+---------+

--
kubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: OpenOffice 3.0 - currently broken

Bruce Marshall
In reply to this post by lanzen
On Thursday 11 December 2008, lanzen wrote:
> Thanks Bruce, I eventually followed your advice and it worked nicely and
> flawlessly at the first try, no error on dependencies.
>
> Now I'm trying to get OOo documents with OOo3 and I've managed to get an
> "Open file with" option for it, By any chance, do you know of any better
> way to do it? I'd rather have OOo3 by default than 2.4.

In KDE3, it is:

settings -->  KDE components -->  file associations.

--
kubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: OpenOffice 3.0 - currently broken

Bruce Marshall
In reply to this post by Paul Lemmons
On Thursday 11 December 2008, lanzen wrote:
> Thanks Bruce, I eventually followed your advice and it worked nicely and
> flawlessly at the first try, no error on dependencies.
>
> Now I'm trying to get OOo documents with OOo3 and I've managed to get an
> "Open file with" option for it, By any chance, do you know of any better
> way to do it? I'd rather have OOo3 by default than 2.4.

You might also want to edit the K-menu for OpenOffice.org and change all the
programs to point to /opt/     In my case I think the load of OO03 did that
automatically.

--
kubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users
123