[PATCH][Zesty SRU] UBUNTU: [Debian] Use default compression for all packages

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[PATCH][Zesty SRU] UBUNTU: [Debian] Use default compression for all packages

Seth Forshee
BugLink: http://bugs.launchpad.net/bugs/1686782

Currently we specify bzip2 compression for the main and extras
packages, but bzip2 is no longer permitted in artful and causes
a ftbfs. Switch to the default compression.

Signed-off-by: Seth Forshee <[hidden email]>
---
 debian/rules.d/2-binary-arch.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/debian/rules.d/2-binary-arch.mk b/debian/rules.d/2-binary-arch.mk
index 627d869f9aa7..edda3f3ba845 100644
--- a/debian/rules.d/2-binary-arch.mk
+++ b/debian/rules.d/2-binary-arch.mk
@@ -471,7 +471,7 @@ binary-%: install-%
  dh_shlibdeps -p$(pkgimg) $(shlibdeps_opts)
  $(lockme) dh_gencontrol -p$(pkgimg) -- -Vlinux:rprovides='$(rprovides)'
  dh_md5sums -p$(pkgimg)
- dh_builddeb -p$(pkgimg) -- -Zbzip2 -z9
+ dh_builddeb -p$(pkgimg)
 
 ifeq ($(do_extras_package),true)
  if [ -f $(DEBIAN)/control.d/$(target_flavour).inclusion-list ] ; then \
@@ -483,7 +483,7 @@ ifeq ($(do_extras_package),true)
  dh_shlibdeps -p$(pkgimg_ex) $(shlibdeps_opts); \
  $(lockme) dh_gencontrol -p$(pkgimg_ex); \
  dh_md5sums -p$(pkgimg_ex); \
- dh_builddeb -p$(pkgimg_ex) -- -Zbzip2 -z9; \
+ dh_builddeb -p$(pkgimg_ex); \
  fi
 endif
 
--
2.7.4


--
kernel-team mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/kernel-team
Reply | Threaded
Open this post in threaded view
|

Re: [PATCH][Zesty SRU] UBUNTU: [Debian] Use default compression for all packages

Seth Forshee
On Thu, Apr 27, 2017 at 11:53:05AM -0500, Seth Forshee wrote:
> BugLink: http://bugs.launchpad.net/bugs/1686782
>
> Currently we specify bzip2 compression for the main and extras
> packages, but bzip2 is no longer permitted in artful and causes
> a ftbfs. Switch to the default compression.

A couple extra details to answer questions which might arise.

The reason for needing this in zesty is that we're currently copying
forward zesty kernels to artful, where it is causing us problems.

I'm told the original reason for using bzip2 was build times. But since
we're only using bzip2 for the main and extras packages the difference
is unlikely to be substantial, and comparision of ppa builds with and
without this patch bear that out.

Seth

--
kernel-team mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/kernel-team
Reply | Threaded
Open this post in threaded view
|

Ack: [PATCH][Zesty SRU] UBUNTU: [Debian] Use default compression for all packages

Brad Figg-2
In reply to this post by Seth Forshee
Reply | Threaded
Open this post in threaded view
|

[Acked] [PATCH][Zesty SRU] UBUNTU: [Debian] Use default compression for all packages

Andy Whitcroft-3
In reply to this post by Seth Forshee
On Thu, Apr 27, 2017 at 11:53:05AM -0500, Seth Forshee wrote:

> BugLink: http://bugs.launchpad.net/bugs/1686782
>
> Currently we specify bzip2 compression for the main and extras
> packages, but bzip2 is no longer permitted in artful and causes
> a ftbfs. Switch to the default compression.
>
> Signed-off-by: Seth Forshee <[hidden email]>
> ---
>  debian/rules.d/2-binary-arch.mk | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/debian/rules.d/2-binary-arch.mk b/debian/rules.d/2-binary-arch.mk
> index 627d869f9aa7..edda3f3ba845 100644
> --- a/debian/rules.d/2-binary-arch.mk
> +++ b/debian/rules.d/2-binary-arch.mk
> @@ -471,7 +471,7 @@ binary-%: install-%
>   dh_shlibdeps -p$(pkgimg) $(shlibdeps_opts)
>   $(lockme) dh_gencontrol -p$(pkgimg) -- -Vlinux:rprovides='$(rprovides)'
>   dh_md5sums -p$(pkgimg)
> - dh_builddeb -p$(pkgimg) -- -Zbzip2 -z9
> + dh_builddeb -p$(pkgimg)
>  
>  ifeq ($(do_extras_package),true)
>   if [ -f $(DEBIAN)/control.d/$(target_flavour).inclusion-list ] ; then \
> @@ -483,7 +483,7 @@ ifeq ($(do_extras_package),true)
>   dh_shlibdeps -p$(pkgimg_ex) $(shlibdeps_opts); \
>   $(lockme) dh_gencontrol -p$(pkgimg_ex); \
>   dh_md5sums -p$(pkgimg_ex); \
> - dh_builddeb -p$(pkgimg_ex) -- -Zbzip2 -z9; \
> + dh_builddeb -p$(pkgimg_ex); \
>   fi
>  endif
>  
> --
> 2.7.4

Should be benign as the consumers are already using the default for
other packages.

Acked-by: Andy Whitcroft <[hidden email]>

-apw

--
kernel-team mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/kernel-team
Reply | Threaded
Open this post in threaded view
|

APPLIED: [PATCH][Zesty SRU] UBUNTU: [Debian] Use default compression for all packages

Kleber Souza
In reply to this post by Seth Forshee