Pasticci con HD esterno

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Pasticci con HD esterno

Tullo Lolli
Buongiorno a tutti,

nonostante utilizzi Ubuntu (Kubuntu 20.04 per la precisione) ormai da
anni non ho mai imparato a cavarmela con partizioni e FSTAB, per cui
faccio danni.

Questa mattina ho formattato un hd esterno in EXT4, dal momento che lo
uso solo per backup ho pensato che fosse la cosa migliore.

Dopo alcuni tentativi tutto sembra funzionare ed ho copiato i dati senza
errori, però quando riavvio il PC l'HD non si monta, se non dal gestore
di partizioni di KDE, l'errore che ricevo é:

  Error mounting system-managed device /dev/sda1: unknown filesystem
type 'defaults'

Questo il contenuto di FSTAB:

> # <file system> <mount point>   <type>  <options>       <dump> <pass>
> LABEL=Maxtor    /media/family/Maxtor    defaults    0    0  0
> UUID=e530d5aa-0aca-441e-bf20-14dc337749e0    /    ext4
>  errors=remount-ro    0    1
> /swapfile    none    swap    sw    0    0
> LABEL=Maxtor    /media/family/Maxtor    ntfs    defaults    0  0

Altra questione, come mai in FSTAB é presente solo questo HD esterno e
non gli altri due che ci sono nel PC? Uno con il sistema operativo,
(DEV/SDB) l'altro dati (DEV/SDC)

Grazie per la pazienza.


Tullo



--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette
Reply | Threaded
Open this post in threaded view
|

Re: Pasticci con HD esterno

Luca 'remix_tj' Lorenzetto
Ciao,

Unknown filesystem defaults è dovuto al fatto che su fstab, prima di defaults e dopo il mountpoint dovevi specificare il tipo di filesystem (ext4)!

In più ci sono troppi zeri (ce ve vanno due soli) a fine riga.

Io vedo comunque un entry duplicata per maxtor, in cui una delle due specifica filesystem ntfs, è corretto?

Il filesystem / invece è referenziato per uuid, in modo corretto.

Luca


Il mer 12 ago 2020, 18:58 Tullo Lolli <[hidden email]> ha scritto:
Buongiorno a tutti,

nonostante utilizzi Ubuntu (Kubuntu 20.04 per la precisione) ormai da
anni non ho mai imparato a cavarmela con partizioni e FSTAB, per cui
faccio danni.

Questa mattina ho formattato un hd esterno in EXT4, dal momento che lo
uso solo per backup ho pensato che fosse la cosa migliore.

Dopo alcuni tentativi tutto sembra funzionare ed ho copiato i dati senza
errori, però quando riavvio il PC l'HD non si monta, se non dal gestore
di partizioni di KDE, l'errore che ricevo é:

  Error mounting system-managed device /dev/sda1: unknown filesystem
type 'defaults'

Questo il contenuto di FSTAB:

> # <file system> <mount point>   <type>  <options>       <dump> <pass>
> LABEL=Maxtor    /media/family/Maxtor    defaults    0    0  0
> UUID=e530d5aa-0aca-441e-bf20-14dc337749e0    /    ext4
>  errors=remount-ro    0    1
> /swapfile    none    swap    sw    0    0
> LABEL=Maxtor    /media/family/Maxtor    ntfs    defaults    0  0

Altra questione, come mai in FSTAB é presente solo questo HD esterno e
non gli altri due che ci sono nel PC? Uno con il sistema operativo,
(DEV/SDB) l'altro dati (DEV/SDC)

Grazie per la pazienza.


Tullo



--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette

--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette
Reply | Threaded
Open this post in threaded view
|

Re: Pasticci con HD esterno

Tullo Lolli

Il 13/08/20 07:57, Luca 'remix_tj' Lorenzetto ha scritto:
>
>
> Io vedo comunque un entry duplicata per maxtor, in cui una delle due
> specifica filesystem ntfs, è corretto?
>

Ciao,

grazie per la risposta, non é corretto, non ci sono filesystem ntfs, ma
2hd interni ext4 e il maxtor esterno ext4 pure lui.


Tullo


--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette
Reply | Threaded
Open this post in threaded view
|

Re: Pasticci con HD esterno

Tullo Lolli
In reply to this post by Luca 'remix_tj' Lorenzetto
Ho modificato fstab così:

# <file system> <mount point>   <type> <options>       <dump>  <pass>
LABEL=Maxtor    /media/family/Maxtor    ext4 defaults    0    0
UUID=e530d5aa-0aca-441e-bf20-14dc337749e0    /    ext4
errors=remount-ro    0    1
/swapfile    none    swap    sw    0    0

Ora sembra tutto a posto, grazie!


Tullo



--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette