Problema con Gestore aggiornamenti

classic Classic list List threaded Threaded
18 messages Options
Reply | Threaded
Open this post in threaded view
|

Problema con Gestore aggiornamenti

Domenico Tarricone
Buongiorno a tutti,

scusate, ma sono di nuovo qui a "rompere".
Ieri sera mi si è verificato un problema col Gestore Aggiornamenti, che, probabilmente, qualcuno di voi avrà avuto in passato.
Ho aperto il Gestore / Verifica/  e mi ha segnalato 12 aggiornamenti. Clicco su  "installa"  e dopo la richiesta della pswd  mi è apparso il seguente messaggio : " Richiede l'installazione di pacchetti non fidati" - " L'azione potrebbe richiedere l'installazione di pacchetti da sorgenti non autenticate "
Per cui non mi lascia installare gli stessi.
Ora, leggendo i nomi degli stessi, mi sembrano file o pacchetti di sistema,  ma ( ovviamente ) ne capisco poco.
Li riporto nel seguito:

Aggiornamenti di sicurezza importanti : transitional english pack for Thunderbird

Aggiornamenti raccomandati: file vari che formano il sistema di base Debian  /  libgudev-1.0 introspection data  /  power management tool for Gnome desktop  /   GObject based wrapper library for libduev  /  udev library  /  rule based device node and kernel event manager

Altri aggiornamenti  (Medibuntu): apport hooks for Medibuntu  /  libav codec library  /  libav utility  library  / MPlayer's movie encoder  /  movie player  for  Unix like systems

La /  separa ( nel mio elenco ) un aggiornamento dall'altro.

Per completezza dirò che nel Gestore Aggiornamenti / Impostazioni ho i seguenti settaggi:

1° scheda : Sw Ubuntu :  flag sui primi 4 / segno - su codice sorgente

2° scheda : altro Sw : sono flaggati : partner di Canonical / indipendente / 2 repository per Ubuntu Tweak  / 2 repository per Medibuntu  / 1 repository per Google Chrome

3° scheda : Aggiornamenti : tutti e 4 sono flaggati.


Ho provato a togliere il segno di spunta dai pacchetti della sezione "Altri aggiornamenti  (Medibuntu)",  ma niente da fare, mi appare sempre lo stesso messaggio citato all'inizio.

Altra info: io ho la 12.04.1  e non sono passato alla 12.10.

Qualcuno sa dirmi cosa posso fare ?

Grazie  e  scusate ancora.


--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette
Reply | Threaded
Open this post in threaded view
|

Re: Problema con Gestore aggiornamenti

aspex

In data domenica 4 novembre 2012 08:52:16, Domenico Tarricone ha scritto:

> Buongiorno a tutti,

>

> scusate, ma sono di nuovo qui a "rompere".

> Ieri sera mi si è verificato un problema col Gestore Aggiornamenti, che,

> probabilmente, qualcuno di voi avrà avuto in passato. Ho aperto il Gestore

> / Verifica/ e mi ha segnalato 12 aggiornamenti. Clicco su "installa" e

> dopo la richiesta della pswd mi è apparso il seguente messaggio : "

> Richiede l'installazione di pacchetti non fidati" - " L'azione potrebbe

> richiedere l'installazione di pacchetti da sorgenti non autenticate "

 

Ti avverte che manca la firma di autenticazione delle sorgenti in oggetto

 

> Per cui non mi lascia installare gli stessi.

 

Non credo, se gli dici di proseguire dovrebbe procedere con l'operazione di aggiornamento.

Dando uno sguardo alle sogìrgenti da te citate non dovresti correre nessun pericolo, in quanto sono note, quindi......

 

Ciao

Sandro

 

--

sandro - http://majaglug.net

http://www.ternistoria.blogspot.com

http://www.informaticaitaliana.blogspot.com/

GNU/Linux-BlueStar 3.2.0 -Linux User #499691 - Linux Machine #429253


--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette
Reply | Threaded
Open this post in threaded view
|

Re: Problema con Gestore aggiornamenti

mapreri
In reply to this post by Domenico Tarricone
Il 04/11/2012 08:52, Domenico Tarricone ha scritto:

> Buongiorno a tutti,
>
> scusate, ma sono di nuovo qui a "rompere".
> Ieri sera mi si è verificato un problema col Gestore Aggiornamenti, che,
> probabilmente, qualcuno di voi avrà avuto in passato.
> Ho aperto il Gestore / Verifica/  e mi ha segnalato 12 aggiornamenti.
> Clicco su  "installa"  e dopo la richiesta della pswd  mi è apparso il
> seguente messaggio : *" Richiede l'installazione di pacchetti non
> fidati" - " L'azione potrebbe richiedere l'installazione di pacchetti da
> sorgenti non autenticate "*
> Per cui non mi lascia installare gli stessi.
> Ora, leggendo i nomi degli stessi, mi sembrano file o pacchetti di
> sistema,  ma ( ovviamente ) ne capisco poco.
[...]
> Qualcuno sa dirmi cosa posso fare ?


prova ad aggiornare le sorgenti da terminale:
$ sudo apt-get update
$ sudo apt-get upgrade
e posta qui quello che esce.


--
bye,
                                                Mattia Rizzolo

GPG key: 0xb530d76b    http://goo.gl/AEW5U
Launchpad User:    https://launchpad.net/~mapreri
Ubuntu Wiki page:   https://wiki.ubuntu.com/MattiaRizzolo

--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette

0xB530D76B.asc (7K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

R: RISOLTO : Problema con Gestore aggiornamenti

Domenico Tarricone
In reply to this post by aspex

Buongiorno,

 

prima rispondo a Sandro:  ho riacceso il pc / gestore aggiornamenti,    nel frattempo i pacchetti o file da scaricare erano diventati 44.   Cosa strana la sezione relativa a Medibuntu non c’era più.

 

Ho provato a cliccare su “installa aggiornamenti”, ma niente da fare : solito messaggio / chiudo il messaggio / clicco nuovamente su installa : di nuovo il messaggio.

 

Allora sono andato in “Impostazioni “ e, dalla scheda relativa, ho tolto i segni di spunta sui 2 repository di Medibuntu.

 

Ho cliccato nuovamente su “installa”  e, questa volta, finalmente è partito lo scaricamento.

 

Ma,  Medibuntu non è un repository  “fidato” ?

 

 

Grazie  e buona domenica.

 

Da: [hidden email] [mailto:[hidden email]] Per conto di Sandro*
Inviato: domenica 4 novembre 2012 10:01
A: [hidden email]
Oggetto: Re: [ubuntu-it] Problema con Gestore aggiornamenti

 

In data domenica 4 novembre 2012 08:52:16, Domenico Tarricone ha scritto:

> Buongiorno a tutti,

>

> scusate, ma sono di nuovo qui a "rompere".

> Ieri sera mi si è verificato un problema col Gestore Aggiornamenti, che,

> probabilmente, qualcuno di voi avrà avuto in passato. Ho aperto il Gestore

> / Verifica/ e mi ha segnalato 12 aggiornamenti. Clicco su "installa" e

> dopo la richiesta della pswd mi è apparso il seguente messaggio : "

> Richiede l'installazione di pacchetti non fidati" - " L'azione potrebbe

> richiedere l'installazione di pacchetti da sorgenti non autenticate "

 

Ti avverte che manca la firma di autenticazione delle sorgenti in oggetto

 

> Per cui non mi lascia installare gli stessi.

 

Non credo, se gli dici di proseguire dovrebbe procedere con l'operazione di aggiornamento.

Dando uno sguardo alle sogìrgenti da te citate non dovresti correre nessun pericolo, in quanto sono note, quindi......

 

Ciao

Sandro

 

--

sandro - http://majaglug.net

http://www.ternistoria.blogspot.com

http://www.informaticaitaliana.blogspot.com/

GNU/Linux-BlueStar 3.2.0 -Linux User #499691 - Linux Machine #429253


--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette
Reply | Threaded
Open this post in threaded view
|

Re: R: RISOLTO : Problema con Gestore aggiornamenti

aspex
In reply to this post by aspex

In data domenica 4 novembre 2012 10:41:07, Domenico ha scritto:

> Buongiorno,

>

> prima rispondo a Sandro: ho riacceso il pc / gestore aggiornamenti, nel

> frattempo i pacchetti o file da scaricare erano diventati 44. Cosa strana

> la sezione relativa a Medibuntu non c’era più.

>

> Ho provato a cliccare su “installa aggiornamenti”, ma niente da fare :

> solito messaggio / chiudo il messaggio / clicco nuovamente su installa : di

> nuovo il messaggio.

>

> Allora sono andato in “Impostazioni “ e, dalla scheda relativa, ho tolto i

> segni di spunta sui 2 repository di Medibuntu.

>

> Ho cliccato nuovamente su “installa” e, questa volta, finalmente è partito

> lo scaricamento.

>

> Ma, Medibuntu non è un repository “fidato” ?

>

Senz'altro. Sono quasi indispensabili se vuoi avere diversi codec proprietari per il settore miltimediale.

Fai una cosa, elimina completamente i repository di medibuntu (non solo toglendo il segno di spunta ma proprio toglendoli).

Dai, ovviamente, un:

 

sudp apt-get update

 

Quindi riaggiungi i repository, con questo comando (attento che nel messaggio risulta su due righe, ma il comando è unico):


sudo wget http://www.medibuntu.org/sources.list.d/ $ (lsb_release-cs) list -. output-document = / etc / apt / sources.list.d / medibuntu.list

 

Quindi il seguente comando per la chiave di autenticazione:

 

wget-q "http://packages.medibuntu.org/medibuntu-key.gpg"-O-| sudo apt-key add

Alla fine ridai il comando:

 

sudo apt-get update

 

poi prova se ti da ancora errore..

Ciao

Sandro

 

--

sandro - http://majaglug.net

http://www.ternistoria.blogspot.com

http://www.informaticaitaliana.blogspot.com/

GNU/Linux-BlueStar 3.2.0 -Linux User #499691 - Linux Machine #429253


--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette
Reply | Threaded
Open this post in threaded view
|

Re: Problema con Gestore aggiornamenti

Domenico Tarricone
In reply to this post by mapreri
Il 04/11/2012 10:29, Mattia Rizzolo ha scritto:
Il 04/11/2012 08:52, Domenico Tarricone ha scritto:
Buongiorno a tutti,

scusate, ma sono di nuovo qui a "rompere".
Ieri sera mi si è verificato un problema col Gestore Aggiornamenti, che,
probabilmente, qualcuno di voi avrà avuto in passato.
Ho aperto il Gestore / Verifica/  e mi ha segnalato 12 aggiornamenti.
Clicco su  "installa"  e dopo la richiesta della pswd  mi è apparso il
seguente messaggio : *" Richiede l'installazione di pacchetti non
fidati" - " L'azione potrebbe richiedere l'installazione di pacchetti da
sorgenti non autenticate "*
Per cui non mi lascia installare gli stessi.
Ora, leggendo i nomi degli stessi, mi sembrano file o pacchetti di
sistema,  ma ( ovviamente ) ne capisco poco.
[...]
Qualcuno sa dirmi cosa posso fare ?

prova ad aggiornare le sorgenti da terminale:
$ sudo apt-get update
$ sudo apt-get upgrade
e posta qui quello che esce.




Rispondo a Mattia:

questa sotto è la parte finale ottenuta col comando UPDATE


W: Errore GPG: http://ppa.launchpad.net precise Release: Le seguenti firme non sono state verificate perché la chiave pubblica non è disponibile: NO_PUBKEY 6AF0E1940624A220
W: Impossibile recuperare http://ppa.launchpad.net/sevenmachines/flash/ubuntu/dists/precise/main/source/Sources  404  Not Found

W: Impossibile recuperare http://ppa.launchpad.net/sevenmachines/flash/ubuntu/dists/precise/main/binary-i386/Packages  404  Not Found

E: Impossibile scaricare alcuni file di indice: saranno ignorati o verranno usati quelli vecchi.

Questa sotto è una parte ottenuta col comando UPGRADE

ATTENZIONE: i seguenti pacchetti non possono essere autenticati.
  ubuntu-tweak


Tieni conto che, io, avendo avuto quel problema che non riuscivo a vedere i filmati in internet,  avevo dovuto installare una versione più vecchia di Flash player e  poi avevo ( nel gestore dei pacchetti ) bloccato le versione.
Inoltre, l'altro giorno ho installato Ubuntu Tweak.

Ma, quindi, d'ora in poi, dovrò aspettarmi sempre di questi problemi ?

Ciao.

--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette
Reply | Threaded
Open this post in threaded view
|

Re: R: RISOLTO : Problema con Gestore aggiornamenti

Domenico Tarricone
In reply to this post by aspex
Il 04/11/2012 10:55, Sandro* ha scritto:

In data domenica 4 novembre 2012 10:41:07, Domenico ha scritto:

> Buongiorno,

>

> prima rispondo a Sandro: ho riacceso il pc / gestore aggiornamenti, nel

> frattempo i pacchetti o file da scaricare erano diventati 44. Cosa strana

> la sezione relativa a Medibuntu non c’era più.

>

> Ho provato a cliccare su “installa aggiornamenti”, ma niente da fare :

> solito messaggio / chiudo il messaggio / clicco nuovamente su installa : di

> nuovo il messaggio.

>

> Allora sono andato in “Impostazioni “ e, dalla scheda relativa, ho tolto i

> segni di spunta sui 2 repository di Medibuntu.

>

> Ho cliccato nuovamente su “installa” e, questa volta, finalmente è partito

> lo scaricamento.

>

> Ma, Medibuntu non è un repository “fidato” ?

>

Senz'altro. Sono quasi indispensabili se vuoi avere diversi codec proprietari per il settore miltimediale.

Fai una cosa, elimina completamente i repository di medibuntu (non solo toglendo il segno di spunta ma proprio toglendoli).

Dai, ovviamente, un:

 

sudp apt-get update

 

Quindi riaggiungi i repository, con questo comando (attento che nel messaggio risulta su due righe, ma il comando è unico):


sudo wget http://www.medibuntu.org/sources.list.d/ $ (lsb_release-cs) list -. output-document = / etc / apt / sources.list.d / medibuntu.list

 

Quindi il seguente comando per la chiave di autenticazione:

 

wget-q "http://packages.medibuntu.org/medibuntu-key.gpg"-O-| sudo apt-key add

Alla fine ridai il comando:

 

sudo apt-get update

 

poi prova se ti da ancora errore..

Ciao

Sandro

 

--

sandro - http://majaglug.net

http://www.ternistoria.blogspot.com

http://www.informaticaitaliana.blogspot.com/

GNU/Linux-BlueStar 3.2.0 -Linux User #499691 - Linux Machine #429253



Nel primo comando non mi accetta nè le parentesi ( mi dice : errore di sintassi ),  nè gli "

Ora devo chiudere per impegni famigliari.

Ciao e grazie.

--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette
Reply | Threaded
Open this post in threaded view
|

Re: Problema con Gestore aggiornamenti

mapreri
In reply to this post by Domenico Tarricone
Il 04/11/2012 10:56, Domenico Tarricone ha scritto:

> *Rispondo a Mattia:**
> **
> **questa sotto è la parte finale ottenuta col comando UPDATE*
>
>
> W: Errore GPG: http://ppa.launchpad.net precise Release: Le seguenti
> firme non sono state verificate perché la chiave pubblica non è
> disponibile: NO_PUBKEY 6AF0E1940624A220

Tralasciando i 404 che alla fine non causano niente, l'errore è questo
sopra ↑↑↑

per sistemare dai
$ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv 6AF0E1940624A220

(tutto su una riga, è andato a capo alla colonna 80..)

>
> Tieni conto che, io, avendo avuto quel problema che non riuscivo a
> vedere i filmati in internet,  avevo dovuto installare una versione più
> vecchia di Flash player e  poi avevo ( nel gestore dei pacchetti )
> bloccato le versione.
> Inoltre, l'altro giorno ho installato Ubuntu Tweak.

il punto è come hai aggiunto il repository di ubuntu-tweak, medibuntu,
stando a quegli errori non centra nulla.

se hai usato add-apt-repository non dovrebbe darti quel warning, mentre
per altre vie (come aggiungere a mano le linee in /etc/apt/sources.list)
lo danno. È una cosa "normale" :)

>
> Ma, quindi, d'ora in poi, dovrò aspettarmi sempre di questi problemi ?
>

dipende da come gestisci le sorgenti software :)

--
bye,
                                                Mattia Rizzolo

GPG key: 0xb530d76b    http://goo.gl/AEW5U
Launchpad User:    https://launchpad.net/~mapreri
Ubuntu Wiki page:   https://wiki.ubuntu.com/MattiaRizzolo

--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette

0xB530D76B.asc (7K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: R: RISOLTO : Problema con Gestore aggiornamenti

aspex
In reply to this post by Domenico Tarricone

In data domenica 4 novembre 2012 11:28:52, Domenico Tarricone ha scritto:

> Nel primo comando non mi accetta nè le parentesi ( mi dice : errore

> di sintassi ), nè gli "

>

> Ora devo chiudere per impegni famigliari.

>

> Ciao e grazie.


Attento agli agli spazi!! Nei tuoi messaggi stai utilizzando del testo formattato e non va bene se fai il copia ed incolla, comunque prova:

 

sudo -E wget --output-document=/etc/apt/sources.list.d/medibuntu.list http://www.medibuntu.org/sources.list.d/$(lsb_release -cs).list && sudo apt-get --quiet update && sudo apt-get --yes --quiet --allow-unauthenticated install medibuntu-keyring && sudo apt-get --quiet update

--

sandro - http://majaglug.net

http://www.ternistoria.blogspot.com

http://www.informaticaitaliana.blogspot.com/

GNU/Linux-BlueStar 3.2.0 -Linux User #499691 - Linux Machine #429253


--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette
Reply | Threaded
Open this post in threaded view
|

Re: R: RISOLTO : Problema con Gestore aggiornamenti

mapreri
Il 04/11/2012 11:56, Sandro* ha scritto:
>  
> Attento agli agli spazi!! Nei tuoi messaggi stai utilizzando del testo
> formattato e non va bene se fai il copia ed incolla,

nella tua email di prima hai scritto questo link nel primo wget:

http://www.medibuntu.org/sources.list.d/ $ (lsb_release-cs)

come vedi ci sono due spazi in più (prima e dopo il $) e uno in meno (i
parametri di lsb_release)

:)

--
bye,
                                                Mattia Rizzolo

GPG key: 0xb530d76b    http://goo.gl/AEW5U
Launchpad User:    https://launchpad.net/~mapreri
Ubuntu Wiki page:   https://wiki.ubuntu.com/MattiaRizzolo

--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette

0xB530D76B.asc (7K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: R: RISOLTO : Problema con Gestore aggiornamenti

aspex

In data domenica 4 novembre 2012 11:59:31, Mattia Rizzolo ha scritto:

> Il 04/11/2012 11:56, Sandro* ha scritto:

> > Attento agli agli spazi!! Nei tuoi messaggi stai utilizzando del testo

> > formattato e non va bene se fai il copia ed incolla,

>

> nella tua email di prima hai scritto questo link nel primo wget:

>

> http://www.medibuntu.org/sources.list.d/ $ (lsb_release-cs)

>

> come vedi ci sono due spazi in più (prima e dopo il $) e uno in meno (i

> parametri di lsb_release)

>

 

Si, me ne sono accorto due secondi fa....(mannaggia l'età e la vista) :-)

 

Comunque si possono aggiungere anche usando "sorgenti software" e mettendo i seguenti:

deb http://packages.medibuntu.org/ precise free non-free

deb-src http://packages.medibuntu.org/ precise free non-free

 

Per poi scaricare e installare la key con il comando appropriato:

 

sudo wget-q "http://packages.medibuntu.org/medibuntu-key.gpg"-O-| sudo apt-key add

 

--

sandro - http://majaglug.net

http://www.ternistoria.blogspot.com

http://www.informaticaitaliana.blogspot.com/

GNU/Linux-BlueStar 3.2.0 -Linux User #499691 - Linux Machine #429253


--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette
Reply | Threaded
Open this post in threaded view
|

Re: R: RISOLTO : Problema con Gestore aggiornamenti

Domenico Tarricone
Il 04/11/2012 12:12, Sandro* ha scritto:

In data domenica 4 novembre 2012 11:59:31, Mattia Rizzolo ha scritto:

> Il 04/11/2012 11:56, Sandro* ha scritto:

> > Attento agli agli spazi!! Nei tuoi messaggi stai utilizzando del testo

> > formattato e non va bene se fai il copia ed incolla,

>

> nella tua email di prima hai scritto questo link nel primo wget:

>

> http://www.medibuntu.org/sources.list.d/ $ (lsb_release-cs)

>

> come vedi ci sono due spazi in più (prima e dopo il $) e uno in meno (i

> parametri di lsb_release)

>

 

Si, me ne sono accorto due secondi fa....(mannaggia l'età e la vista) :-)

 

Comunque si possono aggiungere anche usando "sorgenti software" e mettendo i seguenti:

deb http://packages.medibuntu.org/ precise free non-free

deb-src http://packages.medibuntu.org/ precise free non-free

 

Per poi scaricare e installare la key con il comando appropriato:

 

sudo wget-q "http://packages.medibuntu.org/medibuntu-key.gpg"-O-| sudo apt-key add

 

--

sandro - http://majaglug.net

http://www.ternistoria.blogspot.com

http://www.informaticaitaliana.blogspot.com/

GNU/Linux-BlueStar 3.2.0 -Linux User #499691 - Linux Machine #429253



Ciao,

ho copiato il comando ( quello lungo della tua precedente mail )  e funziona.

Mentre non funge questo:

sudo wget-q "http://packages.medibuntu.org/medibuntu-key.gpg"-O-| sudo apt-key add


Domanda : ma non sapevo che, a volte, dopo aver installato qualcosa, bisognasse anche scaricare ed installare una chiave ?



--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette
Reply | Threaded
Open this post in threaded view
|

Re: R: RISOLTO : Problema con Gestore aggiornamenti

aspex

In data domenica 4 novembre 2012 15:57:44, Domenico Tarricone ha scritto:

> Domanda : ma non sapevo che, a volte, dopo aver installato qualcosa,

> bisognasse anche scaricare ed installare una chiave ?

 

Se è quello della seconda e-mail , cioè il seguente:


>sudo -E wget --output-document=/etc/apt/sources.list.d/medibuntu.list 

>http://www.medibuntu.org/sources.list.d/$(lsb_release -cs).list && sudo apt-

>get --quiet update && sudo apt-get --yes --quiet --allow-unauthenticated 

>install medibuntu-keyring && sudo apt-get --quiet update

L'installazione della chiave era compresa, basta che guardi l'ultima parte...

Non sempre, comunque, è richiesta l'installazione di una chiave

Ciao

Sandro

 

--

sandro - http://majaglug.net

http://www.ternistoria.blogspot.com

http://www.informaticaitaliana.blogspot.com/

GNU/Linux-BlueStar 3.2.0 -Linux User #499691 - Linux Machine #429253


--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette
Reply | Threaded
Open this post in threaded view
|

Re: R: RISOLTO : Problema con Gestore aggiornamenti

mapreri
In reply to this post by Domenico Tarricone
Non per essere cattivo o petulante, ma prova la mia soluzione. riattiva
quello che hai disattivato, quindi:

$ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv 6AF0E1940624A220

e riprova.

--
bye,
                                                Mattia Rizzolo

GPG key: 0xb530d76b    http://goo.gl/AEW5U
Launchpad User:    https://launchpad.net/~mapreri
Ubuntu Wiki page:   https://wiki.ubuntu.com/MattiaRizzolo

--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette

0xB530D76B.asc (7K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: R: RISOLTO : Problema con Gestore aggiornamenti

Domenico Tarricone
Il 04/11/2012 19:28, Mattia Rizzolo ha scritto:
Non per essere cattivo o petulante, ma prova la mia soluzione. riattiva
quello che hai disattivato, quindi:

$ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv 6AF0E1940624A220

e riprova.



Dubbio e domanda:

1) dubbio : ma questa chiave alfanumerica che mi hai dato ( già in una tua precedente ) si riferisce a Medibuntu o a Ubuntu Tweak ?  Se è quella di Ubuntu Tweak, a me servirebbe ( se serve ) quella di Medibuntu.

2) domanda : queste chiavi, qualora necessarie,  dove si trovano / scaricano ?

Grazie.


--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette
Reply | Threaded
Open this post in threaded view
|

Re: R: RISOLTO : Problema con Gestore aggiornamenti

mapreri
Il 05/11/2012 20:35, Domenico Tarricone ha scritto:

> Il 04/11/2012 19:28, Mattia Rizzolo ha scritto:
>> Non per essere cattivo o petulante, ma prova la mia soluzione. riattiva
>> quello che hai disattivato, quindi:
>>
>> $ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv
>> 6AF0E1940624A220
>>
>> e riprova.
>>
>>
>>
> Dubbio e domanda:
Per rispondere alle tue domande è necessaria una premessa:
Tutti i repository per sistemi gnu/linux importanti (non solo debian,
quindi ubuntu) forniscono pacchetti binari firmati digitalmente
attraverso gpg. Anche i pacchetti sorgenti più importanti (linux, tutto
il corpo gnu, xorg, e moltissimi alti) sono firmati (anche se con una
file di firma separato, in questo caso).
Questo permette di capire se una persona ti sta distribuendo un
pacchetto modificato e potenzialmente pericoloso.

Ora devi sapere che il processo di firma gpg è basato su una coppia di
chiavi pubbliche e private, e quelle private, per ovvi motivi sono
segrete, e solo il proprietario ci ha accesso.
Per effettuare la firma è necessaria solo quella privata, mentre per
verificarla è necessaria solo quella pubblica.

La chiave pubblica è una stringa molto lunga, come questa
http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xB0B342BCB530D76B
(che è la mia, trovi il link sempre sotto in firma, e anche la allego,
la mia chiave pubblica...).
Nei sistemi debian esiste un pacchetto (debian-keyring) che contiene le
chiavi usate nei repository ufficiali debian (lo cito perchè con degli
hack è possibile usare i repo debian in ubuntu), e l'equivalente avviene
per ubuntu e i suoi repository.

Inoltre i gestori di pacchetti di queste distribuzioni che firmano i
pacchetti di default installano solo pacchetti firmati (ovviamente è un
comportamento modificabile, ma è sconsigliato)


Ora inverto le domande, per tenere un filo logico ;P

> 2) domanda : queste chiavi, qualora necessarie,  dove si trovano /
> scaricano ?

Ubuntu ha introdotto una novità: quella dei ppa, che consentono a
chiunque di avere un repository personale (che è la traduzione di ppa:
personal package archive).
I pacchetti di questi repository necessitano di essere firmati per
essere usati, infatti alla creazione di un ppa viene generata una coppia
di chiavi (In cui nemmeno il proprietario ha accesso a quella privata,
tra l'altro), usate per firmare i pacchetti.
Come ho scritto qualche email fa, add-apt-repository si occupa, tra le
altre cose, di scaricare la chiave pubblica usata per quel repository in
completa autonomia, predendo le informazioni necessarie da launchpad, e
poi usando apt-key per aggiungerla al portachiavi di apt.

In altri casi (come l'inserimento manuale di voci di repository esterni
in /etc/apt/sources.list oppure uno dei file in
/etc/apt/sources.list.d/) la chiave va importata manualmente via apt-key.

L'informazione necessaria per i ppa la trovi sulla pagina di launchpad
apposita (come questa di un mio ppa
https://launchpad.net/~mapreri/+archive/ubuntu-it-community-accomplishments
(NON USARLO!!)) sotto la voce che compare cliccando su "Techinical
details about this PPA" (in verde poco sopra la lista dei pacchetti).
C'è una voce "Fingerprint", che corrisponde all'impronta della chiave.
Nel mio caso è 5D76B3C6A5D8CFBFDF6DFC2D035AC6DD3322973A, che è
riconducibile a questa chiave:
http://keyserver.ubuntu.com:11371/pks/lookup?search=0x5D76B3C6A5D8CFBFDF6DFC2D035AC6DD3322973A&op=vindex&fingerprint=on

apt-key altro non è che un front-end per gpg, che ha parecchie opzioni.
Anche se non so usare quelle di apt-key (so solo che "adv" serve per
specificare direttamente quelle di gpg), conosco quelle di gpg, e questo
ha un'opzione --recv che consente di specificare l'improta della chiave,
oppure la sua (boh, non mi ricordo come si chiama.. :P) "forma breve",
che consiste in un 0x<ultimi 8 caratteri dell'impronta>, nel caso del
mio ppa è 0x3322973A.

>
> 1) dubbio : ma questa chiave alfanumerica che mi hai dato ( già in una
> tua precedente ) si riferisce a Medibuntu o a Ubuntu Tweak ?  Se è
> quella di Ubuntu Tweak, a me servirebbe ( se serve ) quella di Medibuntu.

Non credo ti serva quella di medibuntu, ogni sito riporta le istruzioni
complete di scaricamento della chiave. piuttosto io quel numero (perchè
alla fine la chiave è un lungo numero esadecimale, quindi usa 16
caratteri, comprese 6 lettere) l'ho ricavato dall'errore di apt-get
update che mi hai postato:

> W: Errore GPG: http://ppa.launchpad.net precise Release: Le seguenti firme non sono state verificate perché la chiave pubblica non è disponibile: NO_PUBKEY 6AF0E1940624A220

Come vedi questo errore riporta anche il server (purtroppo non tutto il
percorso, quindi non è immediato risalire al preciso ppa, però puoi
vedere da qui (quella stringa è una versione un po' più lunga della
versione ridotta dell'impronta, al posto di usare 8 cifre, ne usa 16)
http://keyserver.ubuntu.com:11371/pks/lookup?search=0x6AF0E1940624A220&op=vindex&fingerprint=on
che è "Launchpad PPA for TualatriX", e tualatrix è il nick dello
sviluppatore di ubuntu-tweak.

>
> Grazie.
>

Spero di non aver passato quasi mezz'ora a scrivere per niente :)
Però magari puoi vedere di approfondire un po' come funziona il tutto,
ho fatto parecchie sintesi :)

--
bye,
                                                Mattia Rizzolo

GPG key: 0xb530d76b    http://goo.gl/AEW5U
Launchpad User:    https://launchpad.net/~mapreri
Ubuntu Wiki page:   https://wiki.ubuntu.com/MattiaRizzolo

--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette

0xB530D76B.asc (7K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: R: RISOLTO : Problema con Gestore aggiornamenti

Domenico Tarricone
Il 05/11/2012 21:35, Mattia Rizzolo ha scritto:
Il 05/11/2012 20:35, Domenico Tarricone ha scritto:
Il 04/11/2012 19:28, Mattia Rizzolo ha scritto:
Non per essere cattivo o petulante, ma prova la mia soluzione. riattiva
quello che hai disattivato, quindi:

$ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv
6AF0E1940624A220

e riprova.



Dubbio e domanda:
Per rispondere alle tue domande è necessaria una premessa:
Tutti i repository per sistemi gnu/linux importanti (non solo debian,
quindi ubuntu) forniscono pacchetti binari firmati digitalmente
attraverso gpg. Anche i pacchetti sorgenti più importanti (linux, tutto
il corpo gnu, xorg, e moltissimi alti) sono firmati (anche se con una
file di firma separato, in questo caso).
Questo permette di capire se una persona ti sta distribuendo un
pacchetto modificato e potenzialmente pericoloso.

Ora devi sapere che il processo di firma gpg è basato su una coppia di
chiavi pubbliche e private, e quelle private, per ovvi motivi sono
segrete, e solo il proprietario ci ha accesso.
Per effettuare la firma è necessaria solo quella privata, mentre per
verificarla è necessaria solo quella pubblica.

La chiave pubblica è una stringa molto lunga, come questa
http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xB0B342BCB530D76B
(che è la mia, trovi il link sempre sotto in firma, e anche la allego,
la mia chiave pubblica...).
Nei sistemi debian esiste un pacchetto (debian-keyring) che contiene le
chiavi usate nei repository ufficiali debian (lo cito perchè con degli
hack è possibile usare i repo debian in ubuntu), e l'equivalente avviene
per ubuntu e i suoi repository.

Inoltre i gestori di pacchetti di queste distribuzioni che firmano i
pacchetti di default installano solo pacchetti firmati (ovviamente è un
comportamento modificabile, ma è sconsigliato)


Ora inverto le domande, per tenere un filo logico ;P

2) domanda : queste chiavi, qualora necessarie,  dove si trovano /
scaricano ?
Ubuntu ha introdotto una novità: quella dei ppa, che consentono a
chiunque di avere un repository personale (che è la traduzione di ppa:
personal package archive).
I pacchetti di questi repository necessitano di essere firmati per
essere usati, infatti alla creazione di un ppa viene generata una coppia
di chiavi (In cui nemmeno il proprietario ha accesso a quella privata,
tra l'altro), usate per firmare i pacchetti.
Come ho scritto qualche email fa, add-apt-repository si occupa, tra le
altre cose, di scaricare la chiave pubblica usata per quel repository in
completa autonomia, predendo le informazioni necessarie da launchpad, e
poi usando apt-key per aggiungerla al portachiavi di apt.

In altri casi (come l'inserimento manuale di voci di repository esterni
in /etc/apt/sources.list oppure uno dei file in
/etc/apt/sources.list.d/) la chiave va importata manualmente via apt-key.

L'informazione necessaria per i ppa la trovi sulla pagina di launchpad
apposita (come questa di un mio ppa
https://launchpad.net/~mapreri/+archive/ubuntu-it-community-accomplishments
(NON USARLO!!)) sotto la voce che compare cliccando su "Techinical
details about this PPA" (in verde poco sopra la lista dei pacchetti).
C'è una voce "Fingerprint", che corrisponde all'impronta della chiave.
Nel mio caso è 5D76B3C6A5D8CFBFDF6DFC2D035AC6DD3322973A, che è
riconducibile a questa chiave:
http://keyserver.ubuntu.com:11371/pks/lookup?search=0x5D76B3C6A5D8CFBFDF6DFC2D035AC6DD3322973A&op=vindex&fingerprint=on

apt-key altro non è che un front-end per gpg, che ha parecchie opzioni.
Anche se non so usare quelle di apt-key (so solo che "adv" serve per
specificare direttamente quelle di gpg), conosco quelle di gpg, e questo
ha un'opzione --recv che consente di specificare l'improta della chiave,
oppure la sua (boh, non mi ricordo come si chiama.. :P) "forma breve",
che consiste in un 0x<ultimi 8 caratteri dell'impronta>, nel caso del
mio ppa è 0x3322973A.

1) dubbio : ma questa chiave alfanumerica che mi hai dato ( già in una
tua precedente ) si riferisce a Medibuntu o a Ubuntu Tweak ?  Se è
quella di Ubuntu Tweak, a me servirebbe ( se serve ) quella di Medibuntu.
Non credo ti serva quella di medibuntu, ogni sito riporta le istruzioni
complete di scaricamento della chiave. piuttosto io quel numero (perchè
alla fine la chiave è un lungo numero esadecimale, quindi usa 16
caratteri, comprese 6 lettere) l'ho ricavato dall'errore di apt-get
update che mi hai postato:

W: Errore GPG: http://ppa.launchpad.net precise Release: Le seguenti firme non sono state verificate perché la chiave pubblica non è disponibile: NO_PUBKEY 6AF0E1940624A220 
Come vedi questo errore riporta anche il server (purtroppo non tutto il
percorso, quindi non è immediato risalire al preciso ppa, però puoi
vedere da qui (quella stringa è una versione un po' più lunga della
versione ridotta dell'impronta, al posto di usare 8 cifre, ne usa 16)
http://keyserver.ubuntu.com:11371/pks/lookup?search=0x6AF0E1940624A220&op=vindex&fingerprint=on
che è "Launchpad PPA for TualatriX", e tualatrix è il nick dello
sviluppatore di ubuntu-tweak.

Grazie.

Spero di non aver passato quasi mezz'ora a scrivere per niente :)
Però magari puoi vedere di approfondire un po' come funziona il tutto,
ho fatto parecchie sintesi :)



Grazie,  domani  mi stampo la tua mail e cerco di approfondire.

--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette
Reply | Threaded
Open this post in threaded view
|

Re: R: RISOLTO : Problema con Gestore aggiornamenti

mapreri
Il 05/11/2012 21:45, Domenico Tarricone ha scritto:
> Grazie,  domani  mi stampo la tua mail e cerco di approfondire.

Beh, non serve stamparla, basta leggerla :)


Inoltre se qualcuno magari controlla che non abbia scritto inesattezza,
me lo segnali, che non si sa mai :)

--
bye,
                                                Mattia Rizzolo

GPG key: 0xb530d76b    http://goo.gl/AEW5U
Launchpad User:    https://launchpad.net/~mapreri
Ubuntu Wiki page:   https://wiki.ubuntu.com/MattiaRizzolo

--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette

0xB530D76B.asc (7K) Download Attachment