Python 3.9 for Ubuntu 21.04 (h-series)

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Python 3.9 for Ubuntu 21.04 (h-series)

Matthias Klose-6
Python 3.9 will be the default Python3 version for 21.04 (h-series).  A year ago
we prepared for 3.8 as the default in focal, going ahead of Debian.  For the
transition to 3.9, we started PPA test rebuilds [1] [2] while groovy was frozen,
and submitted bug reports for Debian [3], before starting the 3.9 addition in
Debian [4].  With the opening of the h-series, we will add 3.9 as a supported
Python3 version [5], and then making it the default, hopefully before the end of
the year.

Matthias

[1] https://launchpad.net/~pythoneers/+archive/ubuntu/python3.9/+packages
[2] https://launchpad.net/~pythoneers/+archive/ubuntu/python3.9-fixes/+packages
[3]
https://bugs.debian.org/cgi-bin/pkgreport.cgi?tag=python3.9;users=debian-python@...
[4] https://release.debian.org/transitions/html/python3.9.html
[5] https://people.canonical.com/~ubuntu-archive/transitions/html/python3.9-add.html

--
ubuntu-devel mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel
Reply | Threaded
Open this post in threaded view
|

Re: Python 3.9 for Ubuntu 21.04 (h-series)

Matthias Klose-6
On 10/15/20 1:16 PM, Matthias Klose wrote:

> Python 3.9 will be the default Python3 version for 21.04 (h-series).  A year ago
> we prepared for 3.8 as the default in focal, going ahead of Debian.  For the
> transition to 3.9, we started PPA test rebuilds [1] [2] while groovy was frozen,
> and submitted bug reports for Debian [3], before starting the 3.9 addition in
> Debian [4].  With the opening of the h-series, we will add 3.9 as a supported
> Python3 version [5], and then making it the default, hopefully before the end of
> the year.
>
> Matthias
>
> [1] https://launchpad.net/~pythoneers/+archive/ubuntu/python3.9/+packages
> [2] https://launchpad.net/~pythoneers/+archive/ubuntu/python3.9-fixes/+packages
> [3]
> https://bugs.debian.org/cgi-bin/pkgreport.cgi?tag=python3.9;users=debian-python@...
> [4] https://release.debian.org/transitions/html/python3.9.html
> [5] https://people.canonical.com/~ubuntu-archive/transitions/html/python3.9-add.html
python3-defaults supporting 3.9 is now in hirsute-proposed.  This package, and
many other packages providing python3.9 extensions are still in the -proposed
pocket.  For failing autopkg tests you need to trigger with python3-defaults and
packages from the proposed pocket providing a 3.9 extension, or more simple with
all-proposed=1 until these migrate.

Matthias

--
ubuntu-devel mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel