Python su 18.04 Mate

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Python su 18.04 Mate

Felix_55

Buongiorno e buona Domenica a tutti,
Da oltre 1 mese, ad ogni aggiornamento, ricevo questo msg di errore:

"Si sono verificati degli errori nell'elaborazione:
python3
update-notifier-common
python3-update-manager
netplan.io
ubuntu-release-upgrader-core
pyqt5-dev-tools
python3-netifaces
python3-uno
software-properties-gtk
update-notifier
gnome-software
unattended-upgrades
update-manager
python3-gdbm:amd64
python3-software-properties
python3-distupgrade
software-properties-common
ufw
ubuntu-release-upgrader-gtk
update-manager-core
python3-apt
gnome-software-plugin-snap
E: Sub-process /usr/bin/dpkg returned an error code (1)

Inoltre:
1) ogni volta che accendo il PC mi segnala errore (dopo la segnalazione riferisce che il bug è già noto agli sviluppatori);
2) non posso aggiornare HPlip altrimenti perdo la funzionalità FAX.

Qualcuno ha notizie di questi bugs? Dobbiamo tenerceli o risolveranno?

Grazie,
Felice


--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette
Reply | Threaded
Open this post in threaded view
|

Re: Python su 18.04 Mate

Daniele Piccoli
On 10/02/19 12:55, [hidden email] wrote:

> Buongiorno e buona Domenica a tutti,
> Da oltre 1 mese, ad ogni aggiornamento, ricevo questo msg di errore:
>
> "Si sono verificati degli errori nell'elaborazione:
> python3
> update-notifier-common
> python3-update-manager
> netplan.io
> ubuntu-release-upgrader-core
> pyqt5-dev-tools
> python3-netifaces
> python3-uno
> software-properties-gtk
> update-notifier
> gnome-software
> unattended-upgrades
> update-manager
> python3-gdbm:amd64
> python3-software-properties
> python3-distupgrade
> software-properties-common
> ufw
> ubuntu-release-upgrader-gtk
> update-manager-core
> python3-apt
> gnome-software-plugin-snap
> E: Sub-process /usr/bin/dpkg returned an error code (1)

Questo problema va risolto, non è normale avere questo comportamento

Apri un terminale e dai

$ sudo dpkg --configure -a

se non dovesse fare niente o non funzionare prova con:

$ sudo apt-get install -f

> Inoltre:
> 1) ogni volta che accendo il PC mi segnala errore (dopo la segnalazione> riferisce che il bug è già noto agli sviluppatori);

Probabilmente da 1 mese il tuo sistema non si sta aggiornando, visto che
ti riporta quel messaggio sopra e quindi dpkg non conclude in maniera
corretta la procedura.

> 2) non posso aggiornare HPlip altrimenti perdo la funzionalità FAX.

Beh, per questo puoi sempre bloccare il pacchetto in questione in
maniera che non si aggiorni

$ sudo apt-mark hold nomepacchetto

Per vedere la lista dei pacchetti bloccati

$ sudo apt-mark showhold

> Qualcuno ha notizie di questi bugs? Dobbiamo tenerceli o risolveranno?
>
> Grazie,
> Felice
>

Ciao
Daniele

--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette
Reply | Threaded
Open this post in threaded view
|

Re: Python su 18.04 Mate

Felix_55
Il 10/02/19 19:36, Daniele Piccoli ha scritto:

> On 10/02/19 12:55, [hidden email] wrote:
>> Buongiorno e buona Domenica a tutti,
>> Da oltre 1 mese, ad ogni aggiornamento, ricevo questo msg di errore:
>>
>> "Si sono verificati degli errori nell'elaborazione:
>> python3
>> update-notifier-common
>> python3-update-manager
>> netplan.io
>> ubuntu-release-upgrader-core
>> pyqt5-dev-tools
>> python3-netifaces
>> python3-uno
>> software-properties-gtk
>> update-notifier
>> gnome-software
>> unattended-upgrades
>> update-manager
>> python3-gdbm:amd64
>> python3-software-properties
>> python3-distupgrade
>> software-properties-common
>> ufw
>> ubuntu-release-upgrader-gtk
>> update-manager-core
>> python3-apt
>> gnome-software-plugin-snap
>> E: Sub-process /usr/bin/dpkg returned an error code (1)
>
> Questo problema va risolto, non è normale avere questo comportamento
>
> Apri un terminale e dai
>
> $ sudo dpkg --configure -a
>
> se non dovesse fare niente o non funzionare prova con:
>
> $ sudo apt-get install -f
>

Sono le prime istruzioni che ho dato, ma senza risultato...
Il mio sistema non era aggiornato ma poi si è aggiornato e continua a
farlo; solo quei particolari pacchetti, da un mesetto, non si aggiornano
e all'apertura del sistema mi segnala sempre errore da segnalare agli
sviluppatori...
Il resto non lo commento perchè è procedura normale ed adottata...
La faccenda è davvero strana, purtroppo...

Grazie per la cortese risposta,
Felice

--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette
Reply | Threaded
Open this post in threaded view
|

Re: Python su 18.04 Mate

Daniele Piccoli
On 10/02/19 21:40, Felix_55 wrote:

> Il 10/02/19 19:36, Daniele Piccoli ha scritto:
>> On 10/02/19 12:55, [hidden email] wrote:
>>> Buongiorno e buona Domenica a tutti,
>>> Da oltre 1 mese, ad ogni aggiornamento, ricevo questo msg di errore:
>>>
>>> "Si sono verificati degli errori nell'elaborazione:
>>> python3
>>> update-notifier-common
>>> python3-update-manager
>>> netplan.io
>>> ubuntu-release-upgrader-core
>>> pyqt5-dev-tools
>>> python3-netifaces
>>> python3-uno
>>> software-properties-gtk
>>> update-notifier
>>> gnome-software
>>> unattended-upgrades
>>> update-manager
>>> python3-gdbm:amd64
>>> python3-software-properties
>>> python3-distupgrade
>>> software-properties-common
>>> ufw
>>> ubuntu-release-upgrader-gtk
>>> update-manager-core
>>> python3-apt
>>> gnome-software-plugin-snap
>>> E: Sub-process /usr/bin/dpkg returned an error code (1)
>>
>> Questo problema va risolto, non è normale avere questo comportamento
>>
>> Apri un terminale e dai
>>
>> $ sudo dpkg --configure -a
>>
>> se non dovesse fare niente o non funzionare prova con:
>>
>> $ sudo apt-get install -f
>>
>
> Sono le prime istruzioni che ho dato, ma senza risultato...

Allora potresti provare a procedere così:

 - cerca i file relativi ai pacchetti sopra indicati nella directory
/var/lib/dpkg/info/ e spostali temporaneamente da qualche altra parte,
così da averli in caso ci fossero problemi

 - riprova con sudo apt update && sudo apt full-upgrade

 - se tutto torna a funzionare puoi eliminare i file precedentemente
spostati

> Il mio sistema non era aggiornato ma poi si è aggiornato e continua a
> farlo; solo quei particolari pacchetti, da un mesetto, non si aggiornano
> e all'apertura del sistema mi segnala sempre errore da segnalare agli
> sviluppatori...
> Il resto non lo commento perchè è procedura normale ed adottata...
> La faccenda è davvero strana, purtroppo...
>
> Grazie per la cortese risposta,
> Felice

Daniele

--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette
Reply | Threaded
Open this post in threaded view
|

RISOLTO Re: Python su 18.04 Mate

Felix_55
Il 10/02/19 22:22, Daniele Piccoli ha scritto:

> On 10/02/19 21:40, Felix_55 wrote:
>> Il 10/02/19 19:36, Daniele Piccoli ha scritto:
>>> On 10/02/19 12:55, [hidden email] wrote:
>>>> Buongiorno e buona Domenica a tutti,
>>>> Da oltre 1 mese, ad ogni aggiornamento, ricevo questo msg di errore:
>>>>
>>>> "Si sono verificati degli errori nell'elaborazione:
>>>> python3
>>>> update-notifier-common
>>>> python3-update-manager
>>>> netplan.io
>>>> ubuntu-release-upgrader-core
>>>> pyqt5-dev-tools
>>>> python3-netifaces
>>>> python3-uno
>>>> software-properties-gtk
>>>> update-notifier
>>>> gnome-software
>>>> unattended-upgrades
>>>> update-manager
>>>> python3-gdbm:amd64
>>>> python3-software-properties
>>>> python3-distupgrade
>>>> software-properties-common
>>>> ufw
>>>> ubuntu-release-upgrader-gtk
>>>> update-manager-core
>>>> python3-apt
>>>> gnome-software-plugin-snap
>>>> E: Sub-process /usr/bin/dpkg returned an error code (1)
>>>
>>> Questo problema va risolto, non è normale avere questo comportamento
>>>
>>> Apri un terminale e dai
>>>
>>> $ sudo dpkg --configure -a
>>>
>>> se non dovesse fare niente o non funzionare prova con:
>>>
>>> $ sudo apt-get install -f
>>>
>>
>> Sono le prime istruzioni che ho dato, ma senza risultato...
>
> Allora potresti provare a procedere così:
>
>   - cerca i file relativi ai pacchetti sopra indicati nella directory
> /var/lib/dpkg/info/ e spostali temporaneamente da qualche altra parte,
> così da averli in caso ci fossero problemi
>
>   - riprova con sudo apt update && sudo apt full-upgrade
>
>   - se tutto torna a funzionare puoi eliminare i file precedentemente
> spostati
>

Ok, grazie, il problema si è risolto...
Resta un piccolo inconveniente: ad ogni riavvio si ripresenta il
messaggio di errore di sistema da segnalare agli sviluppatori; però, se
si sceglie di segnalare, non accade nulla...

Per farlo scomparire probabilmente dovrei aggiornare aggiornare Hplip e
lo farò al prossimo backup completo del sistema...

Un caro saluto al cortesissimo Daniele ed a tutta la lista,
Felice


--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette
Reply | Threaded
Open this post in threaded view
|

Re: RISOLTO Re: Python su 18.04 Mate

Daniele Piccoli
On 11/02/19 09:38, Felix_55 wrote:
>
> Ok, grazie, il problema si è risolto...

Bene :)

> Resta un piccolo inconveniente: ad ogni riavvio si ripresenta il
> messaggio di errore di sistema da segnalare agli sviluppatori; però, se
> si sceglie di segnalare, non accade nulla...

Spesso quando ho usato Ubuntu ho visto comparire quella segnalazione, ma
non ho mai indagato :)

> Per farlo scomparire probabilmente dovrei aggiornare aggiornare Hplip e
> lo farò al prossimo backup completo del sistema...

Non credo sia legato ad HPLIP, ma senza ulteriori dettagli è difficile
dirlo.

> Un caro saluto al cortesissimo Daniele ed a tutta la lista,
> Felice
>
>

Buona serata a voi
Daniele

--
ubuntu-it mailing list
[hidden email]
Opzioni d'iscrizione - https://lists.ubuntu.com/mailman/listinfo/ubuntu-it
http://wiki.ubuntu-it.org/Listiquette