Quantcast

Raro mensaje de update y falla en youtube-dl

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Raro mensaje de update y falla en youtube-dl

Douglas Jiménez
Hola a todos:

Pareciera que estuviera usando este hilo para dos problemas distintos pero, en realidad, el segundo problema lo comencé a ver cuando apareció el primero y no sé si están ligados.

El caso es que cuando hago sudo apt-get update la rutina termina invariablemente con este mensaje:

W: No existe ninguna clave pública disponible para los siguientes identificadores de clave:
1397BC53640DB551

aunque después puedo hacer el upgrade sin problemas aparentes.

Desde que se presenta esta situación no he podido bajar ningún vídeo de youtube con youtube-dl pues me envía este mensaje:

[youtube] Setting language
WARNING: unable to set language: <urlopen error [Errno 8] _ssl.c:510: EOF occurred in violation of protocol>
[youtube] 0h3kJVG2K1M: Downloading webpage
ERROR: Unable to download webpage: <urlopen error [Errno 8] _ssl.c:510: EOF occurred in violation of protocol>

¿Es una casualidad? ¿Están relacionados? ¿Cómo puedo resolver cada caso si no están relacionados?

Gracias por adelantado.

Saludos.

Douglas.

--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Raro mensaje de update y falla en youtube-dl

Mauricio J. Adonis C.

Hola.
Lo que pasa es que usas un repositorio que no presenta el archivo de seguridad correspondiente, puede que no exista este fichero con la firma o que haya que descargarlo de algún servidor de claves.
Este archivo sirve para asegurar que los paquetes del repo son seguros,  sin embargo aunque no exista, igual se pueden instalar dichos paquetes...  a riesgo personal.

Saludos,
Mauricio J. Adonis C.


El 17-07-2016 20:37, "Douglas Jiménez" <[hidden email]> escribió:
Hola a todos:

Pareciera que estuviera usando este hilo para dos problemas distintos pero, en realidad, el segundo problema lo comencé a ver cuando apareció el primero y no sé si están ligados.

El caso es que cuando hago sudo apt-get update la rutina termina invariablemente con este mensaje:

W: No existe ninguna clave pública disponible para los siguientes identificadores de clave:
1397BC53640DB551

aunque después puedo hacer el upgrade sin problemas aparentes.

Desde que se presenta esta situación no he podido bajar ningún vídeo de youtube con youtube-dl pues me envía este mensaje:

[youtube] Setting language
WARNING: unable to set language: <urlopen error [Errno 8] _ssl.c:510: EOF occurred in violation of protocol>
[youtube] 0h3kJVG2K1M: Downloading webpage
ERROR: Unable to download webpage: <urlopen error [Errno 8] _ssl.c:510: EOF occurred in violation of protocol>

¿Es una casualidad? ¿Están relacionados? ¿Cómo puedo resolver cada caso si no están relacionados?

Gracias por adelantado.

Saludos.

Douglas.

--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es

--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Raro mensaje de update y falla en youtube-dl

GatoLoko .
In reply to this post by Douglas Jiménez
El 18/07/16 a las 02:36, Douglas Jiménez escribió:
> Hola a todos:
>
> Pareciera que estuviera usando este hilo para dos problemas distintos
> pero, en realidad, el segundo problema lo comencé a ver cuando apareció
> el primero y no sé si están ligados.

Son dos problemas diferentes.

> El caso es que cuando hago sudo apt-get update la rutina termina
> invariablemente con este mensaje:
>
> W: No existe ninguna clave pública disponible para los siguientes
> identificadores de clave:
> 1397BC53640DB551

Este mensaje te indica que no tienes la clave publica para verificar los
paquetes de un repositorio, probablemente uno no oficial añadido por ti.

Para resolverlo, ejecuta lo siguiente (es una sola linea):

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com
1397BC53640DB551

Si no falla nada, descargará la clave publica y la añadirá a tu sistema.
Después de hacer un nuevo update desaparecerá el problema..


> Desde que se presenta esta situación no he podido bajar ningún vídeo de
> youtube con youtube-dl pues me envía este mensaje:
>
> [youtube] Setting language
> WARNING: unable to set language: <urlopen error [Errno 8] _ssl.c:510:
> EOF occurred in violation of protocol>
> [youtube] 0h3kJVG2K1M: Downloading webpage
> ERROR: Unable to download webpage: <urlopen error [Errno 8] _ssl.c:510:
> EOF occurred in violation of protocol>
>
> ¿Es una casualidad? ¿Están relacionados? ¿Cómo puedo resolver cada caso
> si no están relacionados?
Si, es casualidad y no tiene nada que ver con el otro. Este problema se
puede deber a dos causas, una es que tu versión de youtube-dl es antigua
y la otra es que este roto.

En el primer caso, no soporta alguno de los cambios que ha hecho youtube
o la página de la que intentas descargar el vídeo y necesitas una
versión más reciente.

En el segundo caso, reinstala youtube-dl.


--
Raúl Soriano




--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es

signature.asc (220 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Raro mensaje de update y falla en youtube-dl

Douglas Jiménez
El 18 de julio de 2016, 19:03, GatoLoko <[hidden email]> escribió:
El 18/07/16 a las 02:36, Douglas Jiménez escribió:
> ...

Para resolverlo, ejecuta lo siguiente (es una sola linea):

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com
1397BC53640DB551

Si no falla nada, descargará la clave publica y la añadirá a tu sistema.
Después de hacer un nuevo update desaparecerá el problema..

Gracias. Esa es exactamente la solución.

...


En el primer caso, no soporta alguno de los cambios que ha hecho youtube
o la página de la que intentas descargar el vídeo y necesitas una
versión más reciente.

En el segundo caso, reinstala youtube-dl.

Lo removí e instalé de nuevo. No cambió la conducta.

Gracias de nuevo.

Douglas.

--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Raro mensaje de update y falla en youtube-dl

GatoLoko .
El 19/07/16 a las 01:48, Douglas Jiménez escribió:

>     En el primer caso, no soporta alguno de los cambios que ha hecho youtube
>     o la página de la que intentas descargar el vídeo y necesitas una
>     versión más reciente.
>
>     En el segundo caso, reinstala youtube-dl.
>
>
> Lo removí e instalé de nuevo. No cambió la conducta.

Entonces tienes el primer caso, la versión de youtube-dl disponible en
tus repositorios está anticuada.

Por ejemplo, ejecutando "apt-cache policy youtube-dl" en Ubuntu 16.06
podemos ver que la versión disponible en los repositorios oficiales es
la "2016.02.22-1", pero en la web de youtube-dl, la versión más reciente
es la "2016.07.17".

--
Raúl Soriano




--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es

signature.asc (220 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Raro mensaje de update y falla en youtube-dl

Douglas Jiménez
El 19 de julio de 2016, 9:58, GatoLoko <[hidden email]> escribió:
...

Entonces tienes el primer caso, la versión de youtube-dl disponible en
tus repositorios está anticuada.

Por ejemplo, ejecutando "apt-cache policy youtube-dl" en Ubuntu 16.06
podemos ver que la versión disponible en los repositorios oficiales es
la "2016.02.22-1", pero en la web de youtube-dl, la versión más reciente
es la "2016.07.17".

--
Raúl Soriano

Trabajo con Ubuntu 14.04 LTS. Hice

douglas@douglas-VPCYB35AL:~$ sudo apt-cache policy youtube-dl
[sudo] password for douglas:
youtube-dl:
  Instalados: 2014.02.17-1
  Candidato:  2014.02.17-1
  Tabla de versión:
 *** 2014.02.17-1 0
        500 http://ve.archive.ubuntu.com/ubuntu/ trusty/universe i386 Packages
        100 /var/lib/dpkg/status

pero no entiendo la salida ni qué puedo hacer con ella.

Gracias.

Douglas.


--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Raro mensaje de update y falla en youtube-dl

GatoLoko .
El 19/07/16 a las 19:36, Douglas Jiménez escribió:
> Trabajo con Ubuntu 14.04 LTS. Hice
>
> douglas@douglas-VPCYB35AL:~$ sudo apt-cache policy youtube-dl
> [sudo] password for douglas:

Primero, para usar apt-cache no necesitas sudo.

> youtube-dl:

Aqui te indica de que paquete te va a dar información, porque le puedes
pedir más (apt-cache policy paquete1 paquete2).

>   Instalados: 2014.02.17-1
>   Candidato:  2014.02.17-1

La versión que está instalada, y la que esta en el servidor de paquetes,
en este caso son la misma, si hubiese una actualización serian diferentes.

>   Tabla de versión:
>  *** 2014.02.17-1 0
>         500 http://ve.archive.ubuntu.com/ubuntu/ trusty/universe i386

Un paquete puede estar disponible en más de un servidor, y puede haber
versiones diferentes en cada servidor, así que te muestra una lista de
las versiones disponibles y en que servidor están. En este caso solo hay
una versión disponible, la 2014.02.17-1, y esta en el servidor de
ubuntu. El "500" del principio es una puntuación. Cuando hay más de una
versión o más de un servidor, la puntuación mas alta indica cual se
instalará.

> Packages
>         100 /var/lib/dpkg/status

Y para terminar te dice que tienes una copia de ese paquete en tu propio
disco (la que instalaste antes).

> pero no entiendo la salida ni qué puedo hacer con ella.

Resumiendo, la versión disponible en ubuntu 14.04 está anticuada.
Youtube-dl usa fechas como versión, así que 2014.02.17 significa que es
la versión del día 17 de Febrero de 2014, tiene mas de 2 años.

En esos dos años, youtube y muchas otras páginas han hecho cambios en
sus páginas, y por eso este youtube-dl tan antiguo ya no funciona bien.
Necesitas un youtube-dl más moderno.


--
Raúl Soriano




--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es

signature.asc (220 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Raro mensaje de update y falla en youtube-dl

Javier-52

https://launchpad.net/~nilarimogard/+archive/ubuntu/webupd8


El mar, 19-07-2016 a las 23:48 +0200, GatoLoko escribió:

> El 19/07/16 a las 19:36, Douglas Jiménez escribió:
> >
> > Trabajo con Ubuntu 14.04 LTS. Hice
> >
> > douglas@douglas-VPCYB35AL:~$ sudo apt-cache policy youtube-dl
> > [sudo] password for douglas:
>
> Primero, para usar apt-cache no necesitas sudo.
>
> >
> > youtube-dl:
>
> Aqui te indica de que paquete te va a dar información, porque le
> puedes
> pedir más (apt-cache policy paquete1 paquete2).
>
> >
> >   Instalados: 2014.02.17-1
> >   Candidato:  2014.02.17-1
>
> La versión que está instalada, y la que esta en el servidor de
> paquetes,
> en este caso son la misma, si hubiese una actualización serian
> diferentes.
>
> >
> >   Tabla de versión:
> >  *** 2014.02.17-1 0
> >         500 http://ve.archive.ubuntu.com/ubuntu/ trusty/universe
> > i386
>
> Un paquete puede estar disponible en más de un servidor, y puede
> haber
> versiones diferentes en cada servidor, así que te muestra una lista
> de
> las versiones disponibles y en que servidor están. En este caso solo
> hay
> una versión disponible, la 2014.02.17-1, y esta en el servidor de
> ubuntu. El "500" del principio es una puntuación. Cuando hay más de
> una
> versión o más de un servidor, la puntuación mas alta indica cual se
> instalará.
>
> >
> > Packages
> >         100 /var/lib/dpkg/status
>
> Y para terminar te dice que tienes una copia de ese paquete en tu
> propio
> disco (la que instalaste antes).
>
> >
> > pero no entiendo la salida ni qué puedo hacer con ella.
>
> Resumiendo, la versión disponible en ubuntu 14.04 está anticuada.
> Youtube-dl usa fechas como versión, así que 2014.02.17 significa que
> es
> la versión del día 17 de Febrero de 2014, tiene mas de 2 años.
>
> En esos dos años, youtube y muchas otras páginas han hecho cambios en
> sus páginas, y por eso este youtube-dl tan antiguo ya no funciona
> bien.
> Necesitas un youtube-dl más moderno.
>
>


--
ubuntu-es mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-es
Loading...