Quantcast

Re: [Ubuntu-l10n-de-community] [Bug 1057767] Re: Some translation templates are not in sync with upstream

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Ubuntu-l10n-de-community] [Bug 1057767] Re: Some translation templates are not in sync with upstream

Hendrik Knackstedt
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hey!

I saw you've been trying to import Evolution translations to Launchpad
(LP) and import failed. This was because you didn't put the LP header
at the beginning of the po file and maybe templates didn't match.
Upstream and LP templates aren't exactly the same because not every
template change is imported into LP and sometimes LP has additional
strings.

Best way to work around this problem is to download the incomplete
translations from LP, download upstream translations from GNOME,
update the GNOME file with LPs template by using a translation tool
(e.g. Virtaal). After updating the template you have to open both
files with a text editor (make sure you saved them in Virtaal first
and closed them) and copy the LP header (important are the two lines
that look like this[1]) to the GNOME file which you updated before.

Now you can import this file into LP and translations should show up
after some time (maybe a day, can be less or more).

If you have any further questions or facing problems, you can contact
me via E-Mail or write to the list.

Regards,
Hendrik

[1] "X-Generator: Launchpad (build 16165)\n"
"X-Launchpad-Export-Date: 2012-10-18 18:28+0000\n"

Am 12.10.2012 19:20, schrieb Pierre Slamich:
> Indeed. Was too quick on that one. I was wondering how to proceed
> to import the Evolution strings. I've just uploaded a po file from
> GNOME, but I'm not sure if it's the right one:
> http://l10n.gnome.org/languages/fr/gnome-3-6/ui/ given that this
> page mentions: "po/evolution-3.0-fr.po in evolution in Ubuntu
> Quantal" and that my file is 3.6
> https://translations.launchpad.net/ubuntu/quantal/+source/evolution/+imports
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://www.enigmail.net/

iQEcBAEBAgAGBQJQgFsGAAoJED37mHoRisJ80/YH/2B6ozSXzrUbt7VJA60E+IKP
ZJeH5WoCSg4zkmLAZnKUXUPZkzyyjc/5JIVTI5vpNkbnmafDFsmMcrpElUdZ3tW/
wYtiCnFQwFdU24YF/YADk+ruKR05nIFr5BhsJHqgs61ECEp84F8hjO+dPhegEUKe
ovHpTvioj3wDPa14+Z4lpwCFGi95IAy+11riO4jq9iICbGySObbM5Ee43FVWzvIW
+VHH5rIe9vFpHJgsmbErAk23QrHeWFy8ZkvU5wegQMH8vvJ+m4Xsyc5vh7njxypC
RfG6MtgbN2Sahr/m3Ml4UoyBY50jdEAtC9qSnIobELCvaNwLhjb6IWRff3eayAM=
=gomu
-----END PGP SIGNATURE-----

--
ubuntu-translators mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-translators
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Ubuntu-l10n-de-community] [Bug 1057767] Re: Some translation templates are not in sync with upstream

David Planella-4
Al 18/10/12 21:39, En/na Hendrik Knackstedt ha escrit:

> Hey!
>
> I saw you've been trying to import Evolution translations to Launchpad
> (LP) and import failed. This was because you didn't put the LP header
> at the beginning of the po file and maybe templates didn't match.
> Upstream and LP templates aren't exactly the same because not every
> template change is imported into LP and sometimes LP has additional
> strings.
>
> Best way to work around this problem is to download the incomplete
> translations from LP, download upstream translations from GNOME,
> update the GNOME file with LPs template by using a translation tool
> (e.g. Virtaal). After updating the template you have to open both
> files with a text editor (make sure you saved them in Virtaal first
> and closed them) and copy the LP header (important are the two lines
> that look like this[1]) to the GNOME file which you updated before.
>
> Now you can import this file into LP and translations should show up
> after some time (maybe a day, can be less or more).
>
> If you have any further questions or facing problems, you can contact
> me via E-Mail or write to the list.
>
> Regards,
> Hendrik
>
> [1] "X-Generator: Launchpad (build 16165)\n"
> "X-Launchpad-Export-Date: 2012-10-18 18:28+0000\n"
>
Hi Hendrik,

Thanks for the detailed explanation. While this and slight variations
(using msgmerge instead of Virtaal) are a valid approaches, a much
simpler workflow is the following:

1. Get the upstream PO file from the upstream project
2. Get the downstream PO file from Launchpad
3. Copy the X-Generator and X-Launchpad-Export-Date fields from the
   downstream PO file to the upstream PO file
4. Upload the resulting file from the previous step to Launchpad

And that's it, Launchpad will take care of all the merging.

Cheers,
David.

> Am 12.10.2012 19:20, schrieb Pierre Slamich:
>> Indeed. Was too quick on that one. I was wondering how to proceed
>> to import the Evolution strings. I've just uploaded a po file from
>> GNOME, but I'm not sure if it's the right one:
>> http://l10n.gnome.org/languages/fr/gnome-3-6/ui/ given that this
>> page mentions: "po/evolution-3.0-fr.po in evolution in Ubuntu
>> Quantal" and that my file is 3.6
>> https://translations.launchpad.net/ubuntu/quantal/+source/evolution/+imports
>
>
--
David Planella
Ubuntu Translations Coordinator
www.ubuntu.com / www.davidplanella.wordpress.com
www.identi.ca/dplanella / www.twitter.com/dplanella

--
David Planella
Ubuntu Translations Coordinator
www.ubuntu.com / www.davidplanella.wordpress.com
www.identi.ca/dplanella / www.twitter.com/dplanella


--
ubuntu-translators mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-translators

signature.asc (563 bytes) Download Attachment
Loading...