Quantcast

Segundo monitor não é mais detectado quando removido

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Segundo monitor não é mais detectado quando removido

Andre Cavalcante-2
Olá novamente,

Este é um problema que já postei aqui antes e não encontrei solução.
Posto novamente na esperança que alguém possa me ajudar (da outra vez tive
apenas 1 retorno e o que foi sugerido não chegou nem perto do problema real
:( ).

Primeiro, minha máquina: Dell Latiture 3440

$ lspci | grep VGA
>> 00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT
Integrated Graphics Controller (rev 0b)

$ lspci | grep NVIDIA
>> 08:00.0 3D controller: NVIDIA Corporation GK208M [GeForce GT 740M] (rev
a1)

Ou seja, tenho duas placas de vídeos, uma Intel e uma NVidia

$ lsmod | grep nvidia
>>
nvidia_uvm            647168  0
nvidia_drm             53248  3
nvidia_modeset        790528  3 nvidia_drm
nvidia              12144640  54 nvidia_modeset,nvidia_uvm
drm_kms_helper        155648  2 i915,nvidia_drm
drm                   364544  6 i915,drm_kms_helper,nvidia_drm

Versão do sistema:
$ uname -a
Linux andre-3440 4.4.0-72-generic #93-Ubuntu SMP Fri Mar 31 14:07:41 UTC
2017 x86_64 x86_64 x86_64 GNU/Linux

$ lsb_release -i -c -r
Distributor ID:    Ubuntu
Release:    16.04
Codename:    xenial

O Problema:

Coloco um monitor externo (ou projetor).

Monitor detectado, tudo bem. Posso ajustar a resolução e várias outras
coisas em Configurações do Sistema / Monitores.

Quando eu retiro o segundo monitor (ou projetor), a tela dá uma piscada.
Até aí tudo bem.
Só qua aí vem a dificuldade: quando tento inserir um segundo monitor (o
mesmo ou outro) novamente, nada acontece.
Ele não é mais detectado.

Posso tirar e por o cabo quantas vezes quiser e nada.

O erro acontece quando uso Fn+F1 que é a tecla para chavear os modos de
vídeo (somente o laptop, estendido (laptop e monitor lado a lado), ambos
(espelhado), ou somente monitor externo)


Já tentei:
$sudo service dbus restart  (e.g. o Linux congela quando tento isso!)
$sudo service udev restart  (tentar forçar o udev tentar detectar o monitor)
$sudo service lightdm restart  (tentar forçar um reinício do X pra tentar
re-detectar o monitor)

Nada funfa.

Só resolve quando faço

$ reboot   (obviamente pode ser feito pela interface gráfica)

E tome 3 a 4 minutos para reiniciar (esse é outro problema que falo dele
depois)

Pensei em reiniciar o driver de video, mas o que encontro é somente remover
o driver nvidia e depois restartar

$ sudo rmmod -f nvidia*
$ sudo nvidia-smi

Para começo de conversa dá erro e não consegue remover.
O segundo comando diz que não acha nvidia-smi

Peguei estes comandos lendo fóruns por aí.

E aí, alguma luz?

Abraços

--
André Cavalcante
Manaus, AM.

--
Mais sobre o Ubuntu em português: http://www.ubuntu-br.org/comece

Lista de discussão Ubuntu Brasil
Histórico, descadastramento e outras opções:
https://lists.ubuntu.com/mailman/listinfo/ubuntu-br
Loading...