Synaptic currupted

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Synaptic currupted

Ashwani Jain
Hi

I am using ubuntu 5.10 breezy badger.  Today my synaptic developted some problem while I was upgrading Webmin.  Now whenever I try to install or uninstall Webmin or its modules or any other application it returns error at the end:

E: webmin-apache: subprocess post-installation script returned error exit status 2
E: webmin-inetd: subprocess post-installation script returned error exit status 2
E: webmin-krb5: subprocess post-installation script returned error exit status 2
E: webmin-firewall: subprocess post-installation script returned error exit status 2
E: webmin-core: subprocess post-installation script returned error exit status 2
E: webmin-mailboxes: dependency problems - leaving unconfigured
E: webmin-updown: dependency problems - leaving unconfigured

I also tried after restarting the OS for several times but problem is still there, is there any remedy or I have to format the system to get rid of this problem, please help if you know the solution.

Thanks

Ashwani Jain
--
ubuntu-users mailing list
[hidden email]
http://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Synaptic currupted

Peter Garrett
On Fri, 04 Nov 2005 15:34:38 +0530
Ashwani Jain <[hidden email]> wrote:

> Hi
>
> I am using ubuntu 5.10 breezy badger.  Today my synaptic developted some
> problem while I was upgrading Webmin.  Now whenever I try to install or
> uninstall Webmin or its modules or any other application it returns
> error at the end:
>
> E: webmin-apache: subprocess post-installation script returned error
> exit status 2

 <snipped>

>
> I also tried after restarting the OS for several times but problem is
> still there, is there any remedy or I have to format the system to get
> rid of this problem, please help if you know the solution.
>
> Thanks
>
> Ashwani Jain

It's hard to know "the solution" with so little information.
This kind of error often suggests a bad set of sources (repository list).

Please post the contents of your   /etc/apt/sources.list     file.

My guess is that you have 3rd party/ inappropriate repositories in your list, or some other error in the file I've asked you to post.

Peter


--

Linux User #343161

--
ubuntu-users mailing list
[hidden email]
http://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: Synaptic currupted

Lee Braiden-2
In reply to this post by Ashwani Jain
On Friday 04 November 2005 10:04, Ashwani Jain wrote:
> E: webmin-apache: subprocess post-installation script returned error
> exit status 2

This isn't really an official method, but the official method is broken since
you're getting this, so you could run

/var/lib/dpkg/info/webmin-apache.postinst

as root from a shell, and see what it says.  If it's something simple, fix
that file.  Otherwise, you could force dpkg (and thereby apt and synaptic
too) to bypass the script by putting

exit 0

on the second line of it.  Then, do whatever you were doing in synaptic again.

You're getting this error for a lot of webmin-related stuff, so it looks like
all of the webmin-*.postinst scripts are including another file, which will
turn out to be the actual cause.  Look out for that.

--
Lee Braiden
http://www.DigitalUnleashed.com

--
ubuntu-users mailing list
[hidden email]
http://lists.ubuntu.com/mailman/listinfo/ubuntu-users