[USN-3231-1] Pidgin vulnerability

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[USN-3231-1] Pidgin vulnerability

Marc Deslauriers-3
==========================================================================
Ubuntu Security Notice USN-3231-1
March 14, 2017

pidgin vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 14.04 LTS
- Ubuntu 12.04 LTS

Summary:

Pidgin could be made to crash or run programs if it received specially
crafted network traffic.

Software Description:
- pidgin: graphical multi-protocol instant messaging client for X

Details:

Joseph Bisch discovered that Pidgin incorrectly handled certain xml
messages. A remote attacker could use this issue to cause Pidgin to crash,
resulting in a denial of service, or possibly execute arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 14.04 LTS:
  libpurple0                      1:2.10.9-0ubuntu3.4

Ubuntu 12.04 LTS:
  libpurple0                      1:2.10.3-0ubuntu1.8

After a standard system update you need to restart Pidgin to make all the
necessary changes.

References:
  http://www.ubuntu.com/usn/usn-3231-1
  CVE-2017-2640

Package Information:
  https://launchpad.net/ubuntu/+source/pidgin/1:2.10.9-0ubuntu3.4
  https://launchpad.net/ubuntu/+source/pidgin/1:2.10.3-0ubuntu1.8



--
ubuntu-security-announce mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-security-announce

signature.asc (836 bytes) Download Attachment
Loading...