[USN-3518-1] AWStats vulnerability

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[USN-3518-1] AWStats vulnerability

Marc Deslauriers-3
==========================================================================
Ubuntu Security Notice USN-3518-1
January 08, 2018

awstats vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 17.10
- Ubuntu 17.04
- Ubuntu 16.04 LTS
- Ubuntu 14.04 LTS

Summary:

AWStats could be made to run programs if it received specially crafted
network traffic.

Software Description:
- awstats: powerful and featureful web server log analyzer

Details:

It was discovered that AWStats incorrectly filtered certain parameters. A
remote attacker could possibly use this issue to execute arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 17.10:
  awstats                         7.6+dfsg-1ubuntu0.17.10.1

Ubuntu 17.04:
  awstats                         7.6+dfsg-1ubuntu0.17.04.1

Ubuntu 16.04 LTS:
  awstats                         7.4+dfsg-1ubuntu0.2

Ubuntu 14.04 LTS:
  awstats                         7.2+dfsg-1ubuntu0.1

In general, a standard system update will make all the necessary changes.

References:
  https://www.ubuntu.com/usn/usn-3518-1
  CVE-2017-1000501

Package Information:
  https://launchpad.net/ubuntu/+source/awstats/7.6+dfsg-1ubuntu0.17.10.1
  https://launchpad.net/ubuntu/+source/awstats/7.6+dfsg-1ubuntu0.17.04.1
  https://launchpad.net/ubuntu/+source/awstats/7.4+dfsg-1ubuntu0.2
  https://launchpad.net/ubuntu/+source/awstats/7.2+dfsg-1ubuntu0.1



--
ubuntu-security-announce mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-security-announce

signature.asc (817 bytes) Download Attachment