[USN-3853-1] GnuPG vulnerability

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[USN-3853-1] GnuPG vulnerability

Marc Deslauriers-3
==========================================================================
Ubuntu Security Notice USN-3853-1
January 10, 2019

gnupg2 vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 18.10
- Ubuntu 18.04 LTS

Summary:

GnuPG could allow unintended access to network services.

Software Description:
- gnupg2: GNU privacy guard - a free PGP replacement

Details:

Ben Fuhrmannek discovered that GnuPG incorrectly handled Web Key Directory
lookups. A remote attacker could possibly use this issue to cause a denial
of service, or perform Cross-Site Request Forgery attacks.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 18.10:
  gnupg                           2.2.8-3ubuntu1.1
  gpg-wks-client                  2.2.8-3ubuntu1.1

Ubuntu 18.04 LTS:
  gnupg                           2.2.4-1ubuntu1.2
  gpg-wks-client                  2.2.4-1ubuntu1.2

In general, a standard system update will make all the necessary changes.

References:
  https://usn.ubuntu.com/usn/usn-3853-1
  CVE-2018-1000858

Package Information:
  https://launchpad.net/ubuntu/+source/gnupg2/2.2.8-3ubuntu1.1
  https://launchpad.net/ubuntu/+source/gnupg2/2.2.4-1ubuntu1.2


--
ubuntu-security-announce mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-security-announce

signature.asc (849 bytes) Download Attachment