[USN-3990-2] urllib3 vulnerability

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[USN-3990-2] urllib3 vulnerability

Leonidas S. Barbosa
==========================================================================
Ubuntu Security Notice USN-3990-2
July 29, 2019

python-urllib3 vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 14.04 ESM

Summary:

urllib3 could be used to perform a CRLF injection if it received a specially
crafted request.

Software Description:
- python-urllib3: HTTP library with thread-safe connection pooling for Python

Details:

USN-3990-1 fixed a vulnerability in urllib3. This update provides
the corresponding update for Ubuntu 14.04 ESM.

Original advisory details:

 It was discovered that urllib3 incorrectly stripped certain characters from
 requests. A remote attacker could use this issue to perform CRLF injection.
 (CVE-2019-11236)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 14.04 ESM:
  python-urllib3                  1.7.1-1ubuntu4.1+esm1
  python3-urllib3                 1.7.1-1ubuntu4.1+esm1

In general, a standard system update will make all the necessary changes.

References:
  https://usn.ubuntu.com/3990-2
  https://usn.ubuntu.com/3990-1
  CVE-2019-11236

--
ubuntu-security-announce mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-security-announce

signature.asc (836 bytes) Download Attachment