[USN-4138-1] LibreOffice vulnerability

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[USN-4138-1] LibreOffice vulnerability

Marc Deslauriers-3
==========================================================================
Ubuntu Security Notice USN-4138-1
September 24, 2019

libreoffice vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 19.04
- Ubuntu 18.04 LTS
- Ubuntu 16.04 LTS

Summary:

LibreOffice could be made to run programs as your login if it opened a
specially crafted file.

Software Description:
- libreoffice: Office productivity suite

Details:

It was discovered that LibreOffice incorrectly handled embedded scripts in
document files. If a user were tricked into opening a specially crafted
document, a remote attacker could possibly execute arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 19.04:
  libreoffice-core                1:6.2.7-0ubuntu0.19.04.1

Ubuntu 18.04 LTS:
  libreoffice-core                1:6.0.7-0ubuntu0.18.04.10

Ubuntu 16.04 LTS:
  libreoffice-core                1:5.1.6~rc2-0ubuntu1~xenial10

After a standard system update you need to restart LibreOffice to make all
the necessary changes.

References:
  https://usn.ubuntu.com/4138-1
  CVE-2019-9854

Package Information:
  https://launchpad.net/ubuntu/+source/libreoffice/1:6.2.7-0ubuntu0.19.04.1
  https://launchpad.net/ubuntu/+source/libreoffice/1:6.0.7-0ubuntu0.18.04.10
  https://launchpad.net/ubuntu/+source/libreoffice/1:5.1.6~rc2-0ubuntu1~xenial10


--
ubuntu-security-announce mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-security-announce

signature.asc (849 bytes) Download Attachment