[USN-4148-1] OpenEXR vulnerabilities

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[USN-4148-1] OpenEXR vulnerabilities

Marc Deslauriers-3
==========================================================================
Ubuntu Security Notice USN-4148-1
October 07, 2019

openexr vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 19.04
- Ubuntu 18.04 LTS
- Ubuntu 16.04 LTS

Summary:

Several security issues were fixed in OpenEXR.

Software Description:
- openexr: command-line tools for the OpenEXR image format

Details:

It was discovered that OpenEXR incorrectly handled certain malformed EXR
image files. If a user were tricked into opening a crafted EXR image file,
a remote attacker could cause a denial of service, or possibly execute
arbitrary code. This issue only affected Ubuntu 16.04 LTS. (CVE-2017-12596)

Brandon Perry discovered that OpenEXR incorrectly handled certain malformed
EXR image files. If a user were tricked into opening a crafted EXR image
file, a remote attacker could cause a denial of service, or possibly
execute arbitrary code. This issue only affected Ubuntu 16.04 LTS.
(CVE-2017-9110, CVE-2017-9112, CVE-2017-9116)

Brandon Perry discovered that OpenEXR incorrectly handled certain malformed
EXR image files. If a user were tricked into opening a crafted EXR image
file, a remote attacker could cause a denial of service, or possibly
execute arbitrary code. (CVE-2017-9111, CVE-2017-9113, CVE-2017-9115)

Tan Jie discovered that OpenEXR incorrectly handled certain malformed EXR
image files. If a user were tricked into opening a crafted EXR image file,
a remote attacker could cause a denial of service, or possibly execute
arbitrary code. (CVE-2018-18444)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 19.04:
  libopenexr23                    2.2.1-4.1ubuntu0.1
  openexr                         2.2.1-4.1ubuntu0.1

Ubuntu 18.04 LTS:
  libopenexr22                    2.2.0-11.1ubuntu1.1
  openexr                         2.2.0-11.1ubuntu1.1

Ubuntu 16.04 LTS:
  libopenexr22                    2.2.0-10ubuntu2.1
  openexr                         2.2.0-10ubuntu2.1

In general, a standard system update will make all the necessary changes.

References:
  https://usn.ubuntu.com/4148-1
  CVE-2017-12596, CVE-2017-9110, CVE-2017-9111, CVE-2017-9112,
  CVE-2017-9113, CVE-2017-9115, CVE-2017-9116, CVE-2018-18444

Package Information:
  https://launchpad.net/ubuntu/+source/openexr/2.2.1-4.1ubuntu0.1
  https://launchpad.net/ubuntu/+source/openexr/2.2.0-11.1ubuntu1.1
  https://launchpad.net/ubuntu/+source/openexr/2.2.0-10ubuntu2.1


--
ubuntu-security-announce mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-security-announce

signature.asc (849 bytes) Download Attachment