[USN-4614-1] GDM vulnerability

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[USN-4614-1] GDM vulnerability

Marc Deslauriers-3
==========================================================================
Ubuntu Security Notice USN-4614-1
November 03, 2020

gdm3 vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 20.10
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS

Summary:

GDM could be made to create privileged users.

Software Description:
- gdm3: GNOME Display Manager

Details:

Kevin Backhouse discovered that GDM incorrectly launched the initial setup
tool when the accountsservice daemon was not reachable. A local attacker
able to cause accountsservice to crash or stop responding could trick GDM
into launching the initial setup tool and create a privileged user.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 20.10:
  gdm3                            3.38.1-2ubuntu1.1

Ubuntu 20.04 LTS:
  gdm3                            3.36.3-0ubuntu0.20.04.2

Ubuntu 18.04 LTS:
  gdm3                            3.28.3-0ubuntu18.04.6

After a standard system update you need to reboot your computer to make
all the necessary changes.

References:
  https://usn.ubuntu.com/4614-1
  CVE-2020-16125

Package Information:
  https://launchpad.net/ubuntu/+source/gdm3/3.38.1-2ubuntu1.1
  https://launchpad.net/ubuntu/+source/gdm3/3.36.3-0ubuntu0.20.04.2
  https://launchpad.net/ubuntu/+source/gdm3/3.28.3-0ubuntu18.04.6


--
ubuntu-security-announce mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-security-announce

signature.asc (849 bytes) Download Attachment