Ubuntu 12.04 on VPS. Postfix Certficate

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Ubuntu 12.04 on VPS. Postfix Certficate

Panagiotis Theodoropoulos
Σε VPS (A2 Hosting) με λειτουργικό Ubuntu 12.04 έχω εγκαταστήσει τον
Postfix.

Για configuration Postfix for SMTP-AUTH χρησιμοποίησα το πακέτο
mail-stack-delivery package (previously packaged as dovecot-postfix)

sudo apt-get install mail-stack-delivery

Τα ερωτήματά μου είναι:

Αν χρησιμοποιήσω Self-Signed Certificate θα έχω πρόβλημα;
ή Χρειάζεται Certificate Signing Request (CSR)

Αν δεν χρησιμοποιήσω SMTP-AUTH ποια προβλήματα θα αντιμετωπίσω;



--
Παναγιώτης Θεοδωρόπουλος
Panagiotis Theodoropoulos
<[hidden email]>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-gr/attachments/20131216/3f31af8a/attachment.html>
--
Ubuntu-gr mailing list
[hidden email]

If you do not want to receive any more messages from the ubuntu-gr mailing list, please follow this link and choose unsubscribe:
https://lists.ubuntu.com/mailman/listinfo/ubuntu-gr
Reply | Threaded
Open this post in threaded view
|

Re: Ubuntu 12.04 on VPS. Postfix Certficate

Pantelis  Koukousoulas
On Mon, Dec 16, 2013 at 12:55 PM, Panagiotis Theodoropoulos <
[hidden email]> wrote:

> Αν χρησιμοποιήσω Self-Signed Certificate θα έχω πρόβλημα;

ή Χρειάζεται Certificate Signing Request (CSR)
>

Μέχρι και ο thunderbird 2 νομίζω  δε γκρινιάζει για τα self-signed
certificates.
Από εκεί και πέρα δεν έχω δοκιμάσει ο ίδιος αλλά βλέπω κάποια bugs που
με βάζουν σε υποψίες, π.χ.:

https://bugzilla.mozilla.org/show_bug.cgi?id=429843 (μπορεί να λέει
RESOLVED FIXED
αλλά από τα σχόλια φαίνεται ότι κάποιοι έχουν ακόμα αυτό το πρόβλημα)
και
https://bugzilla.mozilla.org/show_bug.cgi?id=439845

(Χωρίς να υπολογίσουμε το γεγονός ότι ακόμα και αν δε γκρινιάξει ο mail
client
υπάρχει το πραγματικό θέμα ότι με self-signed certificate οι χρήστες είναι
ανοιχτοί
σε man in the middle attacks π.χ., μέσω δημόσιου wifi ή σε internet cafes).


> Αν δεν χρησιμοποιήσω SMTP-AUTH ποια προβλήματα θα αντιμετωπίσω;
>

Αν δε χρησιμοποιείς καν SMTP-AUTH τότε θα είσαι open relay
και άρα πολύ γρήγορα:

   * Θα στέλνουν μέσω του server σου ένα κάρο spam διάφορα bots
   * Θα μπεις σε όλες τις blacklists με αποτέλεσμα να μην μπορείς
      να στείλεις email πουθενά
   * Μπορεί να έχεις και θέματα με τον ISP σου

Χαιρετισμούς,
Παντελής
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-gr/attachments/20131216/1f21701f/attachment.html>
--
Ubuntu-gr mailing list
[hidden email]

If you do not want to receive any more messages from the ubuntu-gr mailing list, please follow this link and choose unsubscribe:
https://lists.ubuntu.com/mailman/listinfo/ubuntu-gr
Reply | Threaded
Open this post in threaded view
|

shotwell πρόβλημα

Νίκος Αλμπανόπουλος-2
Εδώ και 2-3 βδομάδες, κάθε φορά που ο υπολογιστής έκανε αναβαθμίσεις
πακέτων, έπαιρνα ένα μήνυμα ότι το πακέτο shotwell 0.15.0 ubuntu κλπ.
δεν μπορούσε να αναβαθμιστεί στο διαθέσιμο 0.15.1 saucy.

Αποφάσισα να απεγκαταστήσω το shotwell και να το εγκαταστήσω εκ νέου.
Στο software center διαπίστωσα ότι υπάρχουν 3 shotwell και τα τρίτα
εγκατεστημένα. Το πρώτο στην πραγματικότητα λέγεται Digital photo
manager, το δεύτερο Shotwell photo manager και το τρίτο shotwell photo
viewer. Τα απεγκατέστησα όλα, και κατόπιν εγκατέστησα πρώτα το πρώτο
(Dig Ph Man) ενώ τα δύο άλλα δεν εγκαθίστανται και μου δίνουν το εξής
λάθος:

installArchives() failed: (Reading database ... (Reading database ... 5%
κλπ. κλπ. ως (Reading database ... 234951 files and directories
currently installed.)
Unpacking shotwell-common (from
.../shotwell-common_0.15.0-0ubuntu1_all.deb) ...
dpkg: error processing
/var/cache/apt/archives/shotwell-common_0.15.0-0ubuntu1_all.deb (--unpack):
  trying to overwrite '/usr/share/GConf/gsettings/shotwell.convert',
which is also in package shotwell 0.15.1-1~saucy1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Processing triggers for gconf2 ...
Errors were encountered while processing:
  /var/cache/apt/archives/shotwell-common_0.15.0-0ubuntu1_all.deb
Error in function:

Δεν γράφει κάτι άλλο μετά από αυτό.

Το ίδιο και αν πάω να εγκαταστήσω το τρίτο πακέτο, το shot ph viewer.

Ως αποτέλεσμα:
Το shotwell είναι κανονικά εγκατεστημένο (το 0.15.1) και λειτουργεί σωστά.

Όταν πηγαίνω στο dash βλέπω τρία πανομοιότυπα εικονίδια που όλα γράφουν
Shotwell Photo Manager και μόνο το ένα ανοίγει το Shotwell, τα άλλα δύο
δεν κάνουν τίποτα με το κλικ.

Τι έχει συμβεί;

Ν.


--
Ubuntu-gr mailing list
[hidden email]

If you do not want to receive any more messages from the ubuntu-gr mailing list, please follow this link and choose unsubscribe:
https://lists.ubuntu.com/mailman/listinfo/ubuntu-gr
Reply | Threaded
Open this post in threaded view
|

Re: shotwell πρόβλημα

Pantelis  Koukousoulas
sudo apt-get remove --purge shotwell-common
και ξαναδοκίμασε μετά την εγκατάσταση.


2013/12/20 Νίκος Αλμπανόπουλος <[hidden email]>

> Εδώ και 2-3 βδομάδες, κάθε φορά που ο υπολογιστής έκανε αναβαθμίσεις
> πακέτων, έπαιρνα ένα μήνυμα ότι το πακέτο shotwell 0.15.0 ubuntu κλπ. δεν
> μπορούσε να αναβαθμιστεί στο διαθέσιμο 0.15.1 saucy.
>
> Αποφάσισα να απεγκαταστήσω το shotwell και να το εγκαταστήσω εκ νέου. Στο
> software center διαπίστωσα ότι υπάρχουν 3 shotwell και τα τρίτα
> εγκατεστημένα. Το πρώτο στην πραγματικότητα λέγεται Digital photo manager,
> το δεύτερο Shotwell photo manager και το τρίτο shotwell photo viewer. Τα
> απεγκατέστησα όλα, και κατόπιν εγκατέστησα πρώτα το πρώτο (Dig Ph Man) ενώ
> τα δύο άλλα δεν εγκαθίστανται και μου δίνουν το εξής λάθος:
>
> installArchives() failed: (Reading database ... (Reading database ... 5%
> κλπ. κλπ. ως (Reading database ... 234951 files and directories currently
> installed.)
> Unpacking shotwell-common (from .../shotwell-common_0.15.0-0ubuntu1_all.deb)
> ...
> dpkg: error processing /var/cache/apt/archives/shotwell-common_0.15.0-0ubuntu1_all.deb
> (--unpack):
>  trying to overwrite '/usr/share/GConf/gsettings/shotwell.convert', which
> is also in package shotwell 0.15.1-1~saucy1
> dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
> Processing triggers for gconf2 ...
> Errors were encountered while processing:
>  /var/cache/apt/archives/shotwell-common_0.15.0-0ubuntu1_all.deb
> Error in function:
>
> Δεν γράφει κάτι άλλο μετά από αυτό.
>
> Το ίδιο και αν πάω να εγκαταστήσω το τρίτο πακέτο, το shot ph viewer.
>
> Ως αποτέλεσμα:
> Το shotwell είναι κανονικά εγκατεστημένο (το 0.15.1) και λειτουργεί σωστά.
>
> Όταν πηγαίνω στο dash βλέπω τρία πανομοιότυπα εικονίδια που όλα γράφουν
> Shotwell Photo Manager και μόνο το ένα ανοίγει το Shotwell, τα άλλα δύο δεν
> κάνουν τίποτα με το κλικ.
>
> Τι έχει συμβεί;
>
> Ν.
>
>
> --
> Ubuntu-gr mailing list
> [hidden email]
>
> If you do not want to receive any more messages from the ubuntu-gr mailing
> list, please follow this link and choose unsubscribe:
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-gr
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-gr/attachments/20131220/70e8aea3/attachment.html>
--
Ubuntu-gr mailing list
[hidden email]

If you do not want to receive any more messages from the ubuntu-gr mailing list, please follow this link and choose unsubscribe:
https://lists.ubuntu.com/mailman/listinfo/ubuntu-gr
Reply | Threaded
Open this post in threaded view
|

Re: shotwell πρόβλημα

Νίκος Αλμπανόπουλος-2
Package 'shotwell-common' is not installed, so not removed

On 20/12/2013 11:51 πμ, Pantelis Koukousoulas wrote:
> sudo apt-get remove --purge shotwell-common


--
Ubuntu-gr mailing list
[hidden email]

If you do not want to receive any more messages from the ubuntu-gr mailing list, please follow this link and choose unsubscribe:
https://lists.ubuntu.com/mailman/listinfo/ubuntu-gr
Reply | Threaded
Open this post in threaded view
|

Re: shotwell πρόβλημα

Pantelis  Koukousoulas
μάλλον αντί για shotwell-common είναι σκέτο shotwell :)

Αυτό που λέει το log που έκανες post είναι ότι σκάει όταν
προσπαθεί να κάνει unpack το shotwell-common γιατί
υπάρχει conflict στο αρχείο
/usr/share/GConf/gsettings/shotwell.convert
με το ήδη εγκατεστημένο πακέτο "shotwell" :)

Οπότε λογικά πρέπει να απεγκαταστήσεις και το "shotwell".
με --purge πριν ξαναρχίσεις την εγκατάσταση :)

Χαιρετισμούς,
Παντελής


On Fri, Dec 20, 2013 at 5:52 PM, Νίκος Αλμπανόπουλος <
[hidden email]> wrote:

> Package 'shotwell-common' is not installed, so not removed
>
>
> On 20/12/2013 11:51 πμ, Pantelis Koukousoulas wrote:
>
>> sudo apt-get remove --purge shotwell-common
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-gr/attachments/20131220/1cbb4be2/attachment.html>
--
Ubuntu-gr mailing list
[hidden email]

If you do not want to receive any more messages from the ubuntu-gr mailing list, please follow this link and choose unsubscribe:
https://lists.ubuntu.com/mailman/listinfo/ubuntu-gr