Version des paquets

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Version des paquets

Thomas De Contes
Bonjour :-)


je suis sous Ubuntu 16.04.6 LTS
(à distance, donc je n'ai accès qu'au terminal)

quand je vais sur place je pense généralement à faire les mise à jour de l'ordinateur, vite fait

mon problème n'est pas d'avoir la toute dernière version, mais un problème de synchronisation


$ apt search GtkAda
libgtkada2.24.4-dev/xenial,now 2.24.4dfsg-1 amd64  [installé]
  Ada binding for the GTK+ GUI (development files)

$ apt show libgtkada2.24.4-dev
Package: libgtkada2.24.4-dev
Version: 2.24.4dfsg-1
Priority: optional
Section: universe/libdevel
Source: libgtkada
Origin: Ubuntu
Maintainer: Ubuntu Developers <[hidden email]>
Original-Maintainer: Ludovic Brenta <[hidden email]>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 20,7 MB
Depends: gnat, gnat-4.9, libgtkada2.24.4 (= 2.24.4dfsg-1), libgtkada-bin (= 2.24.4dfsg-1), libcairo2-dev | libcairo-dev, libgdk-pixbuf2.0-dev, libglib2.0-dev, libgtk2.0-dev (>= 2.24.0), libpango1.0-dev, libx11-dev
Suggests: libgnomeada2.24.4-dev (= 2.24.4dfsg-1), libgtkglada2.24.4-dev (= 2.24.4dfsg-1), libgtkada-doc
Homepage: http://libre.adacore.com/libre/tools/gtkada
Download-Size: 2 260 kB
APT-Manual-Installed: yes
APT-Sources: http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
Description: Ada binding for the GTK+ GUI (development files)
 GtkAda is a library that allows programmers to write GTK+ applications in the
 Ada programming language.
 .
 This package contains the development files and static libraries.


mais ... quand je vais dans
/usr/share/ada/adainclude/gtkada
- les fichiers sont tous datés du 10 novembre 2014
- les fichiers qui le veulent bien contiennent la ligne
--  <c_version>2.16.6</c_version>
(sinon pas de Version indiquée)


est ce que quelqu'un peut m'expliquer svp ?


--
Téléassistance / Télémaintenance
http://invites.biocer.fr/thomas-de-contes/


--
Liste de diffusion ubuntu-fr [hidden email]
Pour s'abonner ou se désabonner : https://lists.ubuntu.com/mailman/listinfo/ubuntu-fr
Charte de la liste: http://doc.ubuntu-fr.org/groupes/ubuntu-fr-ml/charte
Reply | Threaded
Open this post in threaded view
|

Re: Version des paquets

Donk (ubuntu-fr)
Le 14/01/2020 à 23:45, Thomas De Contes a écrit :

> Bonjour :-)
>
>
> je suis sous Ubuntu 16.04.6 LTS
> (à distance, donc je n'ai accès qu'au terminal)
>
> quand je vais sur place je pense généralement à faire les mise à jour de l'ordinateur, vite fait
>
> mon problème n'est pas d'avoir la toute dernière version, mais un problème de synchronisation
>
>
> $ apt search GtkAda
> libgtkada2.24.4-dev/xenial,now 2.24.4dfsg-1 amd64  [installé]
>   Ada binding for the GTK+ GUI (development files)
>
> $ apt show libgtkada2.24.4-dev
> Package: libgtkada2.24.4-dev
> Version: 2.24.4dfsg-1
> Priority: optional
> Section: universe/libdevel
> Source: libgtkada
> Origin: Ubuntu
> Maintainer: Ubuntu Developers <[hidden email]>
> Original-Maintainer: Ludovic Brenta <[hidden email]>
> Bugs: https://bugs.launchpad.net/ubuntu/+filebug
> Installed-Size: 20,7 MB
> Depends: gnat, gnat-4.9, libgtkada2.24.4 (= 2.24.4dfsg-1), libgtkada-bin (= 2.24.4dfsg-1), libcairo2-dev | libcairo-dev, libgdk-pixbuf2.0-dev, libglib2.0-dev, libgtk2.0-dev (>= 2.24.0), libpango1.0-dev, libx11-dev
> Suggests: libgnomeada2.24.4-dev (= 2.24.4dfsg-1), libgtkglada2.24.4-dev (= 2.24.4dfsg-1), libgtkada-doc
> Homepage: http://libre.adacore.com/libre/tools/gtkada
> Download-Size: 2 260 kB
> APT-Manual-Installed: yes
> APT-Sources: http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
> Description: Ada binding for the GTK+ GUI (development files)
>  GtkAda is a library that allows programmers to write GTK+ applications in the
>  Ada programming language.
>  .
>  This package contains the development files and static libraries.
>
>
> mais ... quand je vais dans
> /usr/share/ada/adainclude/gtkada
> - les fichiers sont tous datés du 10 novembre 2014
> - les fichiers qui le veulent bien contiennent la ligne
> --  <c_version>2.16.6</c_version>
> (sinon pas de Version indiquée)
>
>
> est ce que quelqu'un peut m'expliquer svp ?
>
>
Salut,

D’après le site packages.ubuntu.com, la dernière révision du paquet
libgtkada2.24.4-dev est la 2.24.4dfsg-1 et date du 09 novembre 2014.
Et la ligne <c_version>2.16.6</c_version> apparaît aussi dans certains fichiers
source.
Personnellement, je ne vois pas de problème.

@+

--
Donk


--
Liste de diffusion ubuntu-fr [hidden email]
Pour s'abonner ou se désabonner : https://lists.ubuntu.com/mailman/listinfo/ubuntu-fr
Charte de la liste: http://doc.ubuntu-fr.org/groupes/ubuntu-fr-ml/charte

signature.asc (903 bytes) Download Attachment