WinModem auf IBM Thinkpad T23

classic Classic list List threaded Threaded
17 messages Options
Reply | Threaded
Open this post in threaded view
|

WinModem auf IBM Thinkpad T23

Big Maze
Hallo Leute,

ich habe hier ein IBM Thinkpad T23 und das Versprechen, auf diesem
Notebook Win durch Ubuntu zuersetzen. Das ist fast alles gelungen und
wir werden wohl eine weitere Ubuntu-Verliebte hinzu gewinnen. Aber ...

In dem Schl�ppi steckt ein WinModem! Und das bekomme ich nicht zum
laufen. Ich habe es mit
http://ubuntuforums.org/archive/index.php/t-84805.html versucht, jedoch:
1. okay
2. okay
3. make bricht mit Fehler 2 ab.
#: Keine Regel um "Modules" zu erstellen. Schluss.

Was mache ich falsch? Stimmt etwas mit dem Makefile nicht? Hat jemand
auf diesem Notebook das Winmodem laufen? Kennt jemand eine Seite, mit
der es gklappt hat?

Grusz Mathias



--
ubuntu-de mailing list
[hidden email]
http://lists.ubuntu.com/mailman/listinfo/ubuntu-de
Reply | Threaded
Open this post in threaded view
|

Re: WinModem auf IBM Thinkpad T23

Keywan Najafi Tonekaboni
Hallo,

Am Montag, den 14.11.2005, 13:25 +0100 schrieb Big Maze:
> ich habe hier ein IBM Thinkpad T23 und das Versprechen, auf diesem
> Notebook Win durch Ubuntu zuersetzen. Das ist fast alles gelungen und
> wir werden wohl eine weitere Ubuntu-Verliebte hinzu gewinnen. Aber ...

ein allgemeiner Tip zu Thinkpads:

http://www.thinkwiki.org

Gruesse,

Keywan

--
Keywan Najafi Tonekaboni
http://www.prometoys.net
PGP Fingerprint: D5A1 A22E 3758 C9B4 57D2  3CAF EE52 1A78 C6A0 6934

people@world:/# apt-get --purge remove dominion
After unpacking world will be freed.
You are about to do something potentially beneficial
To continue type in the phrase 'Yes, do as We say!'




--
ubuntu-de mailing list
[hidden email]
http://lists.ubuntu.com/mailman/listinfo/ubuntu-de
Reply | Threaded
Open this post in threaded view
|

Re: WinModem auf IBM Thinkpad T23

Friedrich Strohmaier
In reply to this post by Big Maze
Hallo Big Maze, *,

Big Maze schrieb am Montag, 14. November 2005 13:25:

>Hallo Leute,
[.. viel Mühe um Winmodem ..]
>Was mache ich falsch? Stimmt etwas mit dem Makefile nicht? Hat
> jemand auf diesem Notebook das Winmodem laufen? Kennt jemand eine
> Seite, mit der es gklappt hat?

Wenn ich Deine Ausführungen von weitem höre, kann ich nicht
widerstehen, Dir meine Lösung vorzuschlagen:

Ich habe ein Aldi-Asus L-8400C mit nicht zu knackendem ESS-Modem,
für das es einen nicht mehr aufzufindenden binary HP-hack gibt,
weil das Modem auch in einem HP-Notebook verbaut ist.

Viele Stunden Suche und Experimentieren mündete in die Suche nach
PC-Kartenmodems, die Du bei Ebay zu Preisen zwischen 2-<10 EUR
nachgeschmissen bekommst. Du musst nur darauf achten, ein
"serielles" zu erwischen.

guck Dich nach sowas um, und geh' in der ersparten Zeit an die Sonne
- womöglich mit der künftigen Ubuntu-Enthusiastin?? - und tanke
frische Luft und Energie. Glaube mir: Die Zeit ist besser genutzt
so.

Falls also dein Streben kein akademisches ist, frag' hier nochmal
nach, wie Du die Win-"Gurken" aus den PC-Karten ausschließt - ich
müsste auch nochmal nachrecherchieren, und würde es - nur bei
Interesse!! - auch tun.

Friedrich

--
 Beste Grüße von der Schwäbischen Alb


--
ubuntu-de mailing list
[hidden email]
http://lists.ubuntu.com/mailman/listinfo/ubuntu-de
Reply | Threaded
Open this post in threaded view
|

Re: WinModem auf IBM Thinkpad T23

Big Maze
Am Montag, den 14.11.2005, 14:11 +0100 schrieb Friedrich Strohmaier:

Hallo Friedrich,

[...]
>
> >Hallo Leute,
> [.. viel M�he um Winmodem ..]
Ja, die Dinger sind zum K... Im Besonderen, da diese in einem IBM
werkeln(?!?!?). Was haben die sich dabei gedacht?
[...]
Danke f�r die Tips.
>
> Falls also dein Streben kein akademisches ist,
Naja, so �hnlich: Mein Ehrgeiz eben und mein Patos. Denn ich habe
gro�maulig get�nt: "Das kann linux (und im Speziellen Ubuntu) auch."

>
Grusz Mathias



--
ubuntu-de mailing list
[hidden email]
http://lists.ubuntu.com/mailman/listinfo/ubuntu-de
Reply | Threaded
Open this post in threaded view
|

KompilierProblem

Mathias Uebel
In reply to this post by Big Maze
Hallo Leute,

ich versuche es mal anders:
Um ein Winmodem zu installieren habe ich diese Anleitung gefunden.
> http://ubuntuforums.org/archive/index.php/t-84805.html 
Wenn ich nun kompilieren m�chte, unterbricht das "make" mit dieser
Fehlermeldung:

make -C /lib/modules/`uname -r`/build SUBDIRS=/root/ltmodem-2.6-alk-7c
modules
make[1]: Gehe in Verzeichnis �/lib/modules/2.6.12-9-386/build�
make[1]: *** Keine Regel, um >>modules<< zu erstellen. Schluss.
make[1]: Verlasse Verzeichnis �/lib/modules/2.6.12-9-386/build�
make[1]: *** [module] Fehler 2

Was mache ich falsch? Was l�uft falsch?

Hier das Makefile:

# makefile for ltmodem for 2.6 kernels
#

DEVICE_FILE := /dev/ttyLTM0

MODULE_NAME := ltmodem

KERNEL_DIR := /lib/modules/`uname -r`/build
#KERNEL_DIR := /usr/src/linux-2.6.10

INSTALL_DIR := /lib/modules/`uname -r`/other

ltmodem-objs := lt_modem.o ltmdmobj.o

ltserial-objs := serial.o

obj-m += ltmodem.o ltserial.o

EXTRA_CFLAGS += -Wall
#EXTRA_CFLAGS += -Wall -DLT_USE_OLD_NAMES -DLT_USE_FIFO

EXTRA_LDFLAGS := -d

module:
        make -C $(KERNEL_DIR) SUBDIRS=$(PWD) modules

$(obj)/ltmdmobj.o:
        cp $(src)/ltmdmobj.o $(obj)/ltmdmobj.o

clean:
        rm -fR lt_modem.o ltmodem.o ltserial.ko \
        serial.o ltserial.o ltserial.mod.* ltmodem.mod.o \
        ltmodem.ko ltmodem.mod.c \
        .*.cmd .tmp_versions

# mdk_install target courtesy of Bea Petrovicova
mdk_install:
        # Step 1: Creating the folder for the modem driver in the kernel.
        if [ ! -d $(INSTALL_DIR) ]; then \
                mkdir $(INSTALL_DIR); \
        fi
        # Step 2: Copying files ltmodem.ko & ltserial.ko into kernel.
        cp -v *.ko $(INSTALL_DIR)
        # Step 3: Creating device file $(DEVICE_FILE)
        # NOTE: You might need to change change owner ang \
        #       group of $(DEVICE_FILE) to math /dev/ttyS0. \
        #       Debian users set group to 'dialout'.
        if [ ! -e $(DEVICE_FILE) ]; then \
                mknod --mode=0660 $(DEVICE_FILE) c 62 64; \
        fi
        # Step 4: Adding modem configuration into /etc/modprobe.conf
        if [ -e /etc/modprobe.conf ]; then \
                if ! grep "ltserial" /etc/modprobe.conf; then \
                        echo -e "\n# ltmodem configuration" \
                                "\nalias char-major-62 ltserial" \
                                "\nalias /dev/modem ltserial" >>/etc/modprobe.conf; \
                fi; \
        fi
        # Step 5: Adding winmodem module into /etc/modprobe.preload
        if [ -e /etc/modprobe.preload ]; then \
                if ! grep "ltserial" /etc/modprobe.preload; then \
                        echo -e "\n# ltmodem configuration" \
                                "\nltserial" >>/etc/modprobe.preload; \
                fi; \
        fi
        # NOTE: Installation complete. To test your modem, try:
        # depmod -a
        # modprobe ltserial
        # lsmod



--
ubuntu-de mailing list
[hidden email]
http://lists.ubuntu.com/mailman/listinfo/ubuntu-de
Reply | Threaded
Open this post in threaded view
|

Re: KompilierProblem

Matthias K.
Hallo Mathias

Ich vermute mal du stolperst �ber folgende zeile in der anleitung:
2. ln -s /usr/bin/gcc3.4 gcc (This might be different for others)
Das halte ich 1. f�r keine gute idee und 2. musst du daf�r nat�rlich im
verzeichnis /usr/bin/ sein. Besser du machst folgendes:
"export CC=/usr/bin/gcc-3.4"
"make"
Alternativ geht auch ein "CC=/usr/bin/gcc-3.4 make"
Ich gehe mal davon aus das der gcc-3.4 installiert ist.

Viele Gr��e
Matthias

P.S. Sorry wenn ich dir alte h�te verkauft habe. ;)




--
ubuntu-de mailing list
[hidden email]
http://lists.ubuntu.com/mailman/listinfo/ubuntu-de
Reply | Threaded
Open this post in threaded view
|

Re: KompilierProblem

Bugzilla from michael.mauch@gmx.de
In reply to this post by Mathias Uebel
Mathias Uebel wrote:

> ich versuche es mal anders:
> Um ein Winmodem zu installieren habe ich diese Anleitung gefunden.
> > http://ubuntuforums.org/archive/index.php/t-84805.html 
> Wenn ich nun kompilieren m?chte, unterbricht das "make" mit dieser
> Fehlermeldung:
>
> make -C /lib/modules/`uname -r`/build SUBDIRS=/root/ltmodem-2.6-alk-7c
> modules
> make[1]: Gehe in Verzeichnis ?/lib/modules/2.6.12-9-386/build?
> make[1]: *** Keine Regel, um >>modules<< zu erstellen. Schluss.
> make[1]: Verlasse Verzeichnis ?/lib/modules/2.6.12-9-386/build?
> make[1]: *** [module] Fehler 2
>
> Was mache ich falsch? Was l?uft falsch?

Evtl. fehlen die Kernel-Quellen. Das Paket heisst linux-source-2.6.12,
wenn ich mich nicht t?usche.

  Michael

--
ubuntu-de mailing list
[hidden email]
http://lists.ubuntu.com/mailman/listinfo/ubuntu-de
Reply | Threaded
Open this post in threaded view
|

Re: KompilierProblem

Mathias Uebel
In reply to this post by Matthias K.
Am Montag, den 14.11.2005, 23:35 +0100 schrieb Matthias K.:
> Hallo Mathias
Dito
> Ich vermute mal du stolperst �ber folgende zeile in der anleitung:
> 2. ln -s /usr/bin/gcc3.4 gcc (This might be different for others)
> Das halte ich 1. f�r keine gute idee und 2. musst du daf�r nat�rlich im
> verzeichnis /usr/bin/ sein. Besser du machst folgendes:
> "export CC=/usr/bin/gcc-3.4"
> "make"
> Alternativ geht auch ein "CC=/usr/bin/gcc-3.4 make"
> Ich gehe mal davon aus das der gcc-3.4 installiert ist.

Nein, es funktioniert nicht mit symb. Link und auch nicht mit Deiner
Methode (CC=/...) Aber trotzdem danke, denn diese Methode war mir neu
und ist auch gut.

Grusz
Mathias



--
ubuntu-de mailing list
[hidden email]
http://lists.ubuntu.com/mailman/listinfo/ubuntu-de
Reply | Threaded
Open this post in threaded view
|

Re: KompilierProblem

Mathias Uebel
In reply to this post by Bugzilla from michael.mauch@gmx.de
Am Montag, den 14.11.2005, 23:40 +0100 schrieb Michael Mauch:
> Mathias Uebel wrote:
>
[...]
> >
> > Was mache ich falsch? Was l�uft falsch?
>
> Evtl. fehlen die Kernel-Quellen. Das Paket heisst linux-source-2.6.12,
> wenn ich mich nicht t�usche.
Hallo Michael,

danke f�r den Tip, aber das war es auch nicht. Die Quelle habe ich mit
Synaptik geholt.
Was bedeutet die Meldung: Keine *Regel*, um ...

Das wurmt mich!

Grusz Mathias



--
ubuntu-de mailing list
[hidden email]
http://lists.ubuntu.com/mailman/listinfo/ubuntu-de
Reply | Threaded
Open this post in threaded view
|

Re: KompilierProblem

Matthias K.
In reply to this post by Mathias Uebel
Bei mir klappt es.
ubumatz@ubum:/home/work/ltmodem-2.6-alk-7c$ ls -alsh *.ko
549K -rw-r--r--  1 ubumatz ubumatz 547K 2005-11-15 00:13 ltmodem.ko
 20K -rw-r--r--  1 ubumatz ubumatz  18K 2005-11-15 00:13 ltserial.ko

Vielleicht fehlen dir einfach die kernel-headers?
sudo apt-get install linux-headers-`uname -r`

Gr��e
Matthias





--
ubuntu-de mailing list
[hidden email]
http://lists.ubuntu.com/mailman/listinfo/ubuntu-de
Reply | Threaded
Open this post in threaded view
|

Re: KompilierProblem

Bugzilla from michael.mauch@gmx.de
In reply to this post by Mathias Uebel
Mathias Uebel wrote:

> Am Montag, den 14.11.2005, 23:40 +0100 schrieb Michael Mauch:
> > Mathias Uebel wrote:
> >
> [...]
> > >
> > > Was mache ich falsch? Was l?uft falsch?
> >
> > Evtl. fehlen die Kernel-Quellen. Das Paket heisst linux-source-2.6.12,
> > wenn ich mich nicht t?usche.

> danke f?r den Tip, aber das war es auch nicht. Die Quelle habe ich mit
> Synaptik geholt.
> Was bedeutet die Meldung: Keine *Regel*, um ...

Makefiles bestehen aus Regeln, die beschreiben, was getan werden muss,
um bestimmte Ziele zu erreichen. Die Ziele (targets) stehen immer ganz
links vor einem Doppelpunkt.

Gibt's denn jetzt in /lib/modules/2.6.12-9-386/build ein Makefile?

Evtl. ist noch

  make oldconfig

und/oder

  make modules

und/oder sogar

  make

n?tig. Vorher bitte in das Directory /lib/modules/2.6.12-9-386/build
(oder /usr/src/linux) gehen (cd).

  Michael

--
ubuntu-de mailing list
[hidden email]
http://lists.ubuntu.com/mailman/listinfo/ubuntu-de
Reply | Threaded
Open this post in threaded view
|

Re: KompilierProblem

Mathias Uebel
In reply to this post by Matthias K.
Am Dienstag, den 15.11.2005, 00:26 +0100 schrieb Matthias K.:
> Bei mir klappt es.
Du Gl�cklicher!
> ubumatz@ubum:/home/work/ltmodem-2.6-alk-7c$ ls -alsh *.ko
> 549K -rw-r--r--  1 ubumatz ubumatz 547K 2005-11-15 00:13 ltmodem.ko
>  20K -rw-r--r--  1 ubumatz ubumatz  18K 2005-11-15 00:13 ltserial.ko
>
> Vielleicht fehlen dir einfach die kernel-headers?
> sudo apt-get install linux-headers-`uname -r`
Nein, ich habe das alles installiert.

Ich k�nnt ...

Gruz Mathias




--
ubuntu-de mailing list
[hidden email]
http://lists.ubuntu.com/mailman/listinfo/ubuntu-de
Reply | Threaded
Open this post in threaded view
|

Re: KompilierProblem

Mathias Uebel
In reply to this post by Bugzilla from michael.mauch@gmx.de
Am Dienstag, den 15.11.2005, 00:35 +0100 schrieb Michael Mauch:
> Mathias Uebel wrote:
Hallo Michael,
[...]
danke f�r die Erkl�rung.

> Gibt's denn jetzt in /lib/modules/2.6.12-9-386/build ein Makefile?
Nein, das Verzeichnis ist leer.
>
> Evtl. ist noch
>
>   make oldconfig
# make: *** Keine Regel, um >>oldconfig<< zu erstellen
>
> und/oder
>
>   make modules
# make: *** Keine Regel, um >>modules<< zu erstellen
>
> und/oder sogar
>
>   make
Wie gehabt!
>
> n�tig. Vorher bitte in das Directory /lib/modules/2.6.12-9-386/build
> (oder /usr/src/linux) gehen (cd).
Grusz Mathias



--
ubuntu-de mailing list
[hidden email]
http://lists.ubuntu.com/mailman/listinfo/ubuntu-de
Reply | Threaded
Open this post in threaded view
|

Re: WinModem auf IBM Thinkpad T23

ulrich steffens
In reply to this post by Big Maze
Am Montag, den 14.11.2005, 13:25 +0100 schrieb Big Maze:

> Hallo Leute,
>
> ich habe hier ein IBM Thinkpad T23 und das Versprechen, auf diesem
> Notebook Win durch Ubuntu zuersetzen. Das ist fast alles gelungen und
> wir werden wohl eine weitere Ubuntu-Verliebte hinzu gewinnen. Aber ...
>
> In dem Schläppi steckt ein WinModem! Und das bekomme ich nicht zum
> laufen. Ich habe es mit
> http://ubuntuforums.org/archive/index.php/t-84805.html versucht, jedoch:
> 1. okay
> 2. okay
> 3. make bricht mit Fehler 2 ab.
> #: Keine Regel um "Modules" zu erstellen. Schluss.
>
> Was mache ich falsch? Stimmt etwas mit dem Makefile nicht? Hat jemand
> auf diesem Notebook das Winmodem laufen? Kennt jemand eine Seite, mit
> der es gklappt hat?
>
> Grusz Mathias
>
>
kann es sein, dass du gcc-4 benutzt?
soweit ich weiss ist der ubuntu-kernel mit gcc-3.4 kompiliert, also
musst du den auch benutzen um module zu kompilieren.

dazu findet man auf der englischen liste einige threads...

gruss

ulrich



--
ubuntu-de mailing list
[hidden email]
http://lists.ubuntu.com/mailman/listinfo/ubuntu-de
Reply | Threaded
Open this post in threaded view
|

Re: WinModem auf IBM Thinkpad T23

Mathias Uebel
Am Dienstag, den 15.11.2005, 02:51 +0100 schrieb ulrich steffens:
> Am Montag, den 14.11.2005, 13:25 +0100 schrieb Big Maze:
> > Hallo Leute,
[...]
> kann es sein, dass du gcc-4 benutzt?
[...]
>
Hallo Ulrich,

danke f�r den Hinweis. Deswegen ist der Link gesetzt, bzw. mit Matthias
K. "CC=/usr/bin/gcc-3.4 make" ausgef�hrt. Daran kann es nicht liegen,
oder?

Grusz



--
ubuntu-de mailing list
[hidden email]
http://lists.ubuntu.com/mailman/listinfo/ubuntu-de
Reply | Threaded
Open this post in threaded view
|

Re: KompilierProblem

Bugzilla from michael.mauch@gmx.de
In reply to this post by Mathias Uebel
Mathias Uebel wrote:

> Am Dienstag, den 15.11.2005, 00:35 +0100 schrieb Michael Mauch:
> > Mathias Uebel wrote:
> Hallo Michael,
> [...]
> danke f?r die Erkl?rung.
>
> > Gibt's denn jetzt in /lib/modules/2.6.12-9-386/build ein Makefile?
> Nein, das Verzeichnis ist leer.

Das ist schlecht. Aber /lib/modules/2.6.12-9-386/build ist ein Symlink,
der nach /usr/src/linux-2.6.12-9 zeigt?

Gibt's den Symlink /usr/src/linux (sollte auf /usr/src/linux-2.6.12-9
  zeigen)?
  Falls nein:
    Gibt's /usr/src/linux-2.6.12-9?
      Falls ja:
        cd /usr/src
        ln -s linux-2.6.12-9 linux
      Falls nein:
        Was gibt's in /usr/src (Ausgabe von "ls -l /usr/src"?)?

cd /usr/src/linux
  Gibt's darin eine .config?
    Falls nein:
      make oldconfig
    Falls ja:
      cp /boot/config-2.6.12-9-386 .config
  make oldconfig
  make modules
  make

Hoffentlich hab' ich diesmal nichts vergessen.

  Michael

--
ubuntu-de mailing list
[hidden email]
http://lists.ubuntu.com/mailman/listinfo/ubuntu-de
Reply | Threaded
Open this post in threaded view
|

Re: KompilierProblem

Mathias Uebel
Am Dienstag, den 15.11.2005, 18:47 +0100 schrieb Michael Mauch:
> Mathias Uebel wrote:
Hallo Micha,

vielen Dank f�r Deine M�he.
Deine Tips kamen aber zu sp�t. Ich habe das Ding einfach platt gemacht
und nach der Neuinstallation funktionierte das Kompilieren.
Zwar kann ich den Fehler nun nicht mehr nachvollziehen aber was soll�s.

Grusz aus der Enklave



--
ubuntu-de mailing list
[hidden email]
http://lists.ubuntu.com/mailman/listinfo/ubuntu-de