failed verification of LP: #1695093

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

failed verification of LP: #1695093

dann frazier-4
Hi,
  I went to verify LP: #1695093 ('arm64: "unsupported RELA relocation:
275" loading certain modules'") on today's upload of linux-hwe to
xenial-proposed and found that it failed. I looked at the build log,
and see that it did not pick up the gcc-5 release from xenial-updates.
I'm guessing this is because ppa:canonical-kernel-team/ppa has PPA
dependencies set to "Security" and not "Default". Anyway we can change
that and get a respin?

   -dann

--
kernel-team mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/kernel-team
Reply | Threaded
Open this post in threaded view
|

Re: failed verification of LP: #1695093

Andy Whitcroft-3
On Mon, Nov 06, 2017 at 12:16:55PM -0700, dann frazier wrote:
> Hi,
>   I went to verify LP: #1695093 ('arm64: "unsupported RELA relocation:
> 275" loading certain modules'") on today's upload of linux-hwe to
> xenial-proposed and found that it failed. I looked at the build log,
> and see that it did not pick up the gcc-5 release from xenial-updates.
> I'm guessing this is because ppa:canonical-kernel-team/ppa has PPA
> dependencies set to "Security" and not "Default". Anyway we can change
> that and get a respin?

The PPA has to be built against security only as kernels are released
into the -security pocket most of the time.  I believe the failure here
is that the compiler has been released into -updates only.  I will
follow up with the SRU team to confirm this is indeed incorrect and to
get things fixed.

-apw

--
kernel-team mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/kernel-team
Reply | Threaded
Open this post in threaded view
|

Re: failed verification of LP: #1695093

dann frazier-4
On Tue, Nov 7, 2017 at 1:47 AM, Andy Whitcroft <[hidden email]> wrote:

> On Mon, Nov 06, 2017 at 12:16:55PM -0700, dann frazier wrote:
>> Hi,
>>   I went to verify LP: #1695093 ('arm64: "unsupported RELA relocation:
>> 275" loading certain modules'") on today's upload of linux-hwe to
>> xenial-proposed and found that it failed. I looked at the build log,
>> and see that it did not pick up the gcc-5 release from xenial-updates.
>> I'm guessing this is because ppa:canonical-kernel-team/ppa has PPA
>> dependencies set to "Security" and not "Default". Anyway we can change
>> that and get a respin?
>
> The PPA has to be built against security only as kernels are released
> into the -security pocket most of the time.  I believe the failure here
> is that the compiler has been released into -updates only.  I will
> follow up with the SRU team to confirm this is indeed incorrect and to
> get things fixed.

OK, makes sense. Thanks Andy!

  -dann

--
kernel-team mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/kernel-team