gpodder and ubuntu

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

gpodder and ubuntu

Brian-4
Having just moved over to Ubuntu (16.04 LTS) when I managed to work
round a problem with the installer, I'm having trouble getting gpodder
up and running again.

It worked just fine under Debian Stretch, but when I installed it
again (from the repositores), trying to run the program produced the
load of (quoted) output pasted below.

Can somebody please translate this into what I need to do to get
gpodder running again, please, because it's over my head... :(

Thanks.

<paste>

> brian@brian-ubuntu:~$ gpodder
>
> ** (gpodder:13361): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-kVKoNp5AcQ: Connection refused
> 1513096484.441575 [gpodder.sync] WARNING: Could not find gpod
> 1513096484.441853 [gpodder.sync] WARNING: Could not find eyed3.mp3
> 1513096484.717034 [gpodder.log] ERROR: Uncaught exception: Traceback (most recent call last):
>   File "/usr/bin/gpodder", line 160, in <module>
>     main()
>   File "/usr/bin/gpodder", line 155, in main
>     main.main(options)
>   File "/usr/lib/python2.7/dist-packages/gpodder/gtkui/main.py", line 3500, in main
>     gp = gPodder(bus_name, core.Core(UIConfig, model_class=Model), options)
>   File "/usr/lib/python2.7/dist-packages/gpodder/gtkui/main.py", line 121, in __init__
>     BuilderWidget.__init__(self, None)
>   File "/usr/lib/python2.7/dist-packages/gpodder/gtkui/interface/common.py", line 38, in __init__
>     GtkBuilderWidget.__init__(self, gpodder.ui_folders, gpodder.textdomain, **kwargs)
>   File "/usr/lib/python2.7/dist-packages/gpodder/gtkui/base.py", line 66, in __init__
>     self.new()
>   File "/usr/lib/python2.7/dist-packages/gpodder/gtkui/main.py", line 234, in new
>     self.channels = self.model.get_podcasts()
>   File "/usr/lib/python2.7/dist-packages/gpodder/model.py", line 1358, in get_podcasts
>     self.children = self.db.load_podcasts(podcast_factory)
>   File "/usr/lib/python2.7/dist-packages/gpodder/dbsqlite.py", line 159, in load_podcasts
>     cur = self.cursor()
>   File "/usr/lib/python2.7/dist-packages/gpodder/dbsqlite.py", line 103, in cursor
>     return self.db.cursor()
>   File "/usr/lib/python2.7/dist-packages/gpodder/dbsqlite.py", line 94, in db
>     schema.upgrade(self._db, self.database_file)
>   File "/usr/lib/python2.7/dist-packages/gpodder/schema.py", line 202, in upgrade
>     assert version == CURRENT_VERSION
> AssertionError
>
> Traceback (most recent call last):
>   File "/usr/bin/gpodder", line 160, in <module>
>     main()
>   File "/usr/bin/gpodder", line 155, in main
>     main.main(options)
>   File "/usr/lib/python2.7/dist-packages/gpodder/gtkui/main.py", line 3500, in main
>     gp = gPodder(bus_name, core.Core(UIConfig, model_class=Model), options)
>   File "/usr/lib/python2.7/dist-packages/gpodder/gtkui/main.py", line 121, in __init__
>     BuilderWidget.__init__(self, None)
>   File "/usr/lib/python2.7/dist-packages/gpodder/gtkui/interface/common.py", line 38, in __init__
>     GtkBuilderWidget.__init__(self, gpodder.ui_folders, gpodder.textdomain, **kwargs)
>   File "/usr/lib/python2.7/dist-packages/gpodder/gtkui/base.py", line 66, in __init__
>     self.new()
>   File "/usr/lib/python2.7/dist-packages/gpodder/gtkui/main.py", line 234, in new
>     self.channels = self.model.get_podcasts()
>   File "/usr/lib/python2.7/dist-packages/gpodder/model.py", line 1358, in get_podcasts
>     self.children = self.db.load_podcasts(podcast_factory)
>   File "/usr/lib/python2.7/dist-packages/gpodder/dbsqlite.py", line 159, in load_podcasts
>     cur = self.cursor()
>   File "/usr/lib/python2.7/dist-packages/gpodder/dbsqlite.py", line 103, in cursor
>     return self.db.cursor()
>   File "/usr/lib/python2.7/dist-packages/gpodder/dbsqlite.py", line 94, in db
>     schema.upgrade(self._db, self.database_file)
>   File "/usr/lib/python2.7/dist-packages/gpodder/schema.py", line 202, in upgrade
>     assert version == CURRENT_VERSION
> AssertionError
> brian@brian-ubuntu:~$

--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: gpodder and ubuntu

Phil Dobbin
On 12/12/17 16:42, Brian wrote:

> Having just moved over to Ubuntu (16.04 LTS) when I managed to work
> round a problem with the installer, I'm having trouble getting gpodder
> up and running again.
>
> It worked just fine under Debian Stretch, but when I installed it
> again (from the repositores), trying to run the program produced the
> load of (quoted) output pasted below.
>
> Can somebody please translate this into what I need to do to get
> gpodder running again, please, because it's over my head... :(
>
> Thanks.
>
> <paste>
>
>> brian@brian-ubuntu:~$ gpodder
>>
Try launching the GUI version via the Super key.

Cheers,

  Phil.

--
an infinite number of monkeys typing into GNU emacs would never make a
good program
     Linus Torvalds (from the Linux kernel source code)


--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users

signature.asc (836 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: gpodder and ubuntu

Brian-4
On 12/12/2017 11:52 AM, Phil Dobbin wrote:

> On 12/12/17 16:42, Brian wrote:
>
>> Having just moved over to Ubuntu (16.04 LTS) when I managed to work
>> round a problem with the installer, I'm having trouble getting gpodder
>> up and running again.
>>
>> It worked just fine under Debian Stretch, but when I installed it
>> again (from the repositores), trying to run the program produced the
>> load of (quoted) output pasted below.
>>
>> Can somebody please translate this into what I need to do to get
>> gpodder running again, please, because it's over my head... :(
>>
>> Thanks.
>>
>> <paste>
>>
>>> brian@brian-ubuntu:~$ gpodder
>>>
>
> Try launching the GUI version via the Super key.
>

Same happens as when I try to run the GUI version normally - no
visible output, the program never appears in the task list (or, more
likely, it appears but exits too quickly for me to see it).

That was why I switched to running in the terminal, to see whether I
could get some idea of what was happening. It did tell me what was
happening, I just don't understand the output. :(


Brian.

--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: gpodder and ubuntu

Liam Proven
In reply to this post by Brian-4
On 12 December 2017 at 17:42, Brian <[hidden email]> wrote:
>
> Can somebody please translate this into what I need to do to get
> gpodder running again, please, because it's over my head... :(

That's odd. It's in the standard repos, it should just work.

This seems good advice:

http://installion.co.uk/ubuntu/xenial/universe/g/gpodder/uninstall/index.html

Then reinstall with this:

http://installion.co.uk/ubuntu/xenial/universe/g/gpodder/install/index.html

What variant of Ubuntu are you running -- normal Unity or what?

--
Liam Proven • Profile: https://about.me/liamproven
Email: [hidden email] • Google Mail/Talk/Plus: [hidden email]
Twitter/Facebook/Flickr: lproven • Skype/LinkedIn/AIM/Yahoo: liamproven
UK: +44 7939-087884 • ČR/WhatsApp/Telegram/Signal: +420 702 829 053

--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: gpodder and ubuntu

Brian-4
On 12/12/2017 12:38 PM, Liam Proven wrote:

> On 12 December 2017 at 17:42, Brian <[hidden email]> wrote:
>>
>> Can somebody please translate this into what I need to do to get
>> gpodder running again, please, because it's over my head... :(
>
> That's odd. It's in the standard repos, it should just work.
>
> This seems good advice:
>
> http://installion.co.uk/ubuntu/xenial/universe/g/gpodder/uninstall/index.html
>
> Then reinstall with this:
>
> http://installion.co.uk/ubuntu/xenial/universe/g/gpodder/install/index.html
>
> What variant of Ubuntu are you running -- normal Unity or what?
>

Ubuntu Studio, but with XFCE installed (same desktop as I was using
with Debian, when gPodder worked). I'll give the uninstall and
reinstall a try when I get chance, later today.


Brian.

--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: gpodder and ubuntu

Brian-4
On 12/12/2017 01:13 PM, I wrote:

> On 12/12/2017 12:38 PM, Liam Proven wrote:
>> On 12 December 2017 at 17:42, Brian <[hidden email]> wrote:
>>>
>>> Can somebody please translate this into what I need to do to get
>>> gpodder running again, please, because it's over my head... :(
>>
>> That's odd. It's in the standard repos, it should just work.
>>
>> This seems good advice:
>>
>> http://installion.co.uk/ubuntu/xenial/universe/g/gpodder/uninstall/index.html
>>
>> Then reinstall with this:
>>
>> http://installion.co.uk/ubuntu/xenial/universe/g/gpodder/install/index.html
>>
>> What variant of Ubuntu are you running -- normal Unity or what?
>>
>
> Ubuntu Studio, but with XFCE installed (same desktop as I was using
> with Debian, when gPodder worked). I'll give the uninstall and
> reinstall a try when I get chance, later today.
>


I gave it a try, going as far as the purge with the unused
dependencies, and then reinstalled. No difference. Trying to run the
program via the desktop icon has no effect, if I try from the terminal
the output looks more or less the same (pasted below). There's a forum
on gpodder's homepage, I'll paste this lot there as well and see
whether anybody there has any ideas.

Brian.


<Paste>

> brian@brian-ubuntu:~$ gpodder
>
> ** (gpodder:9768): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-NRTw0sl9Ok: Connection refused
> 1513144272.166461 [gpodder.sync] WARNING: Could not find gpod
> 1513144272.166756 [gpodder.sync] WARNING: Could not find eyed3.mp3
> 1513144272.418642 [gpodder.log] ERROR: Uncaught exception: Traceback (most recent call last):
>   File "/usr/bin/gpodder", line 160, in <module>
>     main()
>   File "/usr/bin/gpodder", line 155, in main
>     main.main(options)
>   File "/usr/lib/python2.7/dist-packages/gpodder/gtkui/main.py", line 3500, in main
>     gp = gPodder(bus_name, core.Core(UIConfig, model_class=Model), options)
>   File "/usr/lib/python2.7/dist-packages/gpodder/gtkui/main.py", line 121, in __init__
>     BuilderWidget.__init__(self, None)
>   File "/usr/lib/python2.7/dist-packages/gpodder/gtkui/interface/common.py", line 38, in __init__
>     GtkBuilderWidget.__init__(self, gpodder.ui_folders, gpodder.textdomain, **kwargs)
>   File "/usr/lib/python2.7/dist-packages/gpodder/gtkui/base.py", line 66, in __init__
>     self.new()
>   File "/usr/lib/python2.7/dist-packages/gpodder/gtkui/main.py", line 234, in new
>     self.channels = self.model.get_podcasts()
>   File "/usr/lib/python2.7/dist-packages/gpodder/model.py", line 1358, in get_podcasts
>     self.children = self.db.load_podcasts(podcast_factory)
>   File "/usr/lib/python2.7/dist-packages/gpodder/dbsqlite.py", line 159, in load_podcasts
>     cur = self.cursor()
>   File "/usr/lib/python2.7/dist-packages/gpodder/dbsqlite.py", line 103, in cursor
>     return self.db.cursor()
>   File "/usr/lib/python2.7/dist-packages/gpodder/dbsqlite.py", line 94, in db
>     schema.upgrade(self._db, self.database_file)
>   File "/usr/lib/python2.7/dist-packages/gpodder/schema.py", line 202, in upgrade
>     assert version == CURRENT_VERSION
> AssertionError
>
> Traceback (most recent call last):
>   File "/usr/bin/gpodder", line 160, in <module>
>     main()
>   File "/usr/bin/gpodder", line 155, in main
>     main.main(options)
>   File "/usr/lib/python2.7/dist-packages/gpodder/gtkui/main.py", line 3500, in main
>     gp = gPodder(bus_name, core.Core(UIConfig, model_class=Model), options)
>   File "/usr/lib/python2.7/dist-packages/gpodder/gtkui/main.py", line 121, in __init__
>     BuilderWidget.__init__(self, None)
>   File "/usr/lib/python2.7/dist-packages/gpodder/gtkui/interface/common.py", line 38, in __init__
>     GtkBuilderWidget.__init__(self, gpodder.ui_folders, gpodder.textdomain, **kwargs)
>   File "/usr/lib/python2.7/dist-packages/gpodder/gtkui/base.py", line 66, in __init__
>     self.new()
>   File "/usr/lib/python2.7/dist-packages/gpodder/gtkui/main.py", line 234, in new
>     self.channels = self.model.get_podcasts()
>   File "/usr/lib/python2.7/dist-packages/gpodder/model.py", line 1358, in get_podcasts
>     self.children = self.db.load_podcasts(podcast_factory)
>   File "/usr/lib/python2.7/dist-packages/gpodder/dbsqlite.py", line 159, in load_podcasts
>     cur = self.cursor()
>   File "/usr/lib/python2.7/dist-packages/gpodder/dbsqlite.py", line 103, in cursor
>     return self.db.cursor()
>   File "/usr/lib/python2.7/dist-packages/gpodder/dbsqlite.py", line 94, in db
>     schema.upgrade(self._db, self.database_file)
>   File "/usr/lib/python2.7/dist-packages/gpodder/schema.py", line 202, in upgrade
>     assert version == CURRENT_VERSION
> AssertionError


--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: gpodder and ubuntu

Brian-4
On 12/13/2017 12:55 AM, Brian wrote:

> On 12/12/2017 01:13 PM, I wrote:
>> On 12/12/2017 12:38 PM, Liam Proven wrote:
>>> On 12 December 2017 at 17:42, Brian <[hidden email]> wrote:
>>>>
>>>> Can somebody please translate this into what I need to do to get
>>>> gpodder running again, please, because it's over my head... :(
>>>
>>> That's odd. It's in the standard repos, it should just work.
>>>
>>> This seems good advice:
>>>
>>> http://installion.co.uk/ubuntu/xenial/universe/g/gpodder/uninstall/index.html
>>>
>>> Then reinstall with this:
>>>
>>> http://installion.co.uk/ubuntu/xenial/universe/g/gpodder/install/index.html
>>>
>>> What variant of Ubuntu are you running -- normal Unity or what?
>>>
>>
>> Ubuntu Studio, but with XFCE installed (same desktop as I was using
>> with Debian, when gPodder worked). I'll give the uninstall and
>> reinstall a try when I get chance, later today.
>>
>
>
> I gave it a try, going as far as the purge with the unused
> dependencies, and then reinstalled. No difference. Trying to run the
> program via the desktop icon has no effect, if I try from the terminal
> the output looks more or less the same (pasted below). There's a forum
> on gpodder's homepage, I'll paste this lot there as well and see
> whether anybody there has any ideas.
>

Interesting. There's a ppa for gpodder

(https://launchpad.net/~thp/+archive/ubuntu/gpodder)

and adding that then a dist-upgrade (it's held back by an ordinary
upgrade) installs a new version of gpodder. It still gives a bunch of
error messages when run from a terminal, but now the program WORKS
after it's got all the verbiage out of the way. I don't pretend to
understand why, but if it fixes the problem, I'm happy...


Brian.

--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users