kernel 4.12: iwlwifi: 8260: missing iwlwifi-8000C-{22..30}.ucode firmware

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

kernel 4.12: iwlwifi: 8260: missing iwlwifi-8000C-{22..30}.ucode firmware

Edmund Laugasson-2
Dear all,

I made a bug report at
https://bugzilla.kernel.org/show_bug.cgi?id=196395 but Intel developer
said (as you can see in the end of that report comments) that Ubuntu has
not integrated them. May I ask - why? Currently with Intel 8260
controller does not work with 4.12.x kernel.

Shall I file the bug report at
https://bugs.launchpad.net/~ubuntu-kernel-team ??

Yours faithfully,
Edmund Laugasson


--
kernel-team mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/kernel-team
Reply | Threaded
Open this post in threaded view
|

Re: kernel 4.12: iwlwifi: 8260: missing iwlwifi-8000C-{22..30}.ucode firmware

Seth Forshee
On Mon, Jul 17, 2017 at 03:45:09PM +0300, Edmund Laugasson wrote:

> Dear all,
>
> I made a bug report at
> https://bugzilla.kernel.org/show_bug.cgi?id=196395 but Intel developer
> said (as you can see in the end of that report comments) that Ubuntu has
> not integrated them. May I ask - why? Currently with Intel 8260
> controller does not work with 4.12.x kernel.
>
> Shall I file the bug report at
> https://bugs.launchpad.net/~ubuntu-kernel-team ??

What release are you using? The only place where 4.12 is currently
relevant is artful 17.10, and that is more or less up to date. If you
are using a 4.12 kernel on other releases, that's not supported
currently (the hwe-edge kernel in xenial will move to 4.12 and beyond
later, but that hasn't happened yet). However if there are firmware
updates relevant to a supported kernel for any release you can file a
bug against linux-firmware, and we will consider pulling in the
upedates.

Regarding the -22 firmware specifically, we had to remove that from all
releases because it wasn't working at all for some hardware
configurations. Unless those issues have been fixed we won't be able to
pull in that firmware version.

Thanks,
Seth

--
kernel-team mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/kernel-team
Reply | Threaded
Open this post in threaded view
|

Re: kernel 4.12: iwlwifi: 8260: missing iwlwifi-8000C-{22..30}.ucode firmware

Edmund Laugasson-2
Hi,

> What release are you using? The only place where 4.12 is currently
> relevant is artful 17.10, and that is more or less up to date.
Using still Xenial branch but with newest stable kernel.

> If you are using a 4.12 kernel on other releases, that's not supported
> currently (the hwe-edge kernel in xenial will move to 4.12 and beyond
> later, but that hasn't happened yet).

Are you trying to say that if I install Artful 17.10 then this firmware
is there and Intel 8260 with iwlwifi works? The problem is that 17.10 is
not LTS and therefore not supported by other important cases like
Estonian ID card etc. Most software vendors do not support usually
others than LTS.

> However if there are firmware updates relevant to a supported kernel for any release you can file a
> bug against linux-firmware, and we will consider pulling in the upedates.

Done - https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1704799

> Regarding the -22 firmware specifically, we had to remove that from all
> releases because it wasn't working at all for some hardware
> configurations. Unless those issues have been fixed we won't be able to
> pull in that firmware version.

Sad to hear it. This makes 4.12+ kernel useless for me unless I manually
hack them like I recently did. Mentioned it also in that bug report. I
really hope that you can cope with Intel developers and solve those
issues you mentioned.

Best Regards,
Edmund Laugasson


--
kernel-team mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/kernel-team
Reply | Threaded
Open this post in threaded view
|

Re: kernel 4.12: iwlwifi: 8260: missing iwlwifi-8000C-{22..30}.ucode firmware

Seth Forshee
On Mon, Jul 17, 2017 at 05:26:02PM +0300, Edmund Laugasson wrote:

> Hi,
>
> > What release are you using? The only place where 4.12 is currently
> > relevant is artful 17.10, and that is more or less up to date.
> Using still Xenial branch but with newest stable kernel.
>
> > If you are using a 4.12 kernel on other releases, that's not supported
> > currently (the hwe-edge kernel in xenial will move to 4.12 and beyond
> > later, but that hasn't happened yet).
>
> Are you trying to say that if I install Artful 17.10 then this firmware
> is there and Intel 8260 with iwlwifi works? The problem is that 17.10 is
> not LTS and therefore not supported by other important cases like
> Estonian ID card etc. Most software vendors do not support usually
> others than LTS.

We have iwlwifi-8000C-27.ucode in artful, which is the latest version in
upstream linux-firmware. I can't say for sure whether or not your
hardware will work though, since Intel 8260 wireless has been working
for some in xenial and the hwe kernel.

Note that you can't trust the versions the driver looks for, as Intel
regularly adds support for firmware being used internally that never
gets publicly released.

> > However if there are firmware updates relevant to a supported kernel for any release you can file a
> > bug against linux-firmware, and we will consider pulling in the upedates.
>
> Done - https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1704799
>
> > Regarding the -22 firmware specifically, we had to remove that from all
> > releases because it wasn't working at all for some hardware
> > configurations. Unless those issues have been fixed we won't be able to
> > pull in that firmware version.
>
> Sad to hear it. This makes 4.12+ kernel useless for me unless I manually
> hack them like I recently did. Mentioned it also in that bug report. I
> really hope that you can cope with Intel developers and solve those
> issues you mentioned.

The issues were reported to us by System76, I thought they had reported
them to Intel but I can't say for sure.

I will be pulling newer firmware files into xenial soon as hwe-edge
moves forward to 4.11 and then to 4.12. I will follow up with System76
to see if the -27 firmware has the same issues as -22 did.

Thanks,
Seth

--
kernel-team mailing list
[hidden email]
https://lists.ubuntu.com/mailman/listinfo/kernel-team