python3-numpy depending on *both* python 3.6 and 3.7

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

python3-numpy depending on *both* python 3.6 and 3.7

Andreas Hasenack-5
Hi,

while investigating some DEP8 failures currently in cosmic's
migration, I came across this:
$ dpkg -s python3-numpy|grep Depends
Depends: python3 (<< 3.8), python3 (>= 3.6~), python3.6:any,
python3.7:any, python3:any (>= 3.3.2-2~), libblas3 | libblas.so.3,
libc6 (>= 2.27), liblapack3 | liblapack.so.3

Is it ok/correct to depend on two python versions like that? Is the
point of it making sure numpy is available regardless which python 3
you are using? But at the cost of pulling in both?

This is breaking python3-libcloud, which does not support python3.7,
when pulled in via fdroidserver:
https://pastebin.ubuntu.com/p/Kn77DXfxR5/

The correct fix is to have python3-libcloud work with python 3.7, by
replacing "async" (a reserved keyword in python3.7) with something
else, like async_, but what caught my eye was this numpy dependency in
two python versions. And how libcloud ended up chosing 3.7 over 3.6
I'm not sure.

--
ubuntu-devel mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel
Reply | Threaded
Open this post in threaded view
|

Re: python3-numpy depending on *both* python 3.6 and 3.7

Steve Langasek-6
Hi Andreas,

On Fri, Aug 24, 2018 at 10:05:23AM -0300, Andreas Hasenack wrote:

> Hi,
>
> while investigating some DEP8 failures currently in cosmic's
> migration, I came across this:
> $ dpkg -s python3-numpy|grep Depends
> Depends: python3 (<< 3.8), python3 (>= 3.6~), python3.6:any,
> python3.7:any, python3:any (>= 3.3.2-2~), libblas3 | libblas.so.3,
> libc6 (>= 2.27), liblapack3 | liblapack.so.3
>
> Is it ok/correct to depend on two python versions like that? Is the
> point of it making sure numpy is available regardless which python 3
> you are using? But at the cost of pulling in both?
>
> This is breaking python3-libcloud, which does not support python3.7,
> when pulled in via fdroidserver:
> https://pastebin.ubuntu.com/p/Kn77DXfxR5/
>
> The correct fix is to have python3-libcloud work with python 3.7, by
> replacing "async" (a reserved keyword in python3.7) with something
> else, like async_, but what caught my eye was this numpy dependency in
> two python versions. And how libcloud ended up chosing 3.7 over 3.6
> I'm not sure.
This issue was reported in Debian during the previous python transition, and
was closed without a permanent resolution:

 https://bugs.debian.org/878281

And a bug is now open again about the same issue wrt the python3.7
transition:

 https://bugs.debian.org/903663

I agree that the current behavior is incorrect and not what we expect from
packages that support multiple versions of python3.

--
Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
Ubuntu Developer                                   https://www.debian.org/
[hidden email]                                     [hidden email]

--
ubuntu-devel mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: python3-numpy depending on *both* python 3.6 and 3.7

Michael Hudson-Doyle


On Sat, 25 Aug 2018 at 05:07, Steve Langasek <[hidden email]> wrote:
Hi Andreas,

On Fri, Aug 24, 2018 at 10:05:23AM -0300, Andreas Hasenack wrote:
> Hi,
>
> while investigating some DEP8 failures currently in cosmic's
> migration, I came across this:
> $ dpkg -s python3-numpy|grep Depends
> Depends: python3 (<< 3.8), python3 (>= 3.6~), python3.6:any,
> python3.7:any, python3:any (>= 3.3.2-2~), libblas3 | libblas.so.3,
> libc6 (>= 2.27), liblapack3 | liblapack.so.3
>
> Is it ok/correct to depend on two python versions like that? Is the
> point of it making sure numpy is available regardless which python 3
> you are using? But at the cost of pulling in both?
>
> This is breaking python3-libcloud, which does not support python3.7,
> when pulled in via fdroidserver:
> https://pastebin.ubuntu.com/p/Kn77DXfxR5/
>
> The correct fix is to have python3-libcloud work with python 3.7, by
> replacing "async" (a reserved keyword in python3.7) with something
> else, like async_, but what caught my eye was this numpy dependency in
> two python versions. And how libcloud ended up chosing 3.7 over 3.6
> I'm not sure.

This issue was reported in Debian during the previous python transition, and
was closed without a permanent resolution:

 https://bugs.debian.org/878281

And a bug is now open again about the same issue wrt the python3.7
transition:

 https://bugs.debian.org/903663

I agree that the current behavior is incorrect and not what we expect from
packages that support multiple versions of python3.

So the problem is that python3-numpy contains a version of 'f2py' for each supported version of Python. I guess the proper fix involves creating a separate package for the each version of f2py? python3.6-f2py, python3.7-f2py, and have python3-numpy depend on the one for the default version of Python?

Cheers,
mwh 

--
ubuntu-devel mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel
Reply | Threaded
Open this post in threaded view
|

Re: python3-numpy depending on *both* python 3.6 and 3.7

Dmitry Shachnev-2
On Sun, Aug 26, 2018 at 10:01:38PM +1200, Michael Hudson-Doyle wrote:
> So the problem is that python3-numpy contains a version of 'f2py' for each
> supported version of Python. I guess the proper fix involves creating a
> separate package for the each version of f2py? python3.6-f2py,
> python3.7-f2py, and have python3-numpy depend on the one for the default
> version of Python?

This will mean having a new package name whenever we add a new supported
Python version. It will be very inconvenient to maintain.

Better remove the versioned scripts altogether and use “python3.x -m
numpy.f2py” when one really needs a non-default Python version.

--
Dmitry Shachnev

--
ubuntu-devel mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: python3-numpy depending on *both* python 3.6 and 3.7

Michael Hudson-Doyle


On Sun, 26 Aug 2018 at 23:48, Dmitry Shachnev <[hidden email]> wrote:
On Sun, Aug 26, 2018 at 10:01:38PM +1200, Michael Hudson-Doyle wrote:
> So the problem is that python3-numpy contains a version of 'f2py' for each
> supported version of Python. I guess the proper fix involves creating a
> separate package for the each version of f2py? python3.6-f2py,
> python3.7-f2py, and have python3-numpy depend on the one for the default
> version of Python?

This will mean having a new package name whenever we add a new supported
Python version. It will be very inconvenient to maintain.

Better remove the versioned scripts altogether and use “python3.x -m
numpy.f2py” when one really needs a non-default Python version.


Yes, that's probably a better plan.

Cheers,
mwh 

--
ubuntu-devel mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel
Reply | Threaded
Open this post in threaded view
|

Re: python3-numpy depending on *both* python 3.6 and 3.7

Andreas Hasenack-5
>> Better remove the versioned scripts altogether and use “python3.x -m
>> numpy.f2py” when one really needs a non-default Python version.
>>
>
> Yes, that's probably a better plan.

I filed https://bugs.launchpad.net/debian/+source/python-numpy/+bug/1789199
and linked it to the debian bug as well.

--
ubuntu-devel mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel