"testbed out of date"

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

"testbed out of date"

Andreas Hasenack-5
Hi,

autopkgtest [13:07:06]: ERROR: erroneous package: Test dependencies are unsatisfiable. A common reason is that your testbed is out of date with respect to the archive, and you need to use a current testbed or run apt-get update or use -U.
blame: firejail
badpkg: Test dependencies are unsatisfiable. A common reason is that your testbed is out of date with respect to the archive, and you need to use a current testbed or run apt-get update or use -U.

Can someone confirm if the testbed is prepared with -U so that apt-get update runs? I don't think I can control that from the package's d/t/control file.

Not saying that's the problem, I'm still investigating, but I wanted to see if I can rule that (lack of -U) out.

Thanks


--
ubuntu-devel mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel
Reply | Threaded
Open this post in threaded view
|

Re: "testbed out of date"

Iain Lane-6
On Thu, Dec 07, 2017 at 01:59:45PM -0200, Andreas Hasenack wrote:

> Hi,
>
> I'm getting this error a lot in some test runs (like
> https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful/artful/s390x/f/firejail/20171207_130707_4ca6a@/log.gz
> ):
>
> autopkgtest [13:07:06]: ERROR: erroneous package: Test dependencies
> are unsatisfiable. A common reason is that your testbed is out of date
> with respect to the archive, and you need to use a current testbed or
> run apt-get update or use -U.
> blame: firejail
> badpkg: Test dependencies are unsatisfiable. A common reason is that
> your testbed is out of date with respect to the archive, and you need
> to use a current testbed or run apt-get update or use -U.
The log says

Broken autopkgtest-satdep:s390x Depends on thunderbird:s390x < none @unH >
  Removing autopkgtest-satdep:s390x because I can't find
  thunderbird:s390x

and

laney@nightingale> rmadison -a s390x -s artful,artful-proposed thunderbird
laney@nightingale>

indeed thunderbird isn't available there.

It's a test which started to run when we got isolation-machine on s390x.
All of the tests were skipped before. I think this could be
force-badtested, and I've added that for you.

> Can someone confirm if the testbed is prepared with -U so that apt-get
> update runs? I don't think I can control that from the package's
> d/t/control file.

-U is the same as --apt-upgrade. You can see the exact commandline that
was run near the top of the log file - so yes, it's there.

Cheers,

--
Iain Lane                                  [ [hidden email] ]
Debian Developer                                   [ [hidden email] ]
Ubuntu Developer                                   [ [hidden email] ]

--
ubuntu-devel mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel

signature.asc (817 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: "testbed out of date"

Rik Mills-2
In reply to this post by Andreas Hasenack-5
On 07/12/17 15:59, Andreas Hasenack wrote:

> Hi,
>
> I'm getting this error a lot in some test runs
> (like https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-artful/artful/s390x/f/firejail/20171207_130707_4ca6a@/log.gz):
>
> autopkgtest [13:07:06]: ERROR: erroneous package: Test dependencies are unsatisfiable. A common reason is that your testbed is out of date with respect to the archive, and you need to use a current testbed or run apt-get update or use -U.
> blame: firejail
> badpkg: Test dependencies are unsatisfiable. A common reason is that your testbed is out of date with respect to the archive, and you need to use a current testbed or run apt-get update or use -U.
>
>
> Can someone confirm if the testbed is prepared with -U so that apt-get
> update runs? I don't think I can control that from the package's
> d/t/control file.
>
> Not saying that's the problem, I'm still investigating, but I wanted to
> see if I can rule that (lack of -U) out.
>
> Thanks
>
>
>


The logs says there that the suite dependencies are not satisfiable as
it requires thunderbird:s390x, which does not build on s390x:

https://launchpad.net/ubuntu/+source/thunderbird/1:52.4.0+build1-0ubuntu2

--
ubuntu-devel mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel
Reply | Threaded
Open this post in threaded view
|

Re: "testbed out of date"

Andreas Hasenack-5
In reply to this post by Iain Lane-6
On Thu, Dec 7, 2017 at 2:16 PM, Iain Lane <[hidden email]> wrote:
It's a test which started to run when we got isolation-machine on s390x.
All of the tests were skipped before. I think this could be
force-badtested, and I've added that for you.


Thanks
 
> Can someone confirm if the testbed is prepared with -U so that apt-get
> update runs? I don't think I can control that from the package's
> d/t/control file.

-U is the same as --apt-upgrade. You can see the exact commandline that
was run near the top of the log file - so yes, it's there.


Thanks


--
ubuntu-devel mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel