ubuntu12.04 upgrade issue: xterm Warning: couldn't find charset data for locale true; using ISO 8859-1.

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

ubuntu12.04 upgrade issue: xterm Warning: couldn't find charset data for locale true; using ISO 8859-1.

ping
guys/folks/experts:
this is my 1st post on ubuntu user group...

I yesterday just upgraded to ubntu12.04 from 10.04, after 2 and half years usage as my only work platform.
It seems I don't have to but, since I need to do it sooner or later anyway, plus I have need to install some packages that looks only easily available in the new LTS, I wanted to give it a trial...

the way I upgrade my system is, ssh into it and simply just "do-release-upgrade".

I did see a lot of errors during the long time upgrade procedures, but finally it end up not bad.

here is one annoying issues I got , it actually appears for every package installations:





ping@640g-laptop:~$ sudo apt-get install xtermcontrol
Reading package lists... Done
Building dependency tree      
Reading state information... Done
The following packages were automatically installed and are no longer required:
  aisleriot gnome-mag vinagre gnome-utils libgail-gnome-module gnome-orca pulseaudio-esound-compat at-spi install-package gdebi-kde
  quadrapassel
Use 'apt-get autoremove' to remove them.
The following NEW packages will be installed:
  xtermcontrol
0 upgraded, 1 newly installed, 0 to remove and 439 not upgraded.
2 not fully installed or removed.
Need to get 34.5kB of archives.
After this operation, 102kB of additional disk space will be used.
Get:1 http://us.archive.ubuntu.com/ubuntu/ precise/universe xtermcontrol 2.10-1 [34.5kB]
Fetched 34.5kB in 0s (314kB/s)     
dpkg: warning: parsing file '/var/lib/dpkg/available' near line 27775 package 'linuxqq:i386':
 error in Version string 'v1.0.2-beta1': version number does not start with digit
dpkg: warning: parsing file '/var/lib/dpkg/available' near line 34031 package 'spoonwep-spoonwpa:i386':
 error in Version string 'BT3': version number does not start with digit
Selecting previously unselected package xtermcontrol.
(Reading database ... 726861 files and directories currently installed.)
Unpacking xtermcontrol (from .../xtermcontrol_2.10-1_amd64.deb) ...
Processing triggers for man-db ...
Setting up samba4 (4.0.0~alpha18.dfsg1-4ubuntu2) ...
Unknown parameter encountered: "max log size"
Ignoring unknown parameter "max log size"
Unknown parameter encountered: "syslog"
Ignoring unknown parameter "syslog"
Unknown parameter encountered: "unix password sync"
Ignoring unknown parameter "unix password sync"
Unknown parameter encountered: "passwd program"
Ignoring unknown parameter "passwd program"
Unknown parameter encountered: "pam password change"
Ignoring unknown parameter "pam password change"
Unknown parameter encountered: "map to guest"
Ignoring unknown parameter "map to guest"
Unknown parameter encountered: "usershare allow guests"
Ignoring unknown parameter "usershare allow guests"
Unknown parameter encountered: "guest ok"
Ignoring unknown parameter "guest ok"
Unknown parameter encountered: "guest ok"
Ignoring unknown parameter "guest ok"
Unknown parameter encountered: "max log size"
Ignoring unknown parameter "max log size"
Unknown parameter encountered: "syslog"
Ignoring unknown parameter "syslog"
Unknown parameter encountered: "unix password sync"
Ignoring unknown parameter "unix password sync"
Unknown parameter encountered: "passwd program"
Ignoring unknown parameter "passwd program"
Unknown parameter encountered: "pam password change"
Ignoring unknown parameter "pam password change"
Unknown parameter encountered: "map to guest"
Ignoring unknown parameter "map to guest"
Unknown parameter encountered: "usershare allow guests"
Ignoring unknown parameter "usershare allow guests"
Unknown parameter encountered: "guest ok"
Ignoring unknown parameter "guest ok"
Unknown parameter encountered: "guest ok"
Ignoring unknown parameter "guest ok"
/var/lib/dpkg/info/samba4.postinst: line 14: /usr/share/samba/setoption.pl: Permission denied
dpkg: error processing samba4 (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up zoneminder (1.25.0-1) ...
Stopping ZoneMinder: DBD::mysql::st execute failed: Table 'zm.Logs' doesn't exist at /usr/share/perl5/ZoneMinder/Logger.pm line 609.
Zoneminder already stopped


Initiating database upgrade to version 1.25.0 from version 1.24.2

Upgrading database to version 1.25.0
Loading config from DB
Saving config to DB

Database successfully upgraded from version 1.24.2.

Database successfully upgraded from version 1.24.3.

Converting filters from PHP to JSON format
  PurgeWhenFull - failed, please check or report. Query is '{"sort_field":"Id","terms":[{"val":0,"attr":"Archived","op":"="},{"cnj":"and","val":95,"attr":"DiskPercent","op":">="}],"limit":5,"sort_asc":1}'
ERROR: Unknown type {. at /usr/bin/zmupdate.pl line 930
Conversion complete
ERROR 1142 (42000) at line 10: CREATE command denied to user 'zmuser'@'localhost' for table 'Logs'
Output:
Command 'mysql -hlocalhost -uzmuser -pzmpass zm < /usr/share/zoneminder/db/zm_update-1.24.4.sql' exited with status: 1
dpkg: error processing zoneminder (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up xtermcontrol (2.10-1) ...
Errors were encountered while processing:
 samba4
 zoneminder
E: Sub-process /usr/bin/dpkg returned an error code (1)



my question is , how to stop these things from popping up everytime?
dpkg: warning: parsing file '/var/lib/dpkg/available' near line 27775 package 'linuxqq:i386':
 error in Version string 'v1.0.2-beta1': version number does not start with digit
dpkg: warning: parsing file '/var/lib/dpkg/available' near line 34031 package 'spoonwep-spoonwpa:i386':
 error in Version string 'BT3': version number does not start with digit



Errors were encountered while processing:
 samba4
 zoneminder





--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: ubuntu12.04 upgrade issue: constant apt-get installation errors

ping
correction the email subject, that's another issue that I'm reporting...

On 09/19/2012 04:31 PM, ping wrote:

> guys/folks/experts:
> this is my 1st post on ubuntu user group...
>
> I yesterday just upgraded to ubntu12.04 from 10.04, after 2 and half
> years usage as my only work platform.
> It seems I don't have to but, since I need to do it sooner or later
> anyway, plus I have need to install some packages that looks only easily
> available in the new LTS, I wanted to give it a trial...
>
> the way I upgrade my system is, ssh into it and simply just
> "do-release-upgrade".
>
> I did see a lot of errors during the long time upgrade procedures, but
> finally it end up not bad.
>
> here is one annoying issues I got , it actually appears for every
> package installations:
>
>
>
>
>
> ping@640g-laptop:~$ sudo apt-get install xtermcontrol
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> The following packages were automatically installed and are no longer
> required:
>    aisleriot gnome-mag vinagre gnome-utils libgail-gnome-module
> gnome-orca pulseaudio-esound-compat at-spi install-package gdebi-kde
>    quadrapassel
> Use 'apt-get autoremove' to remove them.
> The following NEW packages will be installed:
>    xtermcontrol
> 0 upgraded, 1 newly installed, 0 to remove and 439 not upgraded.
> 2 not fully installed or removed.
> Need to get 34.5kB of archives.
> After this operation, 102kB of additional disk space will be used.
> Get:1 http://us.archive.ubuntu.com/ubuntu/ precise/universe xtermcontrol
> 2.10-1 [34.5kB]
> Fetched 34.5kB in 0s (314kB/s)
> dpkg: warning: parsing file '/var/lib/dpkg/available' near line 27775
> package 'linuxqq:i386':
>   error in Version string 'v1.0.2-beta1': version number does not start
> with digit
> dpkg: warning: parsing file '/var/lib/dpkg/available' near line 34031
> package 'spoonwep-spoonwpa:i386':
>   error in Version string 'BT3': version number does not start with digit
> Selecting previously unselected package xtermcontrol.
> (Reading database ... 726861 files and directories currently installed.)
> Unpacking xtermcontrol (from .../xtermcontrol_2.10-1_amd64.deb) ...
> Processing triggers for man-db ...
> Setting up samba4 (4.0.0~alpha18.dfsg1-4ubuntu2) ...
> Unknown parameter encountered: "max log size"
> Ignoring unknown parameter "max log size"
> Unknown parameter encountered: "syslog"
> Ignoring unknown parameter "syslog"
> Unknown parameter encountered: "unix password sync"
> Ignoring unknown parameter "unix password sync"
> Unknown parameter encountered: "passwd program"
> Ignoring unknown parameter "passwd program"
> Unknown parameter encountered: "pam password change"
> Ignoring unknown parameter "pam password change"
> Unknown parameter encountered: "map to guest"
> Ignoring unknown parameter "map to guest"
> Unknown parameter encountered: "usershare allow guests"
> Ignoring unknown parameter "usershare allow guests"
> Unknown parameter encountered: "guest ok"
> Ignoring unknown parameter "guest ok"
> Unknown parameter encountered: "guest ok"
> Ignoring unknown parameter "guest ok"
> Unknown parameter encountered: "max log size"
> Ignoring unknown parameter "max log size"
> Unknown parameter encountered: "syslog"
> Ignoring unknown parameter "syslog"
> Unknown parameter encountered: "unix password sync"
> Ignoring unknown parameter "unix password sync"
> Unknown parameter encountered: "passwd program"
> Ignoring unknown parameter "passwd program"
> Unknown parameter encountered: "pam password change"
> Ignoring unknown parameter "pam password change"
> Unknown parameter encountered: "map to guest"
> Ignoring unknown parameter "map to guest"
> Unknown parameter encountered: "usershare allow guests"
> Ignoring unknown parameter "usershare allow guests"
> Unknown parameter encountered: "guest ok"
> Ignoring unknown parameter "guest ok"
> Unknown parameter encountered: "guest ok"
> Ignoring unknown parameter "guest ok"
> /var/lib/dpkg/info/samba4.postinst: line 14:
> /usr/share/samba/setoption.pl: Permission denied
> dpkg: error processing samba4 (--configure):
>   subprocess installed post-installation script returned error exit status 1
> Setting up zoneminder (1.25.0-1) ...
> Stopping ZoneMinder: DBD::mysql::st execute failed: Table 'zm.Logs'
> doesn't exist at /usr/share/perl5/ZoneMinder/Logger.pm line 609.
> Zoneminder already stopped
>
>
> Initiating database upgrade to version 1.25.0 from version 1.24.2
>
> Upgrading database to version 1.25.0
> Loading config from DB
> Saving config to DB
>
> Database successfully upgraded from version 1.24.2.
>
> Database successfully upgraded from version 1.24.3.
>
> Converting filters from PHP to JSON format
>    PurgeWhenFull - failed, please check or report. Query is
> '{"sort_field":"Id","terms":[{"val":0,"attr":"Archived","op":"="},{"cnj":"and","val":95,"attr":"DiskPercent","op":">="}],"limit":5,"sort_asc":1}'
> ERROR: Unknown type {. at /usr/bin/zmupdate.pl line 930
> Conversion complete
> ERROR 1142 (42000) at line 10: CREATE command denied to user
> 'zmuser'@'localhost' for table 'Logs'
> Output:
> Command 'mysql -hlocalhost -uzmuser -pzmpass zm <
> /usr/share/zoneminder/db/zm_update-1.24.4.sql' exited with status: 1
> dpkg: error processing zoneminder (--configure):
>   subprocess installed post-installation script returned error exit status 1
> Setting up xtermcontrol (2.10-1) ...
> Errors were encountered while processing:
>   samba4
>   zoneminder
> E: Sub-process /usr/bin/dpkg returned an error code (1)
>
>
>
> my question is , how to stop these things from popping up everytime?
> dpkg: warning: parsing file '/var/lib/dpkg/available' near line 27775
> package 'linuxqq:i386':
>   error in Version string 'v1.0.2-beta1': version number does not start
> with digit
> dpkg: warning: parsing file '/var/lib/dpkg/available' near line 34031
> package 'spoonwep-spoonwpa:i386':
>   error in Version string 'BT3': version number does not start with digit
>
>
> Errors were encountered while processing:
>   samba4
>   zoneminder
>
>
>

--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: ubuntu12.04 upgrade issue: xterm Warning: couldn't find charset data for locale true; using ISO 8859-1.

ping
In reply to this post by ping
I'm a (basically) happy xterm user, but 1st thing I met after upgraded
to 12.04, I found that my xterm can't display Chinese. here is the info
I got, hope to get some help from experts here:

//logs when launching xterm:
ping@640g-laptop:~$ xterm
Warning: Color name "#1c5572 " is not defined
Warning: Cannot convert string "true " to type Boolean
Warning: Cannot convert string "true " to type Boolean
Warning: Cannot convert string "true " to type Boolean
Warning: Cannot convert string "true " to type Boolean
Warning: Color name "white " is not defined


//in the launched windows there is a warn:
Warning: couldn't find charset data for locale true; using ISO 8859-1.


//my .Xresources file
! English font
xterm*faceName: DejaVu Sans Mono:antialias=True:pixelsize=14
! Chinese font
xterm*faceNameDoublesize: WenQuanYi Micro Hei:pixelsize=14
!
Xft.dpi:96

xpdf.title: PDF

XTerm*locale: true
XTerm*utf8Title: true
XTerm*fontMenu*fontdefault*Label: Default
XTerm*faceName: Lucida Console
XTerm*faceNameDoublesize: LiHei Pro
XTerm*faceSize: 10
XTerm*faceSize1: 10
XTerm*faceSize2: 10
XTerm*faceSize3: 10
XTerm*faceSize4: 10
XTerm*faceSize5: 10
XTerm*faceSize6: 10
XTerm.cjkWidth:true
XTerm*background: #1c5572
XTerm*foreground: white
XTerm*scrollBar: true
XTerm*rightScrollBar: true
XTerm*jumpScroll:  true
XTerm*SaveLines: 1000
~
~
~
~
~
~
~
~
~
~


--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: ubuntu12.04 upgrade issue: xterm Warning: couldn't find charset data for locale true; using ISO 8859-1.

ping


On 09/21/2012 06:28 PM, [hidden email] wrote:

> On Wednesday, September 19, 2012 4:38:04 PM UTC-4, ping wrote:
>> to 12.04, I found that my xterm can't display Chinese. here is the info
> ...
>> //in the launched windows there is a warn:
>>
>> Warning: couldn't find charset data for locale true; using ISO 8859-1.
>
> The warning is from luit.  I have a recent bug-report which I expect
> to fix after the current xterm changes.
>
>

thanks! sorry I just see that.
can you provide more details about the workaround/fix?


--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: ubuntu12.04 upgrade issue: xterm Warning: couldn't find charset data for locale true; using ISO 8859-1.

ping

On 10/03/2012 02:11 PM, ping wrote:
>
 >
 > On 09/21/2012 06:28 PM, [hidden email] wrote:
 >> On Wednesday, September 19, 2012 4:38:04 PM UTC-4, ping wrote:
 >>> to 12.04, I found that my xterm can't display Chinese. here is the info
 >> ...
 >>> //in the launched windows there is a warn:
 >>>
 >>> Warning: couldn't find charset data for locale true; using ISO 8859-1.
 >>
 >> The warning is from luit. I have a recent bug-report which I expect
 >> to fix after the current xterm changes.
 >>
 >>
 >
 > thanks! sorry I just see that.
 > can you provide more details about the workaround/fix?
 >

I still have the warning and no CJK support...
anyone please help suggesting anything to remove this show-stopper for
me?

     Warning: couldn't find charset data for locale true; using ISO 8859-1.
     ping@640g-laptop:~

thanks!

regards


--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
Reply | Threaded
Open this post in threaded view
|

Re: ubuntu12.04 upgrade issue: xterm Warning: couldn't find charset data for locale true; using ISO 8859-1.

Thomas Dickey
On Thu, Dec 20, 2012 at 03:59:28PM -0500, ping wrote:

>
> On 10/03/2012 02:11 PM, ping wrote:
> >
> >
> > On 09/21/2012 06:28 PM, [hidden email] wrote:
> >> On Wednesday, September 19, 2012 4:38:04 PM UTC-4, ping wrote:
> >>> to 12.04, I found that my xterm can't display Chinese. here is the info
> >> ...
> >>> //in the launched windows there is a warn:
> >>>
> >>> Warning: couldn't find charset data for locale true; using ISO 8859-1.
> >>
> >> The warning is from luit. I have a recent bug-report which I expect
> >> to fix after the current xterm changes.
> >>
> >>
> >
> > thanks! sorry I just see that.
> > can you provide more details about the workaround/fix?
> >
>
> I still have the warning and no CJK support...
> anyone please help suggesting anything to remove this show-stopper for
> me?
>
>     Warning: couldn't find charset data for locale true; using ISO 8859-1.
>     ping@640g-laptop:~
hmm - I can do some investigation to advise you, but it would help if I knew
exactly which locale you are using - so that I can remove it later(*).

If you have xfonts-encodings installed, luit "should" handle some
encodings; it relies on those datafiles.

* (I've been keeping my Ubuntu systems in their original lobtomized locale
   configuration for testing, and don't want to install all locales because
   fixing the configuration interferes with other bug reports).

--
Thomas E. Dickey <[hidden email]>
http://invisible-island.net
ftp://invisible-island.net

--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users

signature.asc (205 bytes) Download Attachment