upgrade from PHP 7.4 to 8.0 failing

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

upgrade from PHP 7.4 to 8.0 failing

Noah Garrett Wallach-5
Hi there,

It looks like apache2 is not doing well after the upgrade from PHP 7.4
to 8.0.  Any advice to fix this is welcome.


❯ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=20.04
DISTRIB_CODENAME=focal
DISTRIB_DESCRIPTION="Ubuntu 20.04.1 LTS"


apache systemctl message

Jan 18 01:40:29 nuc2 apachectl[2922]: apache2: Syntax error on line 146
of /etc/apache2/apache2.conf: Syntax error on line 3 of
/etc/apache2/mods-enabled/php7.4.load: Cannot load
/usr/lib/apache2/modules/libphp7.4.so into server:
/usr/lib/apache2/modules/libphp7.4.so: cannot open shared object file:
No such file or directory


❯ sudo apt list --installed | grep apache

WARNING: apt does not have a stable CLI interface. Use with caution in
scripts.

apache2-bin/focal-updates,focal-security,now 2.4.41-4ubuntu3.1 amd64
[installed,automatic]
apache2-data/focal-updates,focal-security,now 2.4.41-4ubuntu3.1 all
[installed,automatic]
apache2-utils/focal-updates,focal-security,now 2.4.41-4ubuntu3.1 amd64
[installed,automatic]
apache2/focal-updates,focal-security,now 2.4.41-4ubuntu3.1 amd64
[installed,automatic]
libapache2-mod-php8.0/focal,now 8.0.1-1+ubuntu20.04.1+deb.sury.org+1
amd64 [installed,automatic]
libapache2-mod-php/focal,now 2:8.0+80~exp2+ubuntu20.04.1+deb.sury.org+1
all [installed]

❯ sudo apt list --installed | grep php

WARNING: apt does not have a stable CLI interface. Use with caution in
scripts.

libapache2-mod-php8.0/focal,now 8.0.1-1+ubuntu20.04.1+deb.sury.org+1
amd64 [installed,automatic]
libapache2-mod-php/focal,now 2:8.0+80~exp2+ubuntu20.04.1+deb.sury.org+1
all [installed]
php-bz2/focal,now 2:8.0+80~exp2+ubuntu20.04.1+deb.sury.org+1 all
[installed,automatic]
php-common/focal,now 2:80~exp2+ubuntu20.04.1+deb.sury.org+1 all
[installed,automatic]
php-composer-ca-bundle/focal,now 1.2.6-1 all [installed,automatic]
php-composer-semver/focal,now 1.5.1-1 all [installed,automatic]
php-composer-spdx-licenses/focal,now 1.5.3-1 all [installed,automatic]
php-composer-xdebug-handler/focal,now 1.4.0-1 all [installed,automatic]
php-curl/focal,now 2:8.0+80~exp2+ubuntu20.04.1+deb.sury.org+1 all
[installed,automatic]
php-gd/focal,now 2:8.0+80~exp2+ubuntu20.04.1+deb.sury.org+1 all
[installed,automatic]
php-google-recaptcha/focal,now 1.2.3-1 all [installed,automatic]
php-json-schema/focal,now 5.2.9-1 all [installed,automatic]
php-mbstring/focal,now 2:8.0+80~exp2+ubuntu20.04.1+deb.sury.org+1 all
[installed,automatic]
php-mysql/focal,now 2:8.0+80~exp2+ubuntu20.04.1+deb.sury.org+1 all
[installed,automatic]
php-phpmyadmin-motranslator/focal,now 5.0.0-1 all [installed,automatic]
php-phpmyadmin-shapefile/focal,now 2.1-3 all [installed,automatic]
php-phpmyadmin-sql-parser/focal,now 4.6.1-2 all [installed,automatic]
php-phpseclib/focal,now 2.0.23-2 all [installed,automatic]
php-psr-cache/focal,now 1.0.1-2 all [installed,automatic]
php-psr-container/focal,now 1.0.0-2 all [installed,automatic]
php-psr-log/focal,now 1.1.2-1 all [installed,automatic]
php-symfony-cache-contracts/focal,now 1.1.8-1 all [installed,automatic]
php-symfony-cache/focal,now 4.3.8+dfsg-1ubuntu1 all [installed,automatic]
php-symfony-console/focal,now 4.3.8+dfsg-1ubuntu1 all [installed,automatic]
php-symfony-expression-language/focal,now 4.3.8+dfsg-1ubuntu1 all
[installed,automatic]
php-symfony-filesystem/focal,now 4.3.8+dfsg-1ubuntu1 all
[installed,automatic]
php-symfony-finder/focal,now 4.3.8+dfsg-1ubuntu1 all [installed,automatic]
php-symfony-process/focal,now 4.3.8+dfsg-1ubuntu1 all [installed,automatic]
php-symfony-service-contracts/focal,now 1.1.8-1 all [installed,automatic]
php-symfony-var-exporter/focal,now 4.3.8+dfsg-1ubuntu1 all
[installed,automatic]
php-tcpdf/focal,now 6.3.5+dfsg1-1 all [installed,automatic]
php-twig-extensions/focal,now 1.5.4-1 all [installed,automatic]
php-twig/focal,now 2.12.5-1 all [installed,automatic]
php-xml/focal,now 2:8.0+80~exp2+ubuntu20.04.1+deb.sury.org+1 all
[installed,automatic]
php-zip/focal,now 2:8.0+80~exp2+ubuntu20.04.1+deb.sury.org+1 all
[installed,automatic]
php7.0-cgi/focal,now 7.0.33-38+ubuntu20.04.1+deb.sury.org+1 amd64
[installed]
php7.0-cli/focal,now 7.0.33-38+ubuntu20.04.1+deb.sury.org+1 amd64
[installed,automatic]
php7.0-common/focal,now 7.0.33-38+ubuntu20.04.1+deb.sury.org+1 amd64
[installed]
php7.0-curl/focal,now 7.0.33-38+ubuntu20.04.1+deb.sury.org+1 amd64
[installed]
php7.0-gd/focal,now 7.0.33-38+ubuntu20.04.1+deb.sury.org+1 amd64 [installed]
php7.0-json/focal,now 7.0.33-38+ubuntu20.04.1+deb.sury.org+1 amd64
[installed]
php7.0-mbstring/focal,now 7.0.33-38+ubuntu20.04.1+deb.sury.org+1 amd64
[installed]
php7.0-mcrypt/focal,now 7.0.33-38+ubuntu20.04.1+deb.sury.org+1 amd64
[installed]
php7.0-mysql/focal,now 7.0.33-38+ubuntu20.04.1+deb.sury.org+1 amd64
[installed]
php7.0-opcache/focal,now 7.0.33-38+ubuntu20.04.1+deb.sury.org+1 amd64
[installed,automatic]
php7.0-readline/focal,now 7.0.33-38+ubuntu20.04.1+deb.sury.org+1 amd64
[installed,automatic]
php7.0-soap/focal,now 7.0.33-38+ubuntu20.04.1+deb.sury.org+1 amd64
[installed]
php7.0-xml/focal,now 7.0.33-38+ubuntu20.04.1+deb.sury.org+1 amd64
[installed]
php7.0-xmlrpc/focal,now 7.0.33-38+ubuntu20.04.1+deb.sury.org+1 amd64
[installed]
php7.0/focal,now 7.0.33-38+ubuntu20.04.1+deb.sury.org+1 all [installed]
php7.4-bz2/focal,now 7.4.14-1+ubuntu20.04.1+deb.sury.org+1 amd64
[installed,automatic]
php7.4-cli/focal,now 7.4.14-1+ubuntu20.04.1+deb.sury.org+1 amd64 [installed]
php7.4-common/focal,now 7.4.14-1+ubuntu20.04.1+deb.sury.org+1 amd64
[installed,automatic]
php7.4-curl/focal,now 7.4.14-1+ubuntu20.04.1+deb.sury.org+1 amd64
[installed]
php7.4-fpm/focal,now 7.4.14-1+ubuntu20.04.1+deb.sury.org+1 amd64 [installed]
php7.4-gd/focal,now 7.4.14-1+ubuntu20.04.1+deb.sury.org+1 amd64 [installed]
php7.4-json/focal,now 7.4.14-1+ubuntu20.04.1+deb.sury.org+1 amd64
[installed]
php7.4-mbstring/focal,now 7.4.14-1+ubuntu20.04.1+deb.sury.org+1 amd64
[installed]
php7.4-mysql/focal,now 7.4.14-1+ubuntu20.04.1+deb.sury.org+1 amd64
[installed]
php7.4-opcache/focal,now 7.4.14-1+ubuntu20.04.1+deb.sury.org+1 amd64
[installed,automatic]
php7.4-readline/focal,now 7.4.14-1+ubuntu20.04.1+deb.sury.org+1 amd64
[installed,automatic]
php7.4-snmp/focal,now 7.4.14-1+ubuntu20.04.1+deb.sury.org+1 amd64
[installed]
php7.4-xml/focal,now 7.4.14-1+ubuntu20.04.1+deb.sury.org+1 amd64 [installed]
php7.4-zip/focal,now 7.4.14-1+ubuntu20.04.1+deb.sury.org+1 amd64 [installed]
php7.4/focal,now 7.4.14-1+ubuntu20.04.1+deb.sury.org+1 all
[installed,automatic]
php8.0-bz2/focal,now 8.0.1-1+ubuntu20.04.1+deb.sury.org+1 amd64
[installed,automatic]
php8.0-cli/focal,now 8.0.1-1+ubuntu20.04.1+deb.sury.org+1 amd64
[installed,automatic]
php8.0-common/focal,now 8.0.1-1+ubuntu20.04.1+deb.sury.org+1 amd64
[installed,automatic]
php8.0-curl/focal,now 8.0.1-1+ubuntu20.04.1+deb.sury.org+1 amd64
[installed,automatic]
php8.0-gd/focal,now 8.0.1-1+ubuntu20.04.1+deb.sury.org+1 amd64
[installed,automatic]
php8.0-mbstring/focal,now 8.0.1-1+ubuntu20.04.1+deb.sury.org+1 amd64
[installed,automatic]
php8.0-mysql/focal,now 8.0.1-1+ubuntu20.04.1+deb.sury.org+1 amd64
[installed,automatic]
php8.0-opcache/focal,now 8.0.1-1+ubuntu20.04.1+deb.sury.org+1 amd64
[installed,automatic]
php8.0-readline/focal,now 8.0.1-1+ubuntu20.04.1+deb.sury.org+1 amd64
[installed,automatic]
php8.0-xml/focal,now 8.0.1-1+ubuntu20.04.1+deb.sury.org+1 amd64
[installed,automatic]
php8.0-zip/focal,now 8.0.1-1+ubuntu20.04.1+deb.sury.org+1 amd64
[installed,automatic]
php8.0/focal,now 8.0.1-1+ubuntu20.04.1+deb.sury.org+1 all
[installed,automatic]
php/focal,now 2:8.0+80~exp2+ubuntu20.04.1+deb.sury.org+1 all
[installed,automatic]
phpmyadmin/focal,now 4:4.9.5+dfsg1-2 all [installed]



--
ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users